1. oshiha's Avatar
    I recently bought a Blackberry Torch 9800 very good condition + box on kijiji. When I got home, I put my simcard in and instead of saying "Insert Sim card", it read SOS beside the reception area. It's not my sim as I tried every carrier sim card. I stuck paper with the simcard in the simcard tray ( to push the simcard onto the pins ), but that didn't work. I also checked if its unlocked and whatnot, and it says it is. I also tried updating my phone to the new .534 but that didn't work.

    I have googled this for many days and tried every solution.
    Does anyone know how to fix this?
    04-20-11 01:25 AM
  2. saudadeii's Avatar
    Did you try the "call your carrier" solution?
    04-20-11 09:52 AM
  3. tbrenn's Avatar
    Chances are the device is not unlocked, or was not unlocked properly, or it is a faluty/in active SIM card. You need to ensure that you have a blackberry specific data plan.

    There was a previous thread where someone thought if the device was unlocked, as long as they put in any sim card, they would have unlimited use....

    Unlocking the device meerly means you can migrate to a different carrier than that who supplied the device. You still need an active account / sim card.


    OP- can you goto 'options', 'device info', 'advance system settings', and then 'sim card'

    Once on that screen, type 'mepd' (without quotations). This will expand your sim screen.

    Tell us all the info there, to see if it is actually unlocked...

    Posted from my CrackBerry at wapforums.crackberry.com
    04-20-11 10:59 AM
  4. oshiha's Avatar
    Before I used the torch, I had a Blackberry social plan using a unlocked bell Blackberry 9700. My simcard is Rogers.

    Heres what the sim card menu shows up as :
    Personalization:
    SIMdisabled
    NetworkDisabled
    Network SubsetDisabled
    Service ProviderDisabled
    CorporateDisabled
    04-20-11 08:36 PM
  5. tbrenn's Avatar
    Head into the rogers store and get a new sim. You might want to call them first, and make sure your device's IMEI is accurate with yourr account. Although most of the time dropping your sim into another device works fine, sometimes the IMEI is good for your carrier to have on file...

    Posted from my CrackBerry at wapforums.crackberry.com
    04-20-11 08:38 PM
  6. oshiha's Avatar
    I found out what the problem is.

    The dumb person who had this phone before thought it would be funny to pluck out 3/6 copper pins where they are suppose to read the simcard. Guess I got screwed over.

    Thanks for your guys help.
    04-21-11 01:10 AM
  7. ste1164's Avatar
    Pretend like you don't know and ask the person where they got the phone. Then take it to the place of retail and say your sim isn't being recognised. They should replace the phone.
    04-21-11 05:54 AM
  8. sassystars's Avatar
    i have a issue with my torch i bought it onlin off kijiji and the slips are there but isnt reading my sim card ....... its unlocked and all says disabled what does this mean ? what do i do know
    08-17-12 04:50 PM
  9. Amir amirmiusa's Avatar
    i have the same problem . if you bought the phone on the street it wont work even if it was unlocked . because it is a reported device and it wont work all over the country. you may sale it to out side the country or exchange it with some body on line to out side the country
    01-07-13 05:52 PM
  10. kylieeserena's Avatar
    ive followed the steps for my sim card and it reads

    sim: disabled
    Network: active
    network subset: disabled
    Service provider: disabled
    Corporate: disabled
    06-01-13 02:11 PM
  11. Anna Lamburth's Avatar
    ive typed in mepd and it says this, sim:disabled network:active network substet:disabled
    service provider:disabled
    corporate:disabled
    what does this mean?
    10-13-13 12:30 PM
  12. saudadeii's Avatar
    It means you're still locked to the original provider.
    10-13-13 08:51 PM
  13. pcguy514's Avatar
    It means you're still locked to the original provider.
    You sure? I unlocked a 85xx this week and Disabled meant Unlocked...
    10-18-13 07:31 PM
  14. saudadeii's Avatar
    It says Network:Active
    10-20-13 09:27 PM
  15. Alvaro Bermudez's Avatar
    I had the typical problem of not recognition of the SIM CARD and solve it. The problem was that after too many times sliding the SIM CARD the slot have a deformation and the connection pins are flat. First of all I push back the silver slot to the original shape by pressing with care the upper border but the most important thing to do is work with a needle very thin to push up the pins one by one many times. Try with the thinner needle you have and take your time. Each pin is located a millimeter before the 6 holes in the upper part of the silver slot.
    11-26-13 12:03 PM
LINK TO POST COPIED TO CLIPBOARD