1. Redcollor's Avatar
    I have looked at all of the past posts pertaining to sim cards not being recognized but have yet to find any solutions for issues I am having with my ATT Torch. I want to use it on the Bell network and when I type MEPD I get the following

    Sim: Disabled
    Network: Disabled
    Network Subset: Disabled
    Service Provider: Disabled
    Corporate: Disabled.

    However the phone will not recognize any sim cards. Also when i type in MEP2 nothing happens! I am very confused by this and was even more surprised when a representative form the Bell store told me that the phone was NOT-unlocked even though I showed him that everything was disabled.

    I could really use some help with this. I have unlocked phones in the past and never had a problem before, however this is beyond my Blackberry knowledge. Thank you.
    03-25-11 10:50 PM
  2. gbsn's Avatar
    The phone is already unlocked, all lines say disabled. What message do you get on the top banner of the home screen when you insert a foreign sim card? Is it initialization error?

    Posted from my CrackBerry at wapforums.crackberry.com
    03-25-11 11:09 PM
  3. shansmi's Avatar
    Yes yes, what is the exact message when you insert a SIM?

    Posted from my CrackBerry at wapforums.crackberry.com
    03-25-11 11:43 PM
  4. Redcollor's Avatar
    Hi guys, Thanks for your response. When I insert a sim card, I get a message at the top of the screen to "Insert Sim Card" and next to the signal indicator I have SOS.

    I have tried a Bell and a Rogers sim card and get the exact same result! really frustrated. Thanks.
    03-26-11 07:49 AM
  5. Redcollor's Avatar
    Any suggestions would be appreciated, thanks
    03-26-11 10:17 AM
  6. gbsn's Avatar
    Can you try something easy? Get a tiny piece of paper, and fold it once, making a rectangle a bit smaller than the sim card. What you will do is, insert this little paper and along with the sim card in the slot, so it provides more pressure (don't put it on the side that has the golden layer but between the top and the slot housing).

    It seems like its not reading the sim card at all and it can probably be attributed to a hardware defect.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-26-11 10:47 AM
  7. Redcollor's Avatar
    I will give that a try! Thanks for the suggestion!
    03-26-11 11:08 AM
  8. gbsn's Avatar
    Let me know if it does anything. That sometimes has fixed problems like that, where the sim card just not reads because its not making proper contact, it sometimes comes with an error like "initialization error".

    If it doesn't, then I guess it has a hardware defect, probably one of the metal pins that read the sim card broke off or something. Because if the phone is unlocked, you already tried with two different sim cards and more pressure doesn't solve it, then I would assume the device is broken.

    Posted from my CrackBerry at wapforums.crackberry.com
    Redcollor likes this.
    03-26-11 12:05 PM
  9. Redcollor's Avatar
    The paper idea did not work, thanks for the suggestion thou. Any other suggestions.
    03-26-11 01:16 PM
  10. gbsn's Avatar
    My last user suggestion would be to wipe the device and install the latest os .486 to discar any software corruption, but it is highly unlikely for that to happen and directly affect the sim card module.

    My last diy suggestion is to disassemble the device and check the sim card slot for damage, but I don't think you want to do that. Where did you buy the phone from?

    Posted from my CrackBerry at wapforums.crackberry.com
    03-26-11 01:25 PM
  11. mirra100's Avatar
    May sound a very stupid suggestion, but I swapped sim cards earlier today to get a phone number from a friends sim, and when I put my sim back in, had exactly the same problem as you......was about to wipe the device, and then realised that being a total numpty I had the sim card upside down!!! I know it sounds stupid, but may be worth double checking - the triangular cut out on the sim sould be top left, as per the diagram on the blackberry! My other mobile phone the sim goes in the other way, so I guess an easy mistake to make!

    Hope this is the problem, and easily solved!
    trimchic likes this.
    03-27-11 03:11 PM
  12. Samuel Seijas's Avatar
    Hello, Im new here, I just registered because I have the same problem and need to know if yuo found a solution for this. thanks.
    02-06-13 11:29 AM
  13. amynichola's Avatar
    Did you find a solution to your problem? i have exactly the same problem and are getting serious withdrawal symptoms Lol, if you did if you could let me no would be brilliant.. thankyou
    07-03-13 12:52 PM
  14. Vito Fiorentino's Avatar
    same with me, i have a 9800 wiped it installed a new software and now its says no sim card
    it worked in the past, what could it be?
    07-09-13 01:43 PM
  15. Christina Ibrahim's Avatar
    Did you solve your blackberry torch problem if so how plzzzzzzz let me know because mine is doing the same thing
    08-03-13 07:48 PM
  16. Mach Fiver's Avatar
    I am having the same problem and I have managed to get the phone to scan for networks again. in the main app drawer select manage connections if box is ticked untick it then retick it then go to setup mobile networks and pick "select connection" to manual. If it doesn't work go back and tick untick again. The status should turn from sos to Tx then manually search for networks. I'm in a basement right now that gets no service from time to time so will have to go outside to make sure that the lack of connecting isn't due to that.
    11-07-15 06:10 AM