01-18-14 08:51 PM
36 12
  1. cjsirois's Avatar
    My Torch thinks it has a Trackball. sometimes after restart the trackpad is not working. Touch screen works fine. When the pad is not working i look at the settings and it stays "Trackball". A few battery pulls seems to make it work as a trackpad. When it is working correctly it says "trackpad" in the settings.

    Any Ideas---Thanks
    05-24-11 07:24 AM
  2. homer1475's Avatar
    What setting are you seeing the word "trackball"?
    05-24-11 07:25 AM
  3. cjsirois's Avatar
    In the "Typing and Input" where you set sensitivity. It say "trackball" when not working. "trackpad" when it is.
    05-24-11 07:33 AM
  4. Deathcommand's Avatar
    This happened to me. I know what you are talking about. The picture even changes to a trackball.
    I'm wondering why RIM even put that there if there are no OS6 trackball devices.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-24-11 07:36 AM
  5. homer1475's Avatar
    New one on me. I would have to say somehow the trackpad identifies to the OS? When it doesn't send an identifier the OS believes it's a trackball? I don't know, never heard this one before. I'm with Deathcommand on this one. Why would OS6 even have a trackball option since there are no OS6 devices with a trackball.
    cjsirois likes this.
    05-24-11 07:41 AM
  6. cjsirois's Avatar
    Its really weird. Its happen several times over the last few weeks. I can't seem to pin it to an app. Happened before and after the lastest AT&T OS update. Sometimes one pull fixes it. Sometime several. Slider open or closed. really frustrating.

    Thanks for your input
    05-24-11 07:51 AM
  7. cjsirois's Avatar
    It has done it on three different themes including the default ATandT

    Posted from my CrackBerry at wapforums.crackberry.com
    05-24-11 10:43 AM
  8. tbrenn's Avatar
    i would maybe try another carrier's OS maybe, it the track pad is perodically not responding... you could always try changing the track pad istelf, but an OS reinstall might be easier to attempt first...

    I have not seen this particular sighting of ''trackball'' on the torch, but i did see it when running the device self test.. the ''trackball'' test however, did respond to the track pad...
    cjsirois likes this.
    05-24-11 10:59 AM
  9. cjsirois's Avatar
    It could be that the ribbon that connects the trackpad needs to be reseated.
    Changing OS is not really an option. While the phone is mine the sim belongs to my company and they make it tough to get registered with the BES. Which it should be.
    Thanks everyone for your input.
    05-24-11 07:58 PM
  10. sterling_bandit's Avatar
    Noticed this its annoying

    Posted from my CrackBerry at wapforums.crackberry.com
    05-24-11 08:20 PM
  11. holte45's Avatar
    Any more info about/solutions to this problem? My torch 9800 also thinks the trackpad is a trackball. The net result of which is that the trackpad doesn't do anything. I've done about 10 battery pulls with no success. How can I check the trackpad cable?

    07-04-11 06:14 PM
  12. weezul's Avatar
    this is so crazy.. just started happening to me recently too. I did not check any settings though, just restarted the phone and the trackpad worked again. If it happens again im straight to the settings to see if that's what it was
    07-04-11 06:58 PM
  13. cjsirois's Avatar
    Still having issue. Any new ideas?
    08-12-11 01:58 PM
  14. fabio984's Avatar
    Only the idea of update to the lastest version software.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-13-11 09:33 AM
  15. cjsirois's Avatar
    I have the latest software. This has happened in three different versions. I am now leaning towards hardware. Before I pull the phine apart. Does any one know it the phone will boot without a trackpad installed?
    08-13-11 01:17 PM
  16. Melvin2212's Avatar
    This has happened to me a dozen times and the carrier of my phone is telus ,but the phone is unlocked.I think the best solution for this is to get the latest version of the Os 6 software even if it has to be another carrier's software...
    03-23-12 10:42 PM
  17. BB55506444's Avatar
    Hey guys, I had the same problem the 2nd day I got my Torch.

    although I searched the internet, I couldn't find any lead on how to deal with this problem except to take it to the agent for replacement. However, I decided to make a last attempt: I installed an older OS, actually I think it was the original OS as when the Torch was introduced.

    It works like a magic !

    I think the reason the trackpad stopped working was because the OS installed would treat the trackpad as a ballpad should the system be restarted, why? I have no idea

    Hope this works for you and good luck
    04-10-12 06:11 PM
  18. DariusG1996's Avatar
    It has happened on my BlackBerry Curve 9360 running OS 7! I am BAFFLED!?!?!?!? NO OS 7 would have a trackball??? My Curve 9360 selects/clicks- but doesn't scroll REAAALLLY ANNOYING and it happened under 2 mins of putting the phone in the pouch!!...

    I really need help, has there been any cures for this? It shows 'Trackball Sensitivity' with a picture of a ball with blue arrows, instead of a grey square with blue arrows!!
    05-03-12 04:11 PM
  19. BBIsTheBest's Avatar
    I have the latest software. This has happened in three different versions. I am now leaning towards hardware. Before I pull the phine apart. Does any one know it the phone will boot without a trackpad installed?
    i'm not 100% sure, but i think it should, coz trackpad isn't the primary input device (like a mouse for a pc ), it should boot without it.

    for me the issue sounds like hardware, could be just a loose connection though
    05-05-12 01:30 AM
  20. DariusG1996's Avatar
    Nobody knows? It STILL doesn't work by the way

    Any ideas???..................................

    05-20-12 01:26 PM
  21. Deathcommand's Avatar
    I had this issue with my 9650.
    It says trackball options instead of Trackpad options right?
    I had to replace my Trackpad for this, or just return it. This should be covered in warranty

    Sent from my BlackBerry Bold 9930-
    05-20-12 02:11 PM
  22. hasa77's Avatar
    I have the latest software. This has happened in three different versions. I am now leaning towards hardware. Before I pull the phine apart. Does any one know it the phone will boot without a trackpad installed?
    It WILL boot up without trackpad as mine has before
    05-20-12 06:47 PM
  23. ronnel.gacutana's Avatar
    please check the link below where I even posted a screenshot.

    Weird Issue... - BlackBerry Support Community Forums
    06-04-12 03:34 AM
  24. REDevils's Avatar
    Hello all,

    My BB Touch 9800 is not functioning permanently after update new version. Try to pull out batt but not working. Reset also has been done. No effect... pls help!!!
    10-16-12 01:18 AM
  25. mo_azhar7's Avatar
    hi, i've got the same problem on my 9360 curve. GOT THE SOLUTION YET?
    03-09-13 10:12 AM
36 12