1. j0esmoe13's Avatar
    I received a warranty replacement for my Torch yesterday and can't add gmail (not the app) as an e-mail account. My device is telling me my password is invalid when it is not. I'm not sure if this is a Torch error or not, but I have never had a similar problem on my Bold, Curve, Pearl Flip or Pearl.


    Title should read "(but it isn't!)"
    Last edited by j0esmoe13; 12-02-10 at 09:53 AM.
    12-02-10 09:47 AM
  2. mykey2k's Avatar
    Is it a gmail account or a Google Apps account?

    Whilst you may be answering that, I'll go search my past posts for the answer
    12-02-10 10:05 AM
  3. mykey2k's Avatar
    Try one of these from your Desktop Browser:
    Gmail account:

    Google apps account, you'll have to copy/paste and change as necessary:
    12-02-10 10:08 AM
  4. mikeyg164's Avatar
    I had a similar issue with a gmail account on my friends phone, and it turned out the gmail account had been hi-jacked! So after going through the recovery options, he finally got his account back luckily.
    12-02-10 01:44 PM
  5. jillygurl's Avatar
    hey the same thing is happening to me! I got a replacement torch and my gmail password is invalid, but its not because it's the one I use all the time! aughh so annoying
    12-11-10 09:20 PM
  6. mykey2k's Avatar
    So did you try the link above?
    12-11-10 10:18 PM
  7. Minnimist82's Avatar
    So did you try the link above?
    I had the same problem with my new torch, I went onto my laptop and clicked the above link to unlock something in google and now it works!!

    Posted from my CrackBerry at wapforums.crackberry.com
    12-24-10 03:12 PM
  8. jbs-horn's Avatar
    Make sure your gmail "All Mail" label is checked to be available on IMAP.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-31-11 06:31 PM
  9. EnigmaV8's Avatar
    For anyone who comes across this issue after looking all over the Interwebernets without the real answer, here it is... It's actually Google that isn't trusting the login. You simply have to enable app trusting and connect within 10minutes to add the Blackberry connection. Because this is a newer security setting that is why you didn't have to do this in the past. This is obviously missing from Google's POP and IMAP configuration guides for Crackberries.


    07-17-12 12:44 AM
  10. Gareth Daniels's Avatar
    I went back to an old BlackBerry (9900) temporarily as my newer one (Q10) was in for repair, I had used my Google account on it before and got this problem, took me ages to get to the bottom of it but eventually managed to, as it was such a pain in the back side I decided to sign up and share the solution.

    Quite rightly said before it is a Google being cautious, what you need to do is sign into your Google account and access your 'Account' settings, from certain screens you can find this option when you click on your picture at the top somewhere, the click 'Account', you will then need to navigate to the option under the 'Signing In' heading called 'Access for less secure apps', make sure you ALLOW. Then try again.

    04-23-15 05:50 PM
  11. Deb Eland's Avatar
    THANK YOU this link worked after many failed attempts
    06-04-15 10:58 AM
  12. beanctr10's Avatar
    worked like a champ thanks
    07-14-15 01:50 AM
  13. Siseko Bukani's Avatar
    This sorted my issue.. Thank you
    06-29-16 06:55 AM
  14. saudadeii's Avatar
    I don't like necroposting but this is still worth a bump. The key was turning on "Access for less secure apps" under my main Google account as detailed above.

    Oddly, my 9800 has worked fine until about a week ago when it said my gmail was invalid. None of my other numerous devices had any problem. Repeated attempts to enter my correct pw failed with an invalid password error (very definition of insanity). No number of battery pulls, signin attempts, worked. I even deleted the mail account and tried to recreate. No joy. I was even able to log into Google using the BB Browser.

    Once I flipped the switch on "less secure apps", I was able to create the account in the mail app. I did, then, get the validation message. So now, all appears well. I'm still waiting for the first sync to occur.

    Once again, CB to the rescue.
    08-07-16 11:07 AM