11-02-12 12:14 PM
150 123 ...
tools
  1. IWANTARIMWATCH's Avatar
    So this issue was driving me nuts, and I tried every possible solution posted on this and other forums, with no success. So I came up with one last option... remove my micro-sd memory card. I have a 16gb micro-sd memory card in my Torch, with about 9gb of it being used (photos and videos). Although I never suspected that this was the cause for my problems, sure enough, after I pulled it out and using the phone all day yesterday, I not once had the spinning clock, lagging, or battery drain problem (whereas it would have easily occurred over 20 times in that same duration before). I have on more "experiment" today... and that is to re-insert the micro-sd card, but to disable automatic compression. Let's see what that does... I'll keep you guys posted.
    05-04-11 12:50 PM
  2. branflakes's Avatar
    Thanks for the update. I think we all forget how much a micro-SD card can cause problems.
    05-04-11 12:52 PM
  3. ShoshiOne's Avatar
    Yes, thank you for the update. Please let us know how your Torch is when the micro-sd card is back in and the automatic compression is off. It'll be interesting to see if that helps your problems from before.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-04-11 01:03 PM
  4. slalom's Avatar
    ...I've had the same issues...its unfortunate if that is the fix....
    05-04-11 02:26 PM
  5. cntrydncr223's Avatar
    just curious, what OS are you running?
    05-04-11 03:56 PM
  6. IWANTARIMWATCH's Avatar
    I'm using .534
    05-04-11 04:09 PM
  7. slalom's Avatar
    I was on .534, but am having the same problem now on .546
    05-05-11 09:34 AM
  8. UN4GTBL's Avatar
    Hmm, this is very interesting, my Torch has been slow for the past little while...

    I just turned off the compression option...lets hope this makes it nice and snappy again!
    05-05-11 10:10 AM
  9. cntrydncr223's Avatar
    i had that problem on .526, then changed to .534 and it quit.
    05-05-11 10:25 AM
  10. Elite1's Avatar
    I wonder how using the onboard media storage would differ in effect…

    I only have about 2MB of mostly photos (majority are wallpapers) on my 8GB microSD card, while I have nothing on my 4GB onboard media memory.

    @ IWANTARIMWATCH - Just curious: what class SD card were you using?
    05-05-11 01:07 PM
  11. IWANTARIMWATCH's Avatar
    I am EXTREMELY happy to report that.... after re-inserting my 16gb Micro-SDHC card back into my Torch, and turning the compression OFF, I am not having the spinning clock/lagging/battery drain problem anymore. What a difference it makes! I tested this all day yesterday and wanted enough time to go by before I reported back. I hope this helps a lot of people... I'm sure it will!
    05-05-11 01:17 PM
  12. Sainthak's Avatar
    I am EXTREMELY happy to report that.... after re-inserting my 16gb Micro-SDHC card back into my Torch, and turning the compression OFF, I am not having the spinning clock/lagging/battery drain problem anymore. What a difference it makes! I tested this all day yesterday and wanted enough time to go by before I reported back. I hope this helps a lot of people... I'm sure it will!
    I will double check this on my system too. I also get the running clock about 20x a day, what an annoyance.
    05-05-11 02:24 PM
  13. KiDPaul's Avatar
    Wow who would've thought that this issue could've been easily fixed by turning the Auto Compression off. Great find.
    05-05-11 02:27 PM
  14. anton-k's Avatar
    Yeah, this is kind of odd. I decided to try turning compression off even though I wasn't really having any issues and almost accidentally read this thread. Perhaps it's just a placebo effect, but the phone seems to be super fast now. Is it supposed to make a difference whether you have much on the SD card or not? I think I have one song on it, and that might be it.
    Maloy likes this.
    05-05-11 02:32 PM
  15. anton-k's Avatar
    P.S. When you say Auto Compression, you mean Enable Compression under Options > Device > Storage, right?
    Ozoro and yogi like this.
    05-05-11 02:34 PM
  16. Mrlovkim's Avatar
    P.S. When you say Auto Compression, you mean Enable Compression under Options > Device > Storage, right?
    I believe so, I just did the same and mine seems to be a bit faster but maybe its my imagination.
    05-05-11 03:29 PM
  17. IWANTARIMWATCH's Avatar
    @anton-k... that is correct!
    @Mrlovkim... trust me, it's not your imagination... I've done extensive testing and it was definitely the cause of these problems...at least on my Torch!
    Mrlovkim and slalom like this.
    05-05-11 03:38 PM
  18. slalom's Avatar
    ok...I was about to downgrade, but I'll stay with .546 and see if this fix helps. What do we lose with compression off?
    05-05-11 04:36 PM
  19. IWANTARIMWATCH's Avatar
    So far, I have not lost anything... it's my belief that the "Compression" was originally created not taking into account the larger capacity micro-sd cards. With so much being stored on these micro-sd cards, I believe the Compression is becoming counter-productive as the device constantly tries to compress such info. I think the Compression was probably originally developed more for the on-device memory rather than the micro-sd cards.
    Ozoro and Mrlovkim like this.
    05-05-11 04:48 PM
  20. ICEMAN9's Avatar
    Going to give this a try...I've been experiencing the same thing & have a lot on my Media Card, so lets see what happens...
    05-05-11 07:47 PM
  21. yerindo's Avatar
    Woow! Since I've bought this torch in oct I couldn't make it home with the battery (nomather what os). By turning of the compression, it lasts 2(!!) More hours!

    Thank you

    Posted from my CrackBerry at wapforums.crackberry.com
    05-06-11 01:10 AM
  22. anton-k's Avatar
    Same for me, at the end of today, I had around 70% battery left as opposed to around 50% yesterday. I didn't use it very much today, but that's still a big improvement. And as I mentioned earlier, I don't use the SD card (as far as I know) and only have one song on it and nothing else that I can think of. If these results continue to prove themselves, I vote for this as the best thread ever!
    toolop75 likes this.
    05-06-11 03:10 AM
  23. Kevin.Gladwell's Avatar
    So I have also been having problems with the clock appearing and then also my social feeds taking about 5 seconds to close after I hit the back button to close it, after upgrading to the AT&T release of .526 . After un-clicking the compression option I noticed my optical pad was more responsive, and that when I go into social feeds and close it closes immediately no more waiting. Thanks for the hint. Hope it stays like this, makes me love this phone even more.
    05-06-11 03:38 AM
  24. chrisryan44's Avatar
    I've gotten the spinning clock occasionally lately too... battery has been fine though, but I'll try this and see what happens. In case anyone was wondering what compression does, heres an excerpt from the user guide (I had to look it up because I was curious):
    About compression
    Compression is designed to reduce the size of your BlackBerry device data while maintaining the integrity of that data. When compression is turned on, your device compresses all device data, including messages, contacts, calendar entries, tasks, and memos. You should keep compression turned on.

    If both compression and encryption are turned on, your device compresses device data before encrypting it.
    So like someone said earlier it might be a relic of when BB's had smaller on-board memory/storage. Now we've got plenty of space
    05-06-11 04:41 AM
  25. alvis#CB's Avatar
    so what difference will it make if I will turn e compression off? does it mean that files will take more space? thank you
    05-06-11 09:32 AM
150 123 ...
LINK TO POST COPIED TO CLIPBOARD