06-30-08 10:08 PM
44 12
tools
  1. kasperapd's Avatar
    Rumor has it that this will work to create themes for the 8300 and 8800. For those who have the time and the skills... give it a shot and let us know how it works!!! It also looks like it comes with the ability to modify the Dimension Today theme... this is something that we have been wanting for a long time!

    Plazmic

    Plazmic Content Developer's Kit v4.2.2 for BlackBerry
    The Plazmic Content Developer's Kit™ (CDK) v4.2.2 for BlackBerry is now available for download. Before downloading, please be sure to review the Compatibility, System Requirements and Download Instructions sections below. After installation, be sure to review the Release Notes for the latest news and information on this release.

    Compatibility
    Plazmic Content Developer's Kit v4.2.2 for BlackBerry is compatible with the following software:
    BlackBerry Software v4.2.2 (all networks)
    Note: Themes created in Theme Builder are only supported on BlackBerry devices running BlackBerry software v4.2 or higher.
    System Requirements
    The system requirements are as follows.
    Operating system – Windows 2000 Professional, Windows XP Professional, Windows Vista
    Processor – 750 MHz or faster Pentium III or higher compatible CPU
    RAM - Required: 128 MB. Recommended: 256 MB or more
    Available Hard Disk Space - 200 MB
    Display - Minimum required resolution is 1024 by 768, with millions of colors
    Adobe Acrobat Reader 3.0 (or later) - for viewing documentation in PDF format
    BlackBerry Java™ Development Environment (JDE) v4.2.2
    BlackBerry Device Simulators
    BlackBerry Email and MDS Services Simulator

    Download Instructions
    When you click on the Download the Plazmic Content Developer's Kit v4.2.2 for BlackBerry link below, you will be taken to the software downloads registration form. In order to download the software, you must fill out all required fields on this form. Your download will begin when you click the Next button at the bottom of the page.

    Download the Plazmic Content Developer's Kit v4.2.2 for BlackBerry!
    Download the Release Notes - PDF
    Last edited by kasperapd; 07-21-07 at 06:28 AM.
    07-21-07 06:22 AM
  2. moorken's Avatar
    when i try to convert themes to 4.2.2 i get below error:

    Warning: The following resources could not be included in the theme for reasons explained below:
    banner.svg
    homescreen.svg
    lockscreen.svg

    does somebody know how to solve this?
    converting to 4.2.1 is no problem at all...
    09-29-07 01:33 PM
  3. spacegirl450's Avatar
    I downloaded the new plazmic software but it says it's not compatable with windows vista. on the website it says it is does anybody know how to solve this problem. i really want to make themes for my pearl.
    09-30-07 12:04 AM
  4. pnutbudrcherryberrysanwich's Avatar
    HI, i need lots of help i'm trying real hard to get this right but it doesnt seem to work... i downloaded all three plazmic, jde and the simulater but it keeps saying it can find the jde... what am i doing wrong? ppppllllleeeeeezzzz help!
    11-01-07 12:17 PM
  5. dlnmorrow's Avatar
    I was having the same issue before I became too engrossed in work to keep at it.
    I wonder who has done it w/ all the updated software there is out there.
    Some help!
    11-01-07 01:03 PM
  6. wolfscmb's Avatar
    i'm planning on taking a look at it this weekend ... seems cool enough
    11-01-07 01:06 PM
  7. DearFloyd's Avatar
    On the Plazmic homepage under system requirements, there are three blue links to software that you have to download and install first - one by one, and in order as they are listed, Then you can download the actual program. I assume you guys have done that?
    11-01-07 01:54 PM
  8. lbevel's Avatar
    I have installed everything in order but I get the same error not compatible with windows vista.
    11-17-07 07:12 AM
  9. Bla1ze's Avatar
    I installed everything as well on an XP box, I can't get past the error,

    "rim_net_plasmic_themereader.cod" is not installed, even though I can CLEARLY see it in the folder I am directing it to.
    11-17-07 07:40 PM
  10. Denise23's Avatar
    So it's installed and works -but I have no clue how to use it, is there sort of a 'howto' basics for it anywhere? Or is it all just guess and test?
    01-18-08 04:09 PM
  11. scottjb's Avatar
    There is a user manual comes with it. Have you had a look at it?
    01-18-08 10:25 PM
  12. ChrisGrant's Avatar
    ok so heres the question, what device simulator should i roll with for my 8130??? i assume the 8100, but any service?
    01-21-08 04:06 PM
  13. Member_No.1's Avatar
    ok so heres the question, what device simulator should i roll with for my 8130??? i assume the 8100, but any service?
    Chris, this is one I am using and it seems to work ok with my 8130.

    Look in this section.

    Software For BlackBerry Device Simulators v4.2.1

    Then download this one.

    BlackBerry Device Simulators v4.2.1.93
    Supported devices: BlackBerry Pearl 8100 smartphone
    Note: Supports Chinese Rendering
    01-21-08 07:38 PM
  14. dfaris's Avatar
    Is it me or is it a pain in the behind to figure out what to download so you can get the Plazmic kit to work? I down load files and then it says I need a JDK file and takes me to a web page that has a ton of different JDK files and I have no idea what to download and install. is there a list someplace that tells us the exact files we should download?
    Last edited by dfaris; 02-17-08 at 06:18 PM.
    02-17-08 06:13 PM
  15. dacur's Avatar
    member 1:

    are you using BlackBerry Email and MDS Services Simulator Package v4.1.2? there are two versions. i think the other is v.4.1.4. thanks -

    dacur

    (any other hints or advice before i get started?)

    also, i'm going to use blackbery jde v.4.2.1, is that what you are using?
    02-22-08 08:36 AM
  16. anon(1109695)'s Avatar
    This article from the Sept 2006 issue of the Blackberry Developer Journal provides a tutorial of sorts on how to use the Plazmic Theme Builder (once you are able to get it loaded and running). If you prefer a PDF printable version, here is a link to the entire Sept 2006 Journal. You'll find the subject article on page 6.

    I'm just downloading the developer kit and all the other bits and pieces now...totals about 400MB.

    I'll post later with my report of success or failure at getting the software to load/run, and ultimately trying to build a theme.
    Last edited by NevadaDad; 02-24-08 at 02:54 AM. Reason: added link details
    02-24-08 02:52 AM
  17. b_girl's Avatar
    so i made a theme and all that stuff.....its pretty simple. but now where can i find different icons and all the stuff i want to customize? i dont want to have to make my own!
    03-07-08 09:54 AM
  18. TornadoDivine's Avatar
    b_girl - there are a few free icons and other goodies on pinstack.com. If you can't find any you like, you can always download GIMP (it's free) and make your own.

    What I've noticed with the Plazmic CDK is that you have to have _exactly_ what the software wants. Later versions won't work.

    So the JDE can't be version 4.3.0, it has to be v4.2
    Likewise the Email and MDS Services Simulator Package has to be v4.1.2, not the 4.1.4

    For those of you who have the Pearl 2 (8110, 8130, 8120) which uses the 4.3 OS you might have a few issues with the 4.2 Plazmic CDK. Some of these are mentioned on the Plazmic forum and revolve around exporting issues.

    I've also noticed a few limitations with the CDK, for example on the banner customization there is no wifi icon, so you have to pretty much hope that it's in a reasonable place when the theme's exported. I guess this is because the CDK supports the 8100 and not the later Pearls.
    03-10-08 08:30 AM
  19. taguluchi's Avatar
    I have all but one of the system requirements I only have XP Home edition ....can I still download it and make themes or what?
    03-15-08 08:39 AM
  20. Jackal's Avatar
    why is RIMs website a pos.... It took me 3 weeks after getting my BB to be able to register with the owners lounge. After countless 404 errors in the process and now when I go to register with the developer community I re-register and after clicking the link in my email to activate... I get a "You have entered an incorrect username/password pair. Please try again."

    and after using the password recovery, I copy and paste exactly what they send me from the email in the password field. And nothing. Can anyone send me the JDE files? I'm running a 8310 Curve with AT&T running 4.2.2
    03-20-08 06:48 PM
  21. mattburns9999's Avatar
    From reading all these posts I guess I will not be attempting this at all! Lol

    Posted from my CrackBerry at wapforums.crackberry.com
    04-06-08 10:56 PM
  22. stevenpow's Avatar
    Im trying to download the right blackberry device simulator but there is no option for the 8310 curve from ATT what should i do???
    04-10-08 07:51 AM
  23. lfarmer's Avatar
    Themes are created as three types zen icon and today. 7100 8100 seriis devices use 240x260 screen layout, 8300 8700 8800 use 320x240. Download the simulator closest to your device. Once a theme is created it can be exported to any device with the same screen size. I have attached the Theme Builder Users Guide.

    Hope this helps.
    04-13-08 08:48 PM
  24. overmydeadberry's Avatar
    wow i'm in the process right now... man... it takes a year... i hope i get it to work!
    04-23-08 09:06 PM
  25. jdauria's Avatar
    I see for the system requirements you need Windows. So im guessing a mac user could not create themes...?
    04-27-08 09:04 PM
44 12
LINK TO POST COPIED TO CLIPBOARD