1. arsenalsocal's Avatar
    So far I have made 3 themes. I have been able to send themes to people via email so they can install using their DM; I know that the themes that I have made actually work because the people have been able to install them into their blackberry.

    Anyways, I want to go OTA and I am trying to upload themes into t35.com and on this other German site (ohost.de), but I keep getting error 404 whenever I try to download the theme, and I am obviously doing something wrong.

    I have uploaded all cod and jad files as well at the .htacess. I have created separate folders for each theme, but I am not being successful when trying to download the theme.

    I know that if I want to download the theme via OTA I need the actual address such as:

    http:// username.mi.ohost.de/themename/com_plazmic_theme_themename.jad

    but unfortunately, I get 404 errors, what I am doing wrong?



    05-01-10 03:04 AM
  2. Virtual Yoda's Avatar
    Could be an issue with the site or the way you are uploading them, I.e permissions,

    what do you use to up load them

    Pm me and i will give you a section of a site for a day or two with a username and password, for you to try,
    05-01-10 06:00 PM
  3. arsenalsocal's Avatar
    Well I found a site that will host my themes for free, and they just require me to write a brief description of each theme.
    05-02-10 03:18 AM
  4. 312's Avatar
    Make sure all the files are named properly in the .jad
    05-02-10 03:39 AM
  5. arsenalsocal's Avatar
    From what I have read and research files are name according to host and the name you gave it to a particular theme, correct?
    So for instance, if I were upload a theme on microsoft.com and the name of the theme is arsenal1 the name would be
    http:// microsoft.com/arsenal1/com_plazmic_theme_arsenal1.jad


    Make sure all the files are named properly in the .jad
    05-02-10 11:15 PM
  6. arsenalsocal's Avatar
    Ok, apparently my themes are downloading but not showing up as actual themes, they show up under third party applications. When I transfer the theme to my blackberry using theme builder it transfers just fine and shows up under themes and being on OS5 it asks to use theme as soon as the phone recognizes there is a new theme there.

    I also have no problem emailing the theme to someone else, so that they use their DM and install the theme.

    I still can't get the ota's to work properly. From what I know, you need to upload 4 files + 1 htdacess file:

    1 jad and 3 CODS, and sometimes there are going to more CODS. I am even uploading those extra CODS just to make sure the theme would actually download. In addition, there also needs to be an hctacess file which can be saved into a .txt What I am not really sure if there should be named .hctacess.txt (a dot in front of the actual file) or just an hctaccess.txt

    So using the previous example the actual address would be
    http:// microsoft.com/arsenal1/com_plazmic_theme_arsenal1.jad
    (without space just before microsoft)

    I think the culprit might my hctaccess file, and the way I saved it, is there a special code for each different theme to write or one standard hctacess file would do the job for each single theme?

    this is what I have been using for all my themes:

    AddType text/vnd.sun.j2me.app-descriptor jad
    AddType application/java-archive jar
    AddType application/vnd.rim.cod cod

    again with the dot before the htaccess

    Any direction here for htaccess?
    05-02-10 11:31 PM
  7. 312's Avatar
    Try without the .htaccess file.
    05-03-10 12:01 AM
  8. arsenalsocal's Avatar
    I get the same error message with and without the .htaccess file



    Try without the .htaccess file.
    05-03-10 02:43 AM
  9. arsenalsocal's Avatar
    I am all good to go now. I know all of you were on your toes lol

    Posted from my CrackBerry at wapforums.crackberry.com
    05-03-10 08:00 PM
  10. roxxi23's Avatar
    Hoping someone can help me out....having a similar issue as above, but I'm completely in the dark about all these files and codes. I created my first theme and tried uploading it on mybbota.com for free hosting and to get a free OTA link. I saw my theme posted today so I clicked on it to check out how it will work and it gave me a 404 error (file not found). Not sure what I did wrong. I exported the theme files before doing this, one was alx and the other cod. Idk what I'm doing wrong. A step by step tutorial would be awesome lol, but any help you can give is much appreciated. Thanks!

    Posted from my CrackBerry at wapforums.crackberry.com
    05-07-10 07:36 AM
  11. Virtual Yoda's Avatar
    You will have a jad file and about 25 cod files and a .htaccess file. All in the same folder make sure the link is to the jad file. Will check when I get home and help out more if you have nbot fixed it

    Posted from my CrackBerry at wapforums.crackberry.com
    05-07-10 07:42 AM
  12. arsenalsocal's Avatar
    Like Virtual Yoda said, you need to upload every single file, ALL including: 1 jad and how many cod's you may have. The amount of COD's differs on how detailed your theme is, make sure you also upload pictures of your theme. (I get the images from Theme Builder, using the screen capture image on Prt Sc, paste them into an image program, and just resize them according to the screen size of the actual device I am working on), and a brief description of it.

    I have also noticed, that the last way you save your file is the way that theme is ready (this may not be true since I am also a newbie as far as theme building goes), by that I mean, if you save last, as desktop, your files won't work for OTA. So make sure you save as OTA last and upload those files.

    Copy this as your .htaccess (just copy and paste into notepad in your comp and save as .hctaccess and also upload to mybbota.com

    AddType text/vnd.sun.j2me.app-descriptor jad
    AddType application/java-archive jar
    AddType application/vnd.rim.cod cod

    Make sure you press on the green plus sign to get more options of files to upload, don't upload the .alx nor .htm files, make sure all of your files are on the same folder (you can verify this just before you save the files for ota), write a brief description of your theme, upload the screen captures, and do upload ALL of your COD's and the 1 JAD.

    I attached my .htaccess file and you have to save it and name it as that .htaccess with the dot at the beginning and nothing else at the end. Also you only need one .htaccess regardless of how many themes you create and upload (considering all your files are hosted on same site of course).

    Hope this helps, if not, you can upload your files on a free site, like t35.com
    Should you have any more questions for that, post here, or pm me.






    Hoping someone can help me out....having a similar issue as above, but I'm completely in the dark about all these files and codes. I created my first theme and tried uploading it on mybbota.com for free hosting and to get a free OTA link. I saw my theme posted today so I clicked on it to check out how it will work and it gave me a 404 error (file not found). Not sure what I did wrong. I exported the theme files before doing this, one was alx and the other cod. Idk what I'm doing wrong. A step by step tutorial would be awesome lol, but any help you can give is much appreciated. Thanks!

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by arsenalsocal; 03-27-11 at 02:36 AM.
    05-07-10 05:27 PM
  13. unbreakablej's Avatar
    can someone please write a step by step tutorial as to how to post our themes online?! that would be so helpful!
    07-26-10 09:12 PM
  14. arsenalsocal's Avatar
    can someone please write a step by step tutorial as to how to post our themes online?! that would be so helpful!
    Get a site that supports ftp, create folders according to themes (if you'd build for various models), upload ALL cod's and the one jad, get the url for the jad, and voila, you are done, or just use bbmthemelab
    10-26-10 04:44 AM
  15. QBall45's Avatar
    If that doesn't work give MyBBOTA.com a look. It does what you want as well.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-27-10 12:07 PM
  16. arsenalsocal's Avatar
    Oops what was supposed to be BBThemeLab
    11-11-10 09:37 PM
LINK TO POST COPIED TO CLIPBOARD