1. morrow95's Avatar
    Just started making themes and have made an svg which places 8 icons at around 60x60px each at the bottom. Also, I put a shadow box behind them when off focus and a highlight box around them when on focus.

    Basically, they look and behave exactly the same as regular 80x80 icons you would insert through TB, but smaller and by an svg file.

    Myself, and others, have noticed the icons lag somewhat when scrolling through them. Is this because of my svg contents or because the stock icons are being sized down by the OS? I cant imagine why they would lag as there is really nothing at all to the svg file and it is very small. Or perhaps there is an optimization trick I am not aware of?

    If anyone could chime in I would appreciate it...
    06-07-09 10:01 PM
  2. BBThemes's Avatar
    Just started making themes and have made an svg which places 8 icons at around 60x60px each at the bottom. Also, I put a shadow box behind them when off focus and a highlight box around them when on focus.

    Basically, they look and behave exactly the same as regular 80x80 icons you would insert through TB, but smaller and by an svg file.

    Myself, and others, have noticed the icons lag somewhat when scrolling through them. Is this because of my svg contents or because the stock icons are being sized down by the OS? I cant imagine why they would lag as there is really nothing at all to the svg file and it is very small. Or perhaps there is an optimization trick I am not aware of?

    If anyone could chime in I would appreciate it...
    hi there, firstly id suggest poppin all stuff like this in the theme developers part of the forum, otherwise it might get missed

    anyhows, when you placed the icons in the svg (presumably using composer) did you change the timings? if not, this could be the issue, all you need to do in composer, is highlight the icon(s) one by one, and select the `edit` option which is in the top left of the screen (just below the new open and save icons) this will then give you the `timeline` section in the bottom of the screen, which as standard is set to 10s per action, click on the first segment of each action, then the line above shows 0.00s with a 1 in the box, and at the end of the line (right across the page) is another box with 10 in it, alter that box down as low as 2, which will then increase the speed of the action, this will have to be done for all states of the icon, and then for each icon individually, to get back to the normal view to select another icon to edit, select `scene` which should be by where the `edit` button was you pressed earlier, not only does this make it flow faster, but also cuts down on the size of the svg, if this doesnt do the trick, then maybe the filesize of the icons or focus background is large and its rendering the icon thats slowing things down

    hope this helps
    06-08-09 05:03 PM
  3. morrow95's Avatar
    Yep, I've done all of that. I really think that it must be the rendering of the smaller icons, or perhaps, because it has a today area. The thing that gets me is the svg file is only around 130kb in size.

    I did read that any image which is part of an animation creates a new file for each second of the animation, but for instance, I tried using the rounded corner tool for my icons and the corners are pretty crummy. It would be much easier if you could replicate a button and just tell it where on your canvas to animate. I have one button at 8 places with the same animations, but Plazmic treats each separate.
    06-08-09 09:16 PM
LINK TO POST COPIED TO CLIPBOARD