1. Member_No.1's Avatar
    Ok, I've decided to try and make a few themes. Took me a while but I finally got the Plazmic software installed and running. Problem is with the BB Device simulator. I opened the application, and can make the phone work, then I loaded a theme, figured out I had to load it just like you do in real time, and it worked. Then I tried to load a theme I made, and it will not show up. Nor can I delete the theme I already loaded. Funny part is the theme I made works fine on my 8130. So question is, how do I delete a theme on the simulator phone, and any ideas why the one I made won't show up?

    Thanks!
    01-15-08 06:18 AM
  2. Member_No.1's Avatar
    This is the response I got when I posted this question on Plazmic's own forum site. Hope this will help others.



    I'll answer each question separately.

    "how do I delete a theme on the simulator phone?"

    If you go to the directory where you installed the simulator (ie. C:\Program Files\Research In Motion\BlackBerry Device Simulators 4.2.1\4.2.1.79 (8800)) you should see a batch file for the simulator you have installed (ie. 8800.bat). If you look in this directory you should also see the cod files for the theme you developed (ie. com_plazmic_theme_MyTheme.cod). If you delete those cod files the theme will be deleted from the simulator. Note that you may also need to delete the .dmp files in the directory as well (ie. 8800-fs.dmp). Note that you can also place the cod files of a theme you have created in this directory and then launch the simulator. The theme you placed in this directory should then up in the theme list. This may be easier than downloading the theme to the simulator.

    "any ideas why the one I made won't show up?"

    One thing to check is the version of the theme (4.2.2, 4.2.1, 4.2.0) against the version of the simulator. For example: a 4.2.1 simulator will not be able to activate themes exported to OS 4.2.2 from Theme Builder. Another problem could be that the base dimension theme is missing from the simulator. If you have developed a "Today" style theme, but the simulator does not have BBDimension Today installed, your theme will not show up.
    01-15-08 02:02 PM
  3. Member_No.1's Avatar
    Well still having issues. For whatever reason, I still can not delete a theme I've loaded into the simulator. I can not locate the file I was to to delete.
    Any of you theme builders have any ideas?
    01-15-08 11:03 PM
  4. Member_No.1's Avatar
    Ok all set. I had a thread going over at Plazmic's own forum.
    Basically I had to open Options>Advanced Options>Applications>Modules> and then delete the theme from there.
    Mind you this is all on the Device Simulator.
    For what ever reason it doesn't show up under Applications as it would on the real unit.

    Thanks to all that tried to help.

    Thread on Plazmic:
    https://www.plazmic.com/PlazmicForum...eID=1891&#1891
    01-16-08 12:42 PM
LINK TO POST COPIED TO CLIPBOARD