1. danisnotstan's Avatar
    I've had my Style for about a month now and recently I've noticed that every few days I will lose data connectivity. I check the services status and it says BIS is not connected. This has happened at least 5 times this month! Usually if I do a battery pull that usually fixes it... sometimes turning on wifi, then turning it off works. Right now I am not connected to BIS and the phone showed I was connected to my wifi network, but it wasn't working. I did a battery pull and wifi is now working but still no BIS. Another interesting thing I've noticed, if the phone doesn't show 1XEV it wont connect to data at all. If it shows 1xev there is no BIS connection, therefore no data. This wasn't the case on my Tour or 8330. So does the Style get 3G or nothing? It doesn't appear to work at all if there is no 3G. I am on the newest version of OS6. I had BIS stop connecting on my Tour once and Sprint re-sent the service books. On a side note, I have also had issues with text messages not being sent... or, on other occasions, the phone tells me it wasn't sent (exceeded retries) but the message was sent. This happened today. The phone said the text wasn't sent, then my wife text me back telling me to stop sending the same message 5 times. The phone still showed the message as not sent even after this. Once again, a battery pull usually fixes this... but why is this happening? Even in the case of service books needing to be re-sent? Why? Does the phone somehow forget how to connect?!

    So I just spent an hour on the phone with Sprint... Advanced Technical Support said they had to send a request to another dept and I should get a call back in a day or 2... screw that... this thing is getting exchanged tomorrow. They tried everything and nothing worked. I'm baffled how a phone that isnt damaged and was working perfectly can just stop connecting to BIS out of nowhere and they can't fix it?! I forgot to mention earlier that my wifes Style is connected to BIS just fine. She has never had any connection issues either (if she did I would've had to attempt to fix it for her). This doesn't make any sense. They also told me that if the phone doesn't show 1XEV then its not connected. They said that should be the case on any BB, but I don't recall that being true on other BB's.. I could be mistaken.

    Update 2... So I decided to snoop around in the phones menus and interestingly enough after running a diagnostic test it connected to BIS and everything seems fine... now I'm REALLY confused haha... does anyone have any ideas?

    Update 3... Well, that lasted for 2 hrs. BIS is gone again. To the Sprint store I go tomorrow.

    Update 4... So I went to the Sprint store and they gave me a new Style. I'm not positive, but I think I found the source of my connectivity issue... ironically... I think it was my Airave Access Point! (the device meant to IMPROVE signal and data!). This might be a coincidence, but I dont think so. The phone previously worked fine, had a few disconnects from BIS but after updating the profile and a battery pull that would fix it. But today I left the store with a working brand new Style. I got home and I restored my backup from my previous Style and when it restarted I had no BIS again. Interestingly this time when I tried to open the browser it said that my plan didnt have a data plan attached to it and I needed to call my provider?! Updating profile kept failing (a few times it said it worked, but the data arrows never moved and it did NOT work). I then called Sprint and the tech refreshed the phone, etc but it didn't work. I got in my car and started to drive to the Sprint store. At a red light I tried to update the profile and sure enough it worked and I was connected to BIS. I went back home and used DM to update the OS and when the phone reset again there was no BIS. I called Sprint again and after more trouble shooting the tech informed me that when I updated the OS it mustve erased the data settings and made the phone think there is no data plan?! He said I had to go back to the store and have them re-flash the phone and have them update the OS. He said there were no other options and that was the only way to fix it. So, back to my car thinking I was about to be at the store for 2hrs and again at a red light I updated the profile and bingo, BIS is back and its been back since. I'm still confused as to why this was happening, but I surely think the Airave is to blame. If anyone else has these issues I suggest you leave the Airave and go to a place with good Sprint signal and attempt to update the profile before wasting time with Sprint. I hope this helps others. Thanks for reading my rant haha
    Last edited by danisnotstan; 02-03-11 at 02:44 PM.
    02-02-11 10:26 PM