1. dsimons82's Avatar
    Hey Everyone,
    I'm currently on TMO and I'm dying to get a touchscreen...i love my 9700, but with all of these touchscreens coming out, I wont dare jump ship and go android. So, I was curious if anyone is using the STORM 2 on TMO, and if the new 5.0 OS is stable when its on EDGE? I used to have a storm 1 unlocked and I would constantly have the edge/EDGE issue. It drove me crazy, so I just sold it. Any feedback would be great, and thanks in advance for all that respond...
    01-20-10 10:21 PM
  2. BlitzedATL's Avatar
    I had the same problem with the storm 1. I only kept it for a week before selling it. I tried so many diff os's, some better than others but the problem always remained.

    Supposed to be getting a storm 2 from craigslist tonight so if nobody else replies that already has it I I'll post back.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-20-10 10:30 PM
  3. dsimons82's Avatar
    awesome...let me know
    01-20-10 10:34 PM
  4. BlitzedATL's Avatar
    Think I jinxed myself.

    As soon as I posted that the guy emailed me back saying someone else got took it. Damn, back to searching.....

    Posted from my CrackBerry at wapforums.crackberry.com
    01-20-10 10:39 PM
  5. MRCUR's Avatar
    I just got one for AT&T and haven't seen these issues at all. In fact, I get full EDGE without anything special happening, nor have I needed to configure any browser settings.
    01-21-10 07:19 AM
  6. Lobo Lansky's Avatar
    i had mine so far now for about a month with the latest 5.0 and no problems whatsoever on anything including emails and incoming texts i love the phone. Hey dsimons82 are you in Nyc?
    01-21-10 08:35 AM
  7. sagnihotri's Avatar
    I just got mine yesterday.... 9550 on Tmo... its working fine... infact I love it... dont think twice.... go for it! I was using a 8900 earlier and i see a huge difference in speed and handling... takes about a day or 2 to get used to it though
    Last edited by sagnihotri; 01-21-10 at 08:43 AM. Reason: .
    01-21-10 08:42 AM
  8. Soarer001's Avatar
    Dude you should you 9520 in GSM networks...Otherwise you will always experience this edge/EDGE issue as 9550 is primarily designed for CDMA networks.

    I use my 9520 in GSM, it works fine.
    01-21-10 08:52 AM
  9. MRCUR's Avatar
    Dude you should you 9520 in GSM networks...Otherwise you will always experience this edge/EDGE issue as 9550 is primarily designed for CDMA networks.

    I use my 9520 in GSM, it works fine.
    Uh, no, not at all true.
    01-21-10 08:54 AM
  10. Soarer001's Avatar
    MRCUR, its just my experience with 9530. Thats why I desided to get 9520.

    Btw I still don't understand why don't T-Mobile or AT&T sell Storm2 officially?
    Last edited by Soarer001; 01-21-10 at 09:02 AM.
    01-21-10 08:59 AM
  11. MRCUR's Avatar
    MRCUR, its just my experience with 9530.

    Btw I still don't understand why don't T-Mobile or AT&T sell Storm2 officially?
    Fair enough, but to say you'll always have issues because it's a "primarily" CDMA phone is completely wrong.
    01-21-10 09:01 AM
  12. shughes31's Avatar
    It's my understanding the 9520 STILL will not support GSM 3G in North America as it uses different 3G frequencies. I am having the Browser issues on my Storm 2 using AT&T. I can browse ok but only via WIFI. When I try to change the options to Internet or Blackberry the options just aren't there. I am going to load a .451 hybrid tonight and hopefully that will fix the issue. I'll post if so.
    01-21-10 09:23 AM
  13. MRCUR's Avatar
    It's my understanding the 9520 STILL will not support GSM 3G in North America as it uses different 3G frequencies. I am having the Browser issues on my Storm 2 using AT&T. I can browse ok but only via WIFI. When I try to change the options to Internet or Blackberry the options just aren't there. I am going to load a .451 hybrid tonight and hopefully that will fix the issue. I'll post if so.
    Yes, that's correct. The 9520 doesn't use US 3G bands - RIM would have to release a US Storm for either T-Mo or AT&T since their 3G bands are different.

    As for your browser, mine works just fine out of the box unlocked. I don't understand why it works for some and others not.
    01-21-10 09:34 AM
  14. shughes31's Avatar
    I don't really see how it could work without at least loading your carrier's Service Books. But hey, I'm not calling you a liar
    01-21-10 09:49 AM
  15. MRCUR's Avatar
    I don't really see how it could work without at least loading your carrier's Service Books. But hey, I'm not calling you a liar
    I have loaded my 9700's service books now, but even before I did that I had full EDGE and a working browser. I should've made it more clear that I have indeed loaded AT&T service books though, sorry.
    01-21-10 09:52 AM
  16. dsimons82's Avatar
    hey everyone thanks for all the posts! Im def going to get one now! and lobo lansky i'm in south florida...but from maryland...lol why do you ask?
    01-21-10 10:14 AM
  17. Soarer001's Avatar
    One more interesting issue about my girlf friend's 9530 S1. It didn't connect to RIM servers in 2G area (edge always), however in 3G area it worked correctly. And the most interesting thing that after getting connected to 3G bands it started working correctly even in 2G area (EDGE) until battery pull or rebooting the device. After rebooting I needed to get to 3G area to make the phone working correctly again. 9500 didn't have this issue.
    01-21-10 10:19 AM
  18. dsimons82's Avatar
    please lets make this post about the STORM 2!!! LOL
    01-21-10 10:32 AM
  19. BMaximus's Avatar
    I love my storm2, and enjoy it on tmobile, seems very reliable so far but I continue to use my 9700 since I love the physical keys.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-21-10 10:41 AM
  20. Alwaysreal74's Avatar
    I got my storm 2 on t mobile and it work great only thing is no youtube for some odd reason

    Posted from my CrackBerry at wapforums.crackberry.com
    01-21-10 04:00 PM
  21. k1fox's Avatar
    I'm using an unlocked 9550 on a GSM carrier in Jamaica and it works fine. After all, both S2 versions are GSM capable and should work fine.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-21-10 04:14 PM
  22. Soarer001's Avatar
    please lets make this post about the STORM 2!!! LOL
    Well there shouldnt be lots of difference between 9530/9550 in compatibility to GSM networks )
    01-21-10 05:22 PM
  23. Soarer001's Avatar
    It's my understanding the 9520 STILL will not support GSM 3G in North America as it uses different 3G frequencies. I am having the Browser issues on my Storm 2 using AT&T. I can browse ok but only via WIFI. When I try to change the options to Internet or Blackberry the options just aren't there. I am going to load a .451 hybrid tonight and hopefully that will fix the issue. I'll post if so.
    That's quite strange because 9700 from AT&T works fine in european GSM networks. But if the frequincies are different... it doesn't make sense.
    01-21-10 05:26 PM
  24. MRCUR's Avatar
    That's quite strange because 9700 from AT&T works fine in european GSM networks. But if the frequincies are different... it doesn't make sense.
    The AT&T (and T-Mo I believe) 9700s will work on their respective US based 3G network, as well as Euro 3G networks. Each phone has multiple 3G bands (designated by band #s in the About page).
    01-21-10 08:36 PM
  25. PurpleSwordfish's Avatar
    There is some truth to what one guy said about the phone being a CDMA device and therefore leading to SOME problems on GSM carriers. I want to be clear in saying that I don't believe the Vodaphone line of Storm 1/Storm 2 is better suited for GSM use. However, whenever you unlock a CDMA device and use it on a GSM network, you WILL run into minor problems.

    Speaking from experience, I had issues with certain 3rd party applications causing me to drop EDGE and switch over to edge. They WOULD work, but they would block me from using programs that required EDGE (i.e. BBM). Other than that, it's all dependant on service books. If you have a good set of service books that you're using (and there are plenty to use on CB.com), you won't have a problem. Other than a couple little flaws here and there, a Storm 2 is going to run just fine on a GSM carrier (it is a "worldwide" phone according to VZW after all), but it takes a saavy user to get it working as if it belongs on a GSM network. I think just about anyone that would stumble upon these boards would be saavy enough to figure it out.

    Go for it, dude. Enjoy it, because if you're not a person really big on physical keyboards, you're going to enjoy this much more than a 9700. I know I am. Good luck!
    01-21-10 09:45 PM
LINK TO POST COPIED TO CLIPBOARD