1. David526's Avatar
    Recently my Storm2 has been clicking alot louder than its supposed to. Sometimes it will click normal, others it will click like 5 times as loud. It sounds like something under the screen might be loose. The clicking almost has a squeak to it. Anyone else have an issue like this? It doesn't happen all the time. It comes in bursts maybe a few times a day and lasts for awhile each time before going back to normal click. Its starting to get really irritating.
    04-12-10 10:44 PM
  2. 1812dave's Avatar
    so swap it out.
    04-12-10 11:55 PM
  3. WhoolioPreludee's Avatar
    Funny. I noticed that today as well. Not the clicking but the squeaking

    Posted from my CrackBerry at wapforums.crackberry.com
    04-13-10 01:16 AM
  4. Rngadng's Avatar
    I too have had this. Periodically, each keystroke will squeak--like wet sneakers on a tile floor. It has lasted for a full day, then magically it stops.
    I previously posted about this not long ago, but received no substantive replies as to cause. In any event, it seems to come and go. This has only happened with my S2, it never happened with my S1. It has happened with both .320 OS and .517 OS. I think it is a hardware issue, but I am hesitant about a swap out (could get worse issues).
    04-13-10 09:55 AM
  5. fatih.kurnaz's Avatar
    Maybe you can try to put a paper or business card between its battery and back cover..


    Fatih Kurnaz
    (Avea, Vodafone, Turkcell Blackberry Bis/BEs)
    04-13-10 11:23 AM
  6. 1812dave's Avatar
    word--WD40
    04-13-10 11:33 AM
LINK TO POST COPIED TO CLIPBOARD