1. Blahzee's Avatar
    does anyone else notice the back of the storm sounds loose when you tap on the top by the camera and some of the corners dont click anymore and the side on the left near the top is loose and makes a squeeking noise.
    i had it since it came out.
    other than that it works real good and fast, but i wish the corners still clicked well only 2 corners dont click.
    just wondering if anyone else is worn like mine or if mine sucks.
    02-06-09 05:42 PM
  2. dmarks83's Avatar
    There are a couple of methods to make your screen click better one is to cut up a piece of card and place between the battery and the back cover.

    second is to loosen two screws under the back cover one has a red sticker on it and the other is parallel to it but doesn't have a sticker... just turn them like 3/4 of a turn.

    Search on here there is lots of threads regarding screen click and ill write a little tutorial on my forum site (below) tomorrow.
    02-06-09 05:45 PM
  3. Blahzee's Avatar
    i know, but does that make the corners better as well?
    02-06-09 05:52 PM
  4. blazanik's Avatar
    i returned my first storm becasue of the squeek above the left convieniance key and my second one does it too - so does my sisters.
    02-06-09 05:59 PM
  5. dmarks83's Avatar
    i know, but does that make the corners better as well?
    I believe so but i havn't had to do it... My first storm had that problem ut never got round to doing it before i had to return it. A bloke on our forum has done it and he said its made it perfect. can but try my friend
    02-06-09 06:15 PM
  6. Blahzee's Avatar
    i returned my first storm becasue of the squeek above the left convieniance key and my second one does it too - so does my sisters.
    yea i think its because of just using it, because the store models do it too.
    02-06-09 06:19 PM
  7. richs10's Avatar
    I also got my Storm on the release date, but don't have any of those problems. If I did, I would take it back for a replacement pronto. You shouldn't put up with problems like that on a two month old phone.

    Rich
    02-06-09 06:19 PM
LINK TO POST COPIED TO CLIPBOARD