10-09-11 12:13 PM
168 123 ...
tools
  1. Crucial_Xtreme's Avatar
    Alright, since the leak of the latest beta OS for the Storm, we've had more people than ever trying to update their device. And many have been having serious problems. First off, I want to say that wiping the device with JL_Cmder is NOT necessary and should only be done by experienced users.
    Now for those having troubles upgrading, please read the following. It was made by John Clark form BlackBerry Forums. JC is a wonderful guy with much experience in the BlackBerry field. Much thanks to JC, and feel free to pop in BBF and give him the thanks he is due.



    So, you downloaded the newest, latest and greatest OS for your BlackBerry and have followed all the instructions found here.

    1. Download and install Desktop Manager.
    2. Download and install the OS of your choice for your device.
    3. Delete vendor.xml located in c:\program files\common files\research in motion\apploader.
    4. Plug in BB and open Desktop Manager.

    However, when you open Desktop Manager you get no prompt to update. When you open Application Loader your new OS is not listed!!

    This has been plaguing people for the last few months. I've never experienced the issue because of the way I've loaded Desktop Manager but Vasco at Horizon did and he and I together figured this out. I believe we've found the issue and will explain how to fix here.

    The problem lies in the new Desktop Manager's automatic "Check for Updates" feature. This feature uses your internet connection to look for OS updates for your device from your carrier. When it does this it loads a second virtual vendor.xml file in the temp folder on your computer (Vista users look in C:\Users\Username\appdata\virtualstore.) So, even after you delete the normal one that is installed with the OS and Desktop Manager, the automatic "check for updates" feature loads another one based on the brand of device you've got plugged into the PC.

    To prevent this from happening this you need to install Desktop Manager WITHOUT this Automatic Update service. Below are the steps to remove this service.

    1. Go to Control Panel >Add/Remove Programs.
    2. Click on "BlackBerry Desktop Software" and select "Change/Remove."
    3. When prompted, hit "Next" and then you should get options for Modify, Repair, or Remove. Choose "Modify."
    4. On DM 4.7 and higher, in the list of installed items, you should see "BlackBerry Automatic Update." Click the icon next to it and change it to "This feature will not be available." That should put an "X" next to "BlackBerry Automatic Update." If you are using DM 4.6 or lower and don't see this option in this list then just continue with the install and the installation will ask you a few screens later. A screen will be shown where you will be asked to check the boxes for:

    A) "Start BlackBerry Desktop Manager automatically each time the computer starts."
    B) "Create a shortcut for BlackBerry Desktop Manager on the Windows Desktop."
    C) "Check for software updates."

    Be sure number 3, "Check for software updates," is NOT checked.

    5. Finish the installation.

    (Note: If you're doing a fresh install of Desktop Manager, be sure and choose the "Custom" install button so that you get the prompt for what features you want installed. Otherwise all the features will be installed as normal and you'll likely run into this issue.)

    Once that is complete, you'll need to go back and search your computer for vendor.xml. When you do the search, make sure you click on "Advanced Options" and make sure that you search Hidden files and folders. This is important as some operating systems create a virtual store in the temp folder that this vendor.xml file is located in. You will not find this particular vendor.xml if you don't have hidden files/folders selected for search. Once the hidden vendor.xml is deleted it won't come back if you've reinstalled Desktop Manager without the Automatic Update Feature enabled.

    Now, make sure your OS is installed (you may need to install the OS again, if you actually remove Desktop Manager and then reinstall Desktop Manager again. Make sure that you delete the normal vendor.xml file LAST before updating the device.

    Tip of the day: Desktop Manager is not even required for doing an OS upgrade. In the same folder as the vendor.xml file is a file called Loader.exe. Running that will run apploader without Desktop Manager. It still makes the full backup and restore, but without all the DM stuff running in the background. I use this for all my OS upgrades. Then later I connect to DM to start my BES activation.
    Last edited by Crucial_Xtreme; 01-04-09 at 03:19 PM.
    NoLimitz80, sbmd and flyingsolid like this.
    12-21-08 07:54 AM
  2. Crucial_Xtreme's Avatar
    Mods, I believe this needs to be stickied. Please. It will help many members out.
    12-21-08 07:58 AM
  3. spektakle's Avatar
    Question... instead of re-installing without the auto update... would unplugging from the internet during the update accomplish the same thing?
    12-21-08 08:23 AM
  4. Crucial_Xtreme's Avatar
    Question... instead of re-installing without the auto update... would unplugging from the internet during the update accomplish the same thing?
    Sometimes, but why would you want to unplug your internet connection just to update? The virtual file has already been created. And the more important thing is why not go ahead and fix the problem for good?? I mean seriously, who here is not going to be aware of a update?? LMAO. Nobody.....
    12-21-08 08:29 AM
  5. spektakle's Avatar
    Yeah makes sense, I thought you may want auto update for future so unplug is easier but you will always know of updates here way before anywhere else!

    btw... thanks for all your help and knowledge, it's appreciated!
    12-21-08 08:57 AM
  6. Crucial_Xtreme's Avatar
    NP, I'm happy to help. There's just so many people having problems upgrading, I wanted to post how to fix it. And just considering that most people will know before updates come out, there's no reason to have the DM set up so that it causes mass confusion.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-21-08 09:01 AM
  7. Ainvar's Avatar
    Good post and I also agree this should be stickied.
    12-21-08 09:14 AM
  8. Crucial_Xtreme's Avatar
    Good post and I also agree this should be stickied.
    Thank you. I agree, especially with all the problems people have been having.
    12-21-08 09:18 AM
  9. chasvs's Avatar
    Question... instead of re-installing without the auto update... would unplugging from the internet during the update accomplish the same thing?
    Yes it does! That's what worked for me! I just downloaded the .83 update. Installed it on the PC and then disconnected my PC from the internet, put my Storm in the cradle and DM loaded the new OS right away. Only took a few minutes, plus my 3rd aprty apps and all data were restored and work fine! one try and all is well!

    I had tried to load .76 when it came out and couldn't get it to work because I was still connected to the internet. This time I did the disconnect and .83 is loaded and works very well!
    12-21-08 09:20 AM
  10. Crucial_Xtreme's Avatar
    Yes it does! That's what worked for me! I just downloaded the .83 update. Installed it on the PC and then disconnected my PC from the internet, put my Storm in the cradle and DM loaded the new OS right away. Only took a few minutes, plus my 3rd aprty apps and all data were restored and work fine! one try and all is well!

    I had tried to load .76 when it came out and couldn't get it to work because I was still connected to the internet. This time I did the disconnect and .83 is loaded and works very well!
    Yes it does work, but why not just fix the problem instead of a temp fix? Anyways, the point is to get it to update no matter how it's done.
    12-21-08 09:28 AM
  11. spektakle's Avatar
    ok that loader app is the best. This was the simplest way to do it. I just followed your instuctions and it was easy. Much better than DM.

    Installed the program, deleted vendor, I went in a deleted sample pics etc, fired up loader... it automatically asked to backup and restore which I did of course. Pressed start, came back 15 mins later and it was all done. Now with sample pics etc gone I have just over 50 megs of free space. Nice.
    12-21-08 11:53 AM
  12. Crucial_Xtreme's Avatar
    Cool, I'm glad it worked well for you.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-21-08 12:58 PM
  13. sciddl's Avatar
    Hi all, BB newb here.

    I have been trying to update to .83 for two days but always get app error 200. i have downloaded jl_cmder but cant get it to work. Fortunatly I can restore .75. If anyone can assist I would appreciate it. .83 sounds like a winner and I want to try it out.

    Thanks
    12-21-08 02:11 PM
  14. Rooster's Avatar
    CX! You continue to be the man! Great thread and glad it's stickied!
    12-21-08 02:26 PM
  15. Crucial_Xtreme's Avatar
    @sciddi: you need to follow the directions in this guide. Then download .83 and double click to install to your computer. Then delete the Vendor Xml file. After that, plug in device>open DM>and it should prompt you to update.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-21-08 03:33 PM
  16. DonNguyen's Avatar
    great write up CX
    12-21-08 04:41 PM
  17. ben-kelley's Avatar
    I have downloaded .83. seemed to work great at first but then i noticed that app cntr and browser were missing. i removed the battery a few times and everything came back, but then I have noticed while phone was sitting idle it came up with a "523 error" on a white screen and was locked up. Can anyone shed some light on this.
    12-21-08 04:53 PM
  18. Crucial_Xtreme's Avatar
    Go to Options>Advanced Options>Host Routing Table>Menu>Register Now. After you receive the activation email, if the Browser doesn't come back pull the battery and replace it, or resend service books.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-21-08 05:01 PM
  19. ben-kelley's Avatar
    i pulled the battery, the icons came back. the problem is that when the phone is idle and on the charger i am getting a "523 error reset" and a white screen.
    12-21-08 05:09 PM
  20. Crucial_Xtreme's Avatar
    you can try pulling the battery a couple more times, although I doubt it will work. I hope you have backed up your device recently! If the pulls do not work, check my guide in the How-To forum on how to wipe with JL_Cmder. After you wipe the device>plug in device>Open DM>Apploader>Add/Remove>and install the Core Applications. After it is done, return to the main menu>Backup/Restore>and restore from a previous backup.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-21-08 05:17 PM
  21. xxfire's Avatar
    so why am I doing this update? I just got my Storm 4 days ago and it seems to work great... What are the "gains" seems nothing but hassle to me..
    12-21-08 05:20 PM
  22. Crucial_Xtreme's Avatar
    If you feel that your Storm is working fine, then do not update. Only those who's devices aren't working so well, are updating, or those who just want to install the newest. By no means do you have to install this OS.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-21-08 05:22 PM
  23. enilm's Avatar
    so why am I doing this update? I just got my Storm 4 days ago and it seems to work great... What are the "gains" seems nothing but hassle to me..
    Here at Crackberry, we don't believe in "if it ain't broken, why fix it." We upgrade no matter what, lol.
    12-21-08 06:24 PM
  24. sciddl's Avatar
    @sciddi: you need to follow the directions in this guide. Then download .83 and double click to install to your computer. Then delete the Vendor Xml file. After that, plug in device>open DM>and it should prompt you to update.

    Posted from my CrackBerry at wapforums.crackberry.com
    Roger, followed instructions 3 times. I got the prompt to update. The update looked clean until it reset the device. Then I got an endless loop of "app error 200". I have redownloaded the update for fear it wasnt a good d'load. No dice. I believe I will wait for an official verizon update. They are more stable anyway.

    Thanks for the assistance.
    12-21-08 06:41 PM
  25. Crucial_Xtreme's Avatar
    NP. It is a 3rd party application that is more than likely causing the problem. I would suggest going back to .76. But I do want to tell you that there is no difference between the beta and the Official version.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-21-08 06:50 PM
168 123 ...
LINK TO POST COPIED TO CLIPBOARD