1. AnonymousZ's Avatar
    This thread isn't to gloat... it is truly one of disbelief and wondering are a majority of these problems the end user or the Storm itself? I got my Storm on Nov 21. It has OS version 4.7.65 and I didn't have any real problems. The OS did have a few minor ticks but nothing major. Nothing that .75 didn't fix.

    I don't have the screen click problem. When I upgraded to .75 all of my icons were still there. My internet works GREAT. Callers can hear me just fine. Etc.

    I guess my question is did I just luck out? I LOVE my phone and am telling all my friends / colleagues to upgrade to it.
    12-05-08 05:00 PM
  2. realitydigg's Avatar
    mine's fine too!
    12-05-08 05:03 PM
  3. davemathbn's Avatar
    Agreed. Mine is virtually flawless after the .75 upgrade.

    However, I still wouldn't mind ANOTHER upgrade in the near future! haha
    12-05-08 05:10 PM
  4. SourD's Avatar
    I wish I could say the same. .65 was just a little buggy for me and now .75 has me restarting constantly, freezing in different apps, and memory speeds that are just nasty. i can't even tell you how long it takes for the accelerometer to flip and to switch between apps. I am praying that .76 is the cure to my problems because i have been fowarding calls to my curve and watching my storm act a fool.

    btw.. this is my 6th blackberry. i'm no stranger to battery pulls.
    12-05-08 05:10 PM
  5. gquerbes's Avatar
    Im a little confused as well. My phone has never spontaneously reset itself. nor has is ever had any problems with missing icons or anything close to the complaints other people are having, (knock on wood). I got my phone on the 21st as well. Yet 3 of my close friends who also purchased the storm, 2 of them on the 22nd and on later on the next week are complaining about it being laggy and freezing on them. ive had them all update to .75 and they see some performance changes but still are complaining about some issues
    12-05-08 05:36 PM
  6. AnthonyIsCracked's Avatar
    I agree. I love my storm. It works perfectly!

    Posted from my CrackBerry at wapforums.crackberry.com
    12-05-08 05:45 PM
LINK TO POST COPIED TO CLIPBOARD