1. dsimons82's Avatar
    Who uses a storm on tmobile? What are the pros and cons? What apps are you using? Thanks for all the feedback!!

    Posted from my CrackBerry at wapforums.crackberry.com
    05-23-09 10:50 PM
  2. Magtastic's Avatar
    The major drawback is that the Storm won't work on T-Mobile's 3G network.

    Other than that, I've been pretty pleased, especially after upgrading the OS.
    05-24-09 02:11 PM
  3. omuzikworld's Avatar
    Everything works fine for me except blackberry maps. And I would like to have 3G working. Other than that its excellent.
    I have not upgraded the OS yet still at .75 and it sucks compared to the others from what I have been reading.
    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by omuzikworld; 05-24-09 at 03:21 PM.
    05-24-09 03:17 PM
  4. CrucialConflict's Avatar
    I'm using a 9530 on T-Mobile. I tried all of the upgrades with radio changes, and nothing seems to keep EDGE like .75. My phone is very stable using .75 and not very slow. I'll stick with it until a major OS upgrade.
    05-24-09 11:13 PM
  5. Sirhill's Avatar
    Just got my storm today and it has been great. Up graded the os to .148 and it has been like night and day.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-25-09 12:27 AM
  6. wayfr's Avatar
    I'm using a 9530 on T-Mobile. I tried all of the upgrades with radio changes, and nothing seems to keep EDGE like .75. My phone is very stable using .75 and not very slow. I'll stick with it until a major OS upgrade.
    Same here. I installed .141 a few weeks ago and it maintained a decent EDGE connection for about a day. Couldn't get any of the other radios to maintain it either. That was the .141 deal breaker for me. I'm back on .75 as of today. I won't be doing any further upgrades to this phone. It works great as is.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-25-09 12:39 AM
  7. Sphynx1187's Avatar
    I guess I just got lucky with my storm o.o I've had constant EDGE on every O.S I've uploaded, with the exception of .109. Of course, I don't use MMS, which seems to be the major thing that kills it.
    05-25-09 02:40 PM
LINK TO POST COPIED TO CLIPBOARD