View Poll Results: Zero click problems?

Voters
30. You may not vote on this poll
  • Yes, manufacture date is before recall

    16 53.33%
  • Yes, manufacture date is after recall

    8 26.67%
  • No, manufacture date is before recall

    3 10.00%
  • No, manufacture date is after recall

    7 23.33%
Multiple Choice Poll.
  1. misdeismo's Avatar
    Through my searching I have not been able to find an exact answer to this question. I bought a Storm 2 April 1st and received a version with a "130310" date stamp indicating its manufacture after the recall date of February 22th, 2010.


    My problem is that the screen will not click in these specifics spots consistently. If I move my finger slightly over it will click but what I want to know is if this is commonl. Do those who say they have a good clicking phone have ZERO dead spots in every single place they have ever tried to click on the phone, particularly in the areas I have circled below:



    All the white highlighted parts give me problems, the blue rectangled portion has never given me any issues.

    I'm just trying to figure out whether I should have this phone replaced or not.

    By the way, if it matters, I'm on .607.

    Thanks
    Last edited by misdeismo; 04-17-10 at 09:05 AM. Reason: recall date is the 22th of February
    04-17-10 08:59 AM
  2. Mr. Orange 645's Avatar
    Those circled areas appear to be between the "buttons" and should not click.

    Oh, and I have zero dead spots. .607/.612 hybrid OS built in October, 2009.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-17-10 09:38 AM
  3. Murphy5111's Avatar
    I agree you want those areas to be "dead spots". I have no screen issues or dead spots with my storm. Except in this areas you highlighted which I fully expect.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-17-10 09:46 AM
  4. seVer916's Avatar
    bought in December. and why would you expect to have a click in an area that does nothing?! the phone has sense spots where there is an action that can be done.
    04-17-10 11:26 AM
  5. codythibeauuu's Avatar
    bought in December. and why would you expect to have a click in an area that does nothing?! the phone has sense spots where there is an action that can be done.
    Sactown?

    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    04-17-10 11:31 AM
  6. Matic386's Avatar
    These dead spots are there meant to be I think. Btw, othereuse why would they be usefoul except fro "not clicking", they are there to help you make less mistakes while typing. So that you don't click instead "P" the "back button".
    Just my opinion.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-17-10 12:31 PM
  7. seVer916's Avatar
    Sactown?

    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    that's right.
    04-17-10 12:36 PM
  8. misdeismo's Avatar
    bought in December. and why would you expect to have a click in an area that does nothing?! the phone has sense spots where there is an action that can be done.
    That makes sense guys, I just wasn't sure if it was supposed to behave that way. I thought that when people complained of non-responsiveness it was in these regions too.

    Actually I initally thought that the whole screen was clickable in all areas when it was ON and that in the areas that I circled it would "choose" based on proximity what button you were trying to press if you were not entirely accurate with the press.

    So the software can detect where you are pressing and restrict movement based on location? The screen is not just ON and OFF, there's location based detection? I didn't know it was programmed that well.
    04-17-10 12:41 PM
  9. afropoika's Avatar
    Technically that's not the screen. Sure the digitizer extends past the screen. Just saying.
    04-17-10 12:51 PM
  10. misdeismo's Avatar
    Technically that's not the screen. Sure the digitizer extends past the screen. Just saying.
    Yeah that's true.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-17-10 01:00 PM
  11. 1812dave's Avatar
    never had any dead spots on any of the storms I've owned. a couple of S1's and several S2's. no dead pixels, either.
    04-17-10 08:03 PM
  12. anon(112479)'s Avatar
    None for me

    Posted from my BlackBerry using BerryBlab
    04-17-10 08:07 PM
  13. heateris's Avatar
    None that I found yet.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-17-10 08:11 PM
  14. jgfan1972's Avatar
    I have issues with my send button area. It is like the the button sensor is bit off. I can live with it but my guess is that it is mostly o/s related...BTW I am also running 607 on a "after recall device".
    Last edited by jgfan1972; 04-19-10 at 09:58 AM.
    04-19-10 09:52 AM
LINK TO POST COPIED TO CLIPBOARD