05-17-09 01:08 PM
51 123
tools
  1. ozikiwi's Avatar
    Alright so a little background first.

    My phone (9500) has v4.7.0.141 (Platform 4.0.0.174) installed. I'm trying to install Lyricidal's 9530/9500 .141/5.0.0.93[9000] Hybrid (BETA) onto it.

    Now from a post by crashin2cjk, I've tried following these instructions...
    1) Dont have 141 installed on your phone. If your going to a hybrid of this sort it will not downgrade correctly. ( ie lock and quicklaunch will NOT be fixed )

    2) Delete all OS's Installed on your PC, Not the exe files but the OS's ( you can have multiple OS's downloaded but not installed) . These can be found in "installed programs" in control panel. Make sure you only have Research in Motion Blackberry Manager Installed.

    3) I Then installed the .132 Leak OS onto my computer.

    4) I then Updated my phone with the .132 OS. Blackberry Manager works fine. You can appload.exe or what have you.
    But when I try to update my phone to .132 (either through DM or by the apploader loader.exe) it tells me that no further actions are required? I can't seem to make the upgrade for some reason. Vendor.xml is being deleted too btw.

    When I try to follow Lyricidal's instructions...
    April 29 8:30PM EST:
    Quick Launch fix - Recommended to Install this Hybrid over .132, as some people have tried over 141 and had issues with QL still
    Lock button Fix
    I have the same problem in that it won't seem to update to .132

    When I try to follow these instructions by Lyricidal...
    9500 Users: Upgrade from .141 (which is easiest)
    - Install .141 leak. (Skip this step if you already have it)
    - Run the Hybrid Installer and Click Install
    - Shrink Your Os [If you do, it will delete Vendor.xml for you]
    - Update your Phone using Loader.exe (Click Launch Loader.exe in Shrink-A-OS or go to C:\Program Files\Common Files\Research In Motion\AppLoader)
    its fine up until the shrinking the OS part.

    For the top field where my OS is installed I have the following (this is in Shrink A OS)
    C:/Program Files/Common Files/Research in Motion/Shared/Loader Files/9500-v4.7.0.141_P4.0.0.174

    But when I try to hit the "Fix Lock" option I get an error along the lines of
    "Unhandled Exception Error - Could not find a part of the path...."

    I have a dozen tabs open atm with all the threads about updating OS and so on but still don't know why its giving me so much grief.

    Would very much appreciate some advise and guidance on what I'm doing wrong please.

    Thanks in advance
    05-17-09 05:32 AM
  2. smcoldBB's Avatar
    wow long post!
    bottom line is you want .141/5.0
    lets take a step back for a second.

    uninstall whatever you have on your PC now reload a fresh .141 exe file from lyric's post.

    I'll have a quick look at what he's got there and update you after your done the uninstall
    05-17-09 05:39 AM
  3. smcoldBB's Avatar
    send me a PM when your done
    05-17-09 05:39 AM
  4. smcoldBB's Avatar
    05-17-09 05:41 AM
  5. ozikiwi's Avatar
    Hehe yeah sorry about the length/size of the post. But thanks for responding.

    Anyways I "think" I might know whats been going wrong. The computer has still been connected to the internet while I've been trying to update. Just found this post http://forums.crackberry.com/f135/wh...l-file-120048/ and realized thats a step I've been missing.

    Anyways, will try again. And yep I have Lyric's post already up. But based on what I've read so far, it seems like its a better idea to update from .141 to .132 to combat this lock and quick launch issue.

    I've uninstalled the OS. I'm going to install a fresh .132 leak and take it from there. Will post back soon-ish.

    Thanks again.
    05-17-09 05:49 AM
  6. smcoldBB's Avatar
    are you on XP or vista?
    05-17-09 05:51 AM
  7. smcoldBB's Avatar
    http://www.theiexplorers.com/bb/5.0.0.90Hybrid-9500.exe

    here's your installer. I think the lock and QL fix is already in here. we can check in a little bit.
    05-17-09 05:54 AM
  8. ozikiwi's Avatar
    I'm on xp.

    Hmm that hybrid file looks a lil different from the one I got from lyric's page. The one I have is 5.0Hybrid-9500.exe but the hybrid I just d/loaded from your link is 5.0.0.90Hybrid-9500.exe.......?
    Last edited by ozikiwi; 05-17-09 at 06:00 AM.
    05-17-09 05:55 AM
  9. smcoldBB's Avatar
    that's okay same link different title. use mine please
    05-17-09 06:07 AM
  10. smcoldBB's Avatar
    it's from the top link in his page:

    Always stay up to date with my latest work at:
    BlackBerry Apps/Hybrids by lyricidal
    05-17-09 06:10 AM
  11. ozikiwi's Avatar
    Ok small update. Uninstalled OS from comp. Installed the .132 leak. Deleted the vendor.xml file. Disconnected pc from internet. Hit loader.exe and I got the same thing....no further actions are required. Couldn't update to the .132
    05-17-09 06:13 AM
  12. smcoldBB's Avatar
    C: program files > common files > research.....> shared - tell me whats there
    05-17-09 06:18 AM
  13. ozikiwi's Avatar
    In the shared folder is "Loader Files"

    inside the loader files folder are 2 folders, one is 9500-v4.7.0.141_P4.0.0.174 and the other is 9530-v4.7.0.132_P4.0.0.162

    that where the problem lays?
    05-17-09 06:21 AM
  14. smcoldBB's Avatar
    try a shut down and reboot
    05-17-09 06:21 AM
  15. smcoldBB's Avatar
    yes you have a 9500 right? not a 9530

    if you uninstalled your current os it should have been empty that .141 shouldn't be there delete it and re download YOUR version of .132
    05-17-09 06:22 AM
  16. ozikiwi's Avatar
    Yeah its 9500

    but the only reason I'm trying to install .132 (although its for 9530) is that I read that needs to be the base for the 9500 .141 hybrid to go over for this lock and quick launch fix?
    05-17-09 06:23 AM
  17. crackberryfan's Avatar
    Kudos to oziwiki for the detailed description of the problem and the steps he took. Long post? Yes. But he certainly showed that he put some effort into his issue and deserved the quality responses he got. Much better than posts like "OMG! Help! Storm freezes during an upgrade. Won't upgrade!! IDK what happened!! PLEASE help."
    05-17-09 06:26 AM
  18. smcoldBB's Avatar
    no like I said it should be fixed in the loader .exe
    05-17-09 06:27 AM
  19. ozikiwi's Avatar
    So should I try a restart of my comp then?

    Is it better to uninstall the current .132 leak that I have installed before restarting my comp?

    And those two folders....should I delete one or both of them before restarting?
    05-17-09 06:29 AM
  20. smcoldBB's Avatar
    05-17-09 06:33 AM
  21. ozikiwi's Avatar
    Soooo.....I should uninstall the current .132 leak I have and then install this .131 yeah? And then try upgrading to it? And then, if all goes well using the lyric hybrid to upgrade from the .131?

    Is this with or without restarting my comp and should I still delete those other 2 folders in the shared/loader files directory?

    Sorry but my head is starting to spin now, yours too most likely.
    05-17-09 06:38 AM
  22. smcoldBB's Avatar
    unistall .132
    install .131 for the 9500 delete vendor file
    run the hybrid loader and force it over top of .131 C: program files......
    open app loader
    just to be sure here's a link for you QL / Lock fix just extract and overwrite into the java;

    lock - http://www.brettwyman.com/blackberry...ribbon_app.zip

    QL - http://www.brettwyman.com/blackberry...launch_Fix.zip

    run your apploader and this should be all you need.

    when your done you should see .141/.158 on your device options > about

    go to options > applications > bb button > modules > in this list you should see files from .131 / .132 / .141 / 5.0

    check your pm i've sent you my bb pin and email. i'm off work soon so might not be in front of my pc

    lemme know if you run into any more issues
    05-17-09 06:42 AM
  23. ozikiwi's Avatar
    Ok smc. Will try this.

    Just one quick question. The two files you linked, should that extraction and overwriting of the java files be done before or after running the hybrid and shrink?
    05-17-09 07:05 AM
  24. smcoldBB's Avatar
    After hybrid b4 shrink. But now your not fixing thr lock QL with shrink. Its already fixed when you overwrote the .cod's

    Posted from my CrackBerry at wapforums.crackberry.com
    05-17-09 07:21 AM
  25. ozikiwi's Avatar
    This is starting to annoy the living crap out of me now.

    I followed your instructions to the letter. Only thing I'm not sure if I did right was disconnecting my pc from the internet before hitting the loader.exe

    Upon trying to update through the apploader loader.exe I got a windows "Handheld application loader wizard has encountered a problem....." error.

    When trying to update through DM, I got the same error and then DM told me that "A fatal error has occurred while updating your device's software. Please try again" error.

    I'm ready to strangle myself and my phone atm.

    I'm deleting the OS again, deleting anything that might still be remaining in the shared/loader files folder, rebooting and trying over from scratch again.
    05-17-09 07:38 AM
51 123
LINK TO POST COPIED TO CLIPBOARD