1. soundsawful's Avatar
    I am coming to the conclusion that all my USB problems are due to my desktop. I plugged my Storm into my friend's laptop and it worked fine but when I plug it into my desktop, I get the "USB device not recognized" error. I had previously uninstalled/reinstalled the desktop software, rebooted, battery pulled, etc with no successful results. Anybody have this problem? What can I do?

    I doubt anything is wrong with my ports because other stuff works fine (flash drive for example).
    02-21-09 11:22 AM
  2. cporcelli's Avatar
    I have this problem too restart computer and phone then works I thought it eas just my crappy laptop.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-21-09 11:39 AM
  3. soundsawful's Avatar
    tried that already but thanks for the help
    02-21-09 12:28 PM
  4. stormberry22's Avatar
    am having a similair problem... when i insert my storm and go to my computer, it doesnt say BLACKBERRY1 or BLACKBERRY2... it says removable disk F and removable disk G.... when i open either of them it says, "please insert... somethin" help
    02-21-09 11:02 PM
  5. Morganizer's Avatar
    To the OP, if you're running DM 4.7 that is probably your problem. Try uninstalling 4.7 and install 4.6, then give it another try.
    02-21-09 11:04 PM
  6. soundsawful's Avatar
    When I install 4.6 it tells me something about needing 4.7, not as an optional update. I was doing a lot of uninstalling/reinstalling yesterday and had luck for a second and then it disconnected again and back to the same problem. if i try to reinstall drivers, it says I have a newer version. i uninstalled DM, installed the drivers, reinstalled DM and it didn't help. anybody?

    In the device status, it comes up as an unknown device and says that drivers are not installed but.. come on. They come with DM and it WAS recognized before, just wasn't connecting in DM. Now it's just back to a USB error/non-readable.
    02-22-09 12:12 PM
  7. Raptor007's Avatar
    I run into this issue a lot on my iMac running Parallels. It works for a while then just stops. The issue is I need the storm to show up so I can tether it to my desktop as a modem which I pay for. So far the only thing that has worked for me is restoring from my backup desktop files.
    02-22-09 12:46 PM
  8. soundsawful's Avatar
    So anybody know of a solution to this problem?
    02-23-09 10:49 AM
  9. LarryM04's Avatar
    Sometimes Windows can be very picky about the physical connector that you use. Makes no sense to me, but I did notice that I originally set up my BB on my laptop I used USB connector "A". One day I happened to use USB connector "B" on the same laptop, and Windows informed me that it was an "unrecognized device". Plugged it into USB connector "A" and it recognized it just fine.

    Try plugging into a different connector, the original one if you can remember which one you used.
    02-23-09 12:20 PM
LINK TO POST COPIED TO CLIPBOARD