1. asad7874's Avatar
    I just upgraded to 5.0xxx via BB DM and ran into this issue.
    Screen goes blank as per backlight timeout setting but it never comes up, however you push the screen, press the lock button. No display :-(. The phone is still on and I can see the buttons at bottom lit up and I can even receive calls but no display on the main screen. Have to battery-pull to make the screen work.
    Whats wrong?? I have tried adjusting Backlight Timeout settings, rebooting without media card, but to no avail. The problem is only with upgrade 5.0. I downgrade it to 4.7 and it works fine.
    Please suggest what to do.

    Thanks.
    04-22-10 02:25 AM
  2. tb146's Avatar
    which OS 5 did u used ? better to use 5.0.0.517 or hybrid.
    Mine using Lyiricidal hybrid 604 without any problem at all.
    04-22-10 05:11 AM
  3. nlitenme's Avatar
    I just upgraded to 5.0xxx via BB DM and ran into this issue.
    Screen goes blank as per backlight timeout setting but it never comes up, however you push the screen, press the lock button. No display :-(. The phone is still on and I can see the buttons at bottom lit up and I can even receive calls but no display on the main screen. Have to battery-pull to make the screen work.
    Whats wrong?? I have tried adjusting Backlight Timeout settings, rebooting without media card, but to no avail. The problem is only with upgrade 5.0. I downgrade it to 4.7 and it works fine.
    Please suggest what to do.

    Thanks.
    Do you have a Storm2 (9550) or a Storm 1 (9530)?
    04-22-10 09:28 AM
  4. bad_boy321's Avatar
    I was having that same issue. DL .517 hybrid and it fixed the issue.
    04-22-10 09:30 AM
  5. asad7874's Avatar
    Sorry, should have mentioned earlier, I am using Storm 1(9530).
    I only do upgrades using BBDM and it doesn't show me .517 hybrid. Any idea where I can download it from?

    Thanks.
    04-22-10 11:21 AM
  6. 5 point 1's Avatar
    Sorry, should have mentioned earlier, I am using Storm 1(9530).
    I only do upgrades using BBDM and it doesn't show me .517 hybrid. Any idea where I can download it from?

    Thanks.
    What a nub. You're in the wrong forum.
    04-22-10 12:35 PM
  7. nlitenme's Avatar
    Like 5 point 1 said - You're in the wrong forum. The OS's discussed here won't work on the Storm 1.

    Go to the BlackBerry Storm 9530/9500 forum & try again.
    04-23-10 01:05 PM
  8. aven's Avatar
    fail............
    04-23-10 03:10 PM
LINK TO POST COPIED TO CLIPBOARD