1. Monkey618's Avatar
    I'm sort of new to this whole upgrade thing because I was waiting for an official update to come out rather than a leaked, but that doesn't seem like it's going to happen. I followed the instructions found on this website and upgraded from my .75 to the 4.7/5.0 hybrid and the phone works amazing. However, when I opened my DocstoGo, it wasn't the premium version which I know I had purchased because I don't always have computer access and I have to write a lot of papers. I can no longer create my own documents. I figured, "okay no big deal, I'll just restore the phone and it will be fixed." I was wrong. I restored the phone and I still don't have my premium edition but now I also don't have the web browser and something else is missing but I'm not sure what exactly.

    Please, PLEASE help me fix this problem. I'm scared to touch my phone until somebody tells my exactly what i need to do.
    05-23-09 12:55 PM
  2. Michael Hepples's Avatar
    For the browser, try a battery pull first.

    If that doesn't do the trick, Options>Mobile Network>BB Key>Diagnostics Test>BB Key> Run.

    I'm not 100% on the DocstoGo, but I believe it is something as simple as a license key. If you have the original email with the license key, you should be able to open the app, select Activate Premium Edition, and select Activate. Enter your license key and away you go.

    Hope this helped.
    05-23-09 12:59 PM
  3. Monkey618's Avatar
    Okay I did the battery pull and it fixed the browser and whatever the other thing was that was missing. Thank you so much I was freaking out.

    Now I just need to find the original product key to the Premium because that was a very expensive $70 to a penny pincher like me. Does anybody have any suggestions on how I could get that? I should still have my hard copy but just in case. Would Verizon have kept that on record???
    05-23-09 01:13 PM
  4. bearkat38's Avatar
    Okay I did the battery pull and it fixed the browser and whatever the other thing was that was missing. Thank you so much I was freaking out.

    Now I just need to find the original product key to the Premium because that was a very expensive $70 to a penny pincher like me. Does anybody have any suggestions on how I could get that? I should still have my hard copy but just in case. Would Verizon have kept that on record???
    DataViz should have record of your purchase.
    05-23-09 01:16 PM
  5. jdk2's Avatar
    Contact the vendor of the software for a product key/registration.
    05-23-09 01:16 PM
  6. Michael Hepples's Avatar
    Okay I did the battery pull and it fixed the browser and whatever the other thing was that was missing. Thank you so much I was freaking out.

    Now I just need to find the original product key to the Premium because that was a very expensive $70 to a penny pincher like me. Does anybody have any suggestions on how I could get that? I should still have my hard copy but just in case. Would Verizon have kept that on record???
    Verizon won't have a record but you can try emailing their support and see if they can help.
    05-23-09 01:22 PM
  7. Monkey618's Avatar
    Thank you all for your help. The Browser is running again and I managed to track down my registration number through DataViz. They sent me my activation codes so I now have a document of that and it is filed away. The sad thing is that when I went to activate my product again, all I had to do was hit *Activate Premium* > Activate and it activated itself without me having to put any information in.

    But none the less thank you for your prompt help. . I was freaking out.
    05-23-09 01:27 PM
LINK TO POST COPIED TO CLIPBOARD