1. 93lt1z28's Avatar
    just got my replacement storm today and im unable to download yahoo and aim applications... saying sorry my device does not meet the requirements that are needed to support yahoo...

    same goes with aim...
    any help would be great, thanks
    02-28-09 04:48 PM
  2. clovis_ll's Avatar
    try installing it using blackberry device manager not by downloading it OTA. mine was saying the same error at first but now, it works great!

    good luck!
    02-28-09 06:14 PM
LINK TO POST COPIED TO CLIPBOARD