1. Max_Powers's Avatar
    Any obscure setting that I may have tripped that would kill these two at the same time all of the sudden? I'm at a loss other than the fact the sucker got wet about 10 days ago. I did the proper wet phone recovery procedure and even had it apart same day to make sure it wasn't moist in there. Worked fine till about an hour ago.

    ....Isn't moist a gross word? ...moist.... Ugh. Just thought I'd throw that out there.

    Cam

    Posted from my CrackBerry at wapforums.crackberry.com
    04-22-10 10:02 PM
  2. Mr. Orange 645's Avatar
    I would guess the moisture finally killed it. If thats the only change or incident that has occurred, then that is probably the most logical answer.

    Even if you go through the proper procedure and make sure it is wet, there is a very high probability that there will be some moisture remaining which will eventually corrode electrical connections.

    Remember: Water + Electronic Devices = Bad juju.

    Sorry....hope you have insurance.
    04-22-10 10:37 PM
  3. Max_Powers's Avatar
    I might add it was coffee and not just water... Speedbumps and cup holders are awesome when combined!

    Unfortunately the insurance plans available to us Canadians aren't worth the paper they are written on. I may have to get in there again and re-flow some solder.

    Cam

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by Max_Powers; 04-22-10 at 10:59 PM.
    04-22-10 10:57 PM
  4. Esteve1's Avatar
    Did you try a battery pull by chance it still amazes me what that will fix sometimes.
    04-23-10 12:38 AM
  5. Max_Powers's Avatar
    Sure did. First thing I tried when they went into early retirement.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-23-10 01:04 AM
LINK TO POST COPIED TO CLIPBOARD