1. Philly-Sports's Avatar
    Hey All,

    I still have my original (first day) Storm. Lots of crashes, upgrades/downdrades, and freezes requiring Battery Pulls.

    Original back was coming loose. I ended up getting the 2600mah (I THINK) battery from Seidio - along with a new batter cover.

    Now, Im really having problems with the screen, especially with browsing (Using the BB Browser and Bolt - both are problematic.

    I'm wondering if these are all connected???

    Thanks!!
    02-08-09 01:10 PM
  2. Fisk112#AC's Avatar
    what os running? what apps running?
    02-08-09 01:59 PM
  3. ArmaK's Avatar
    Hey All,

    I still have my original (first day) Storm. Lots of crashes, upgrades/downdrades, and freezes requiring Battery Pulls.

    Original back was coming loose. I ended up getting the 2600mah (I THINK) battery from Seidio - along with a new batter cover.

    Now, Im really having problems with the screen, especially with browsing (Using the BB Browser and Bolt - both are problematic.

    I'm wondering if these are all connected???

    Thanks!!
    Like the other user is trying to state. The problem could be the OS, the apps or a combination of the two. Some of the apps have leaks in them that cause the memory to drain quicker than usual or are not totally compatible with the storm yet. Also some of the OS such as .90 have cause many users problems with random restarts.

    As for the browser problems, are you having problems with clicking? This could be partly due to the new battery and battery door. If you remember when the storm first came out, the solution to the clicking problem was to put a business card under the battery door. What could be happening is that the battery and door are too tight against the screen increasing the resistance against your click. If this is the problem, try testing the device without the battery door on to see if there is any change. Also try popping in the original battery and see if the problem appears while using it.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-08-09 02:54 PM
  4. Philly-Sports's Avatar
    OS = .75 (after everything through .99).

    Here's the weird thing I'm only having clicking on the browsers. In the BB Browser - Going to Facebook. put in my username and password fine (this time) I go to click on "Login" and can't get rid of the magnifying glass on curser mode. If I'm in pan mode and click on the button - it just magnifies it.

    It looks like all of my previous diagnosis were way off base. I'm not sure that somewhere along the line - I didn't muck up my browser options.

    BTW - I did put in the business card - that seems to have helped.
    02-08-09 06:25 PM
  5. Philly-Sports's Avatar
    Update - Just spent like an hour at the VZW store - they thought they fixed it - they didn't. I'll be getting a replacement tomorrow. . .
    02-09-09 03:49 PM
LINK TO POST COPIED TO CLIPBOARD