1. houstonn's Avatar
    Hey everyone, I have a storm2 9550 from telus.. I unlocked it and also removed the activation required by getting the MSL code from telus... I currently use it on rogers.. The one major problem i'm having is my caller id... anyone calling from a rogers number the caller id shows or if anyone calling from a landline the caller id shows.. but anything else i get UNKNOWN NUMBER like if it's from another provider or any other cell number that's not rogers or landline.. Is anyone else having this problem? I've called rogers and they have resetted a few things and did a couple of things but still i have that problem..
    12-29-09 09:28 PM
  2. mcano's Avatar
    Hey everyone, I have a storm2 9550 from telus.. I unlocked it and also removed the activation required by getting the MSL code from telus... I currently use it on rogers.. The one major problem i'm having is my caller id... anyone calling from a rogers number the caller id shows or if anyone calling from a landline the caller id shows.. but anything else i get UNKNOWN NUMBER like if it's from another provider or any other cell number that's not rogers or landline.. Is anyone else having this problem? I've called rogers and they have resetted a few things and did a couple of things but still i have that problem..
    HOw did you get the code from Telus???
    12-29-09 09:30 PM
  3. houstonn's Avatar
    when i first called them... they wouldn't do anything cause i didn't have a telus account... my cousin that has telus with a storm 1 came to visit and i got him to call and luckily we got a tech support that was nice... he had told them that he was outta town and the phone would ask for a code everytime he powered it up.. gave them my imei id and the guy gave the code.. at first he gave the code for his storm 1 lol...
    12-29-09 09:39 PM
  4. mcano's Avatar
    omg bro....after calling Telus like 300 times I finally got s/m sympathetic to my cause and I got the code!!!!!!!!

    wooohooo!!!
    12-30-09 08:25 AM
  5. mcano's Avatar
    Crap now I am having the same caller ID issue...

    caller ID showing unknown number
    12-30-09 09:32 AM
  6. chasvs's Avatar
    when i first called them... they wouldn't do anything cause i didn't have a telus account... my cousin that has telus with a storm 1 came to visit and i got him to call and luckily we got a tech support that was nice... he had told them that he was outta town and the phone would ask for a code everytime he powered it up.. gave them my imei id and the guy gave the code.. at first he gave the code for his storm 1 lol...
    Amazing what you can get when you Lie to people isn't it?
    12-30-09 09:51 AM
  7. dhong2's Avatar
    Call Rogers and get them to disable name display but keep caller id. Its a bundled feature from Rogers and that's what screws up the incomming calls. This will resolve your unknown number issues.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-30-09 09:51 AM
  8. houstonn's Avatar
    I never had this problem with my 8900 and 9700 so why with the 9550

    Posted from my CrackBerry at wapforums.crackberry.com
    12-30-09 03:25 PM
  9. houstonn's Avatar
    Call Rogers and get them to disable name display but keep caller id. Its a bundled feature from Rogers and that's what screws up the incomming calls. This will resolve your unknown number issues.

    Posted from my CrackBerry at wapforums.crackberry.com


    anyone confirms that this is working... on a side note, caller id works perfectly fine when you are on a call and calling waiting is coming in..
    01-11-10 02:50 AM
  10. jaimbot's Avatar
    i am also having this problem but my phone is from verizon, please someone confirm that method up there is working(disable name display)
    01-11-10 10:38 AM
  11. houstonn's Avatar
    if you are encountering the same problem i wonder who else is that doesn't even notice it... also , if you are encountering the same problem, it might just not be telus 9550.. and since it works while im on a line and another incoming comes in it's normal, i'm hoping it's OS related and maybe an os update will fix the problem..
    01-12-10 12:30 AM
  12. jaimbot's Avatar
    anyone can confirm a fix yet?(maybe disabling name display?
    01-15-10 12:39 AM
  13. houstonn's Avatar
    nobody has this problem? well i get my verizon 9550 tomorrow so i'll see if it does it the same...
    01-18-10 12:33 PM
  14. shanedogg's Avatar
    I am having the exact same problem with the "Unknown Number" coming up.

    I am on an unlocked Verizon 9550 on the Rogers network.

    I called Rogers and asked them to remove the Name Display from my value pack. I was told this is impossible as they cannot adjust whats in the value pack. And if I wanted to separate the items in my value pack it would cost considerably more.

    Anyone with a solution PLEASE let us know!
    01-23-10 09:12 PM
  15. preferredgeoff's Avatar
    ok I have the same problem on my verizon storm 2 on fido no call display, for them to fix this you have to tell them to disable name display not remove as they cant remove stuff from the bundles, but they can disable stuff. I had them disable who called as I have voicemail and call display so i dont need there annoying text message. I will try in the am and let you guys know....
    01-24-10 02:50 AM
  16. johnpaul1884's Avatar
    @gthomson 75, can you let us know the latest info as per your caller id,i am also with fido and my caller id is not working on my storm 2 that i was unloced from verizon, except the numbers on my contact list,so did yours started working after you disabled the who called option?
    02-05-10 02:13 PM
  17. johnpaul1884's Avatar
    Everyone,my caller id on storm 2 is now working,all i did was to call Fido and i told them to disable my name display option.And my caller id started working.
    02-07-10 07:15 AM
  18. spanish_harlem55's Avatar
    anyone confirms that this is working... on a side note, caller id works perfectly fine when you are on a call and calling waiting is coming in..
    This is so frustrating.... having the exact same problem as I'm w Rogers and also have a Verizon 9550 unlocked. Mine however, doesn't work when i'm on call waiting either. I have had to call Rogers about this issue about three times... I haven't had a good agent that has been able to simply disactivate my name display yet.... I will keep you all updated and see if this issue is resolved once I get a competent person on the phone.
    04-24-10 07:48 PM
LINK TO POST COPIED TO CLIPBOARD