1. 600bb's Avatar
    OK earlier this month i spent 2 weeks in Medellin Colombia. Before the trip i call Verizon and had them set the phone up for global service. When i was there the phone had a very hard time staying on the EDGE network. I called Global support and they try to help me get the phone working, but even when i set it up manually to stay on the edge network then it would stay in sos mode. in the 2 weeks i was there the phone work about 20% of the time. it would go for days with out data connection and the last 2 days there i can not even make a phone call. But i did notice that with goggle maps it was very accurate (with in 4 meters). but it will not do any routes in Medellin. when i came back to Miami the goggle maps went back to within 1500 meters.

    any advice will be appreciated for my next trip in a few weeks.

    thanks
    Brian
    02-25-09 10:29 PM
  2. Zalansho's Avatar
    If your Google Maps version is anything prior to 3.0.2 it's almost 100% certain you won't get accurate locations in the US, where the phone will prefer Verizon's CDMA network.
    Down in Columbia the phone is using GSM(even if it can't get much of a connection) and something about the phone using GSM allows Google Maps prior to 3.0.2 to use the GPS where it couldn't on CDMA. That issue was fixed in 3.0.2 and you ought to get good locations wherever the phone can see enough satellites.

    I'm not sure what's up with the EDGE dropping out, it could be spotty coverage on the part of the carrier down there or a problem with the way the phone is configured. It is possible to get the unlock code from Verizon(if you're able to convince them to) and then buy a prepaid SIM in the foreign country and use it that way. If the problem is the carrier Verizon contracts with, that might solve things.

    Also, I'd highly recommend checking that you have Google Maps 3.0.2
    02-25-09 10:59 PM
  3. latteguy73's Avatar
    I had the same problem when I stopped over in Thailand on the way to Singapore. I called Global Support in Singapore who had me change my settings on options to "global". On the way, passing through Thailand, it worked like a charm. I would call those guys while u are still in the states to have it properly configure.
    02-25-09 11:33 PM
LINK TO POST COPIED TO CLIPBOARD