1. stratt1978's Avatar
    Sometimes my storm won't charge from the wall charger. The lightning bolt shows up and I wake up in the morning and it hasnt charged at all. Why?
    05-31-09 08:57 AM
  2. jaskru's Avatar
    One thing I have come across is getting little things stuck in either the cable end or in the phone jack. Might try cleaning those out to get a good plug in. Even really little things will cause a bad connection. Also, you might have a soder connection that that may be cracked or is acting up on you which would be a warranty issue.

    I had the same issue for a couple of days and then it went away. I was about to call in for my fourth storm......lol

    edit: that issue was the male end being bent upwards a little bit and not getting a firm connection for the charge.
    Last edited by jaskru; 06-26-09 at 11:14 PM.
    05-31-09 09:21 AM
  3. stratt1978's Avatar
    One thing I have come across is getting little things stuck in either the cable end or in the phone jack. Might try cleaning those out to get a good plug in. Even really little things will cause a bad connection. Also, you might have a soder connection that that may be cracked or is acting up on you which would be a warranty issue.

    I had the same issue for a couple of days and then it went away. I was about to call in for my fourth storm......lol
    Thanks man
    05-31-09 09:36 AM
  4. Transfigured's Avatar
    Try clock > menu > options > clock > when charging > do nothing + battery pull (w/device ON).
    05-31-09 10:19 AM
LINK TO POST COPIED TO CLIPBOARD