1. toothpaste's Avatar
    My storm 9530 is having display problems. I have not seen anything on the forums about this. I have tried every possible solution to this including os upgrades, downgrades, hard reset AKA battery pull, soft reset, i reset it to factory settings and still no luck. I'm coming to the conclusion that it is a hardware issue. Any help would be appreciated greatly.

    The phone isn't always black it seems if i try to unlock the phone by hitting the return key it has a brain fart, but if i go strait for the unlock key i have much better luck. I am not a pro by any means but I know more then the average jo.

    Since i'm not a verizon customer i'm out of luck on any warranty or exchange.
    Its a sad day. The storm has improved greatly since its release but there is only so much you can do with less than up to par hardware.

    Thank you
    toothpaste
    08-08-09 03:37 AM
  2. yogi's Avatar
    On what os are you running? Try the .151. If you use this os, try to reload it, maybe it is corrupt. Look like that.
    08-08-09 06:06 AM
  3. crackzilla's Avatar
    First off I love the wolverine suit. I would wear that!!! Anyway... This is the dark side of unlocking.

    If ur running .151 downgrade to .148 and vice versa. If that doesnt work wipe and reinstall... if it still doesnt work im sure someone else has some neat trick we all can learn from.

    I sounds more of a software prob than hardware though.
    08-08-09 06:39 AM
  4. Thomas184's Avatar
    Sorry to hear that. My first storm had a similar problem but half my screen was darker than the rest.
    I'm sure you can buy I new screen and install it if the screen turns out to be bad. Why don't you take it to a Verizon store mabye the will
    Help you out and let you know if the screen went bad.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-08-09 07:35 PM
  5. aarin85's Avatar
    any luck solving your problem as mine is doing the same
    08-02-10 11:14 AM
LINK TO POST COPIED TO CLIPBOARD