1. michaelnguyenx3's Avatar
    i know i responded in some threads already about this problem. but i just want to getthis out there because i did a reguluar battery pull and it seemed to start working! i was soo surprised. then now that i checked in about 10 min ago, it started to recharged from 5%, and now its back up to 15% but after a nother ten minutes, it STILL at 15%, and before the battery pull, it was stuck at 15% as weell.

    heres the story.

    last tnight before i went to bed around 8, i put it to charge and it was at 15% s well. i woke up wthis morning at 9 and it was still in the yellowarea still at 15%!!!

    and this is my THIRD replacement and i had just put .99 on it. i just got the replacement three days ago. -_-

    and now im thinking its either the phone or the leaked .99.

    can anyone help me? because it seems like its just stuck at 15% -_-

    ugh this is annoying because i do not want to go and call verizon for another one. its ridiculous. -_-
    02-04-09 12:46 PM
  2. Xverhoeven's Avatar
    O.K.... maybe you should try to downgrade to a official version for your device and see if everything works o.k..... I mean unless you want to hold the record for switching from storm 2 storm

    Ps. I recenly had a BIG problem with my storm, people advised me to return it, bur after a bit of a work around got it up and running to a 110% soo bevore returning I would suggest to downgrade first and see how this is working out for ya?!
    02-04-09 12:50 PM
  3. michaelnguyenx3's Avatar
    ^ true. haha.

    thanks for your adivce. i just tried another b attery pull and i put it in the charger and it went passed 15% lol its at 20% now

    well we'll see how it goes, but if anyone else has any other advice, please feel free to share

    umm, and ill see if downgrading it will be the best thing to do, cus i know that in a couple of days or a week or so theres gonna be an official upgrade
    02-04-09 12:59 PM
  4. Xverhoeven's Avatar
    Sure *** **** hope so!!, god luck!!
    02-05-09 01:50 AM
  5. martinerwin's Avatar
    This is a stupid question, but I've seen it more than I care to admit with customers. You aren't using a BT microusb charger, are you? So many people get the bundled JBT2050 and try to charge the Storm with the Jabra charger, getting pretty much the same result you are.
    02-05-09 01:55 AM
LINK TO POST COPIED TO CLIPBOARD