1. Kingsley's Avatar
    I was one of the lucky ones to get a Storm Friday. Besides the lag, phone has worked fairly well, except until Monday. I made a few calls yesterday afternoon and I could not hear the person on the other side, they could hear me. I did a battery pull and that took of care of it.

    This morning, same issue again. Anyone else having this problem? I'm losing my patience for this phone already.
    11-25-08 08:08 PM
  2. david600rr's Avatar
    ouch, i would do a hard reset, with out installing restoring the device. and test. If that doesn't work you might have your self a broken phone. That's what vzw tech support is going to do. Don't get it replaced through the phone, they might send you a refurbished device (if there is any yet). Since its not more than 30 days old, they will give you a brand new one. (if they have some). Good Luck, and Keep us posted!
    11-25-08 08:15 PM
  3. scozz6's Avatar
    I had the same issue, made some calls then I could not hear people on the other end. A friend told me to take battery out and that's what worked. It has not happened since. I am not finding this phone user friendly! I will admit that this is my first blackberry and it is very frustrating! I will try to stick it out for at least 25 days!
    11-25-08 08:24 PM
  4. Kingsley's Avatar
    Frustrating, hang in there. RIM has always churned out quality devices. I have faith. Its tough to deal with these issues only because I love my Curve so much. I called Verizon and the rep told me that no one else has reported this issue according to their database. I encourage you to call them.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-25-08 09:40 PM
  5. MLaX3's Avatar
    I had this same issue and the battery pull worked for me too...frustrating!

    Posted from my CrackBerry at wapforums.crackberry.com
    11-25-08 09:46 PM
  6. rob198's Avatar
    the same thing happened to me tonight. i tried several different tel#s and all the same thing. it said connnected, but they couldn't hear me. i tried turning it off. that didn't fix it. i finally took the battery out and rebooted...then it was fixed. i hope this doesn't happen very often.
    11-25-08 09:46 PM
LINK TO POST COPIED TO CLIPBOARD