1. Rob1's Avatar
    Hello all,

    Just purchased a Storm and setup a BES server with our companies MS Exchange 2003 server.

    All is working with emails and such but for some reason, new emails do not go to the correct folders...everything goes to the INBOX on the Storm.

    I have setup the folders on the device I want to have redirected but they still go to the inbox????

    When I do a folder view, none of the folders show that a message is waiting??


    Sorry - new and confused.

    Cheers
    12-17-08 08:42 AM
  2. Mark_Venture's Avatar
    If you have created sub-folders in your exchange mailbox space, and want to see changes reflected on the BB after you move the emails in outlook..

    You need to turn on Folder Redirection for these additional folders... i.e. by default, only the Main Inbox and Sent items are wirelessly reconciled. If you make additional folders, you need to make the BES/BB aware, otherwise if you file a message (or move it from your inbox to a sub folder), the change wont be reflected on your hand held, instead, the message stays in your main message list on the hand held.

    Adjusting which folders are wirelessly reconciled can be done either from the hand held, or Desktop Manager on your computer (when connected to your company's network).

    To configure from the device this you do the following.. From the hand held... Home Screen -> Messages -> {menu button} -> Options -> Email Settings -> {menu button} -> Folder Redirection... You'll be presented with your folder list.. or a "+" next to... "Mailbox - Your name.." and you'll have to highlight -> {menu b} -> Expand to see them all...

    Go down the folder list, and select those folders you wish to reconcile with.

    Save that and exit. Give it a few minutes for the BES to become aware of the setting change.

    From that point on, when you file a message either from outlook or on the hand held to one of these folders, the changes will be reconciled (approximately every 20 or so minutes).

    One other thing... You might want to set "Hide Filed Messages" to YES. (its under Home Screen -> Messages -> {menu button} -> Options -> General options). When set this way, if you or Outlook/Exchange Rules move mail from the inbox to one of those sub folders on the exchange server, You'll see it on the BB in the message list while its Unread/unopened. The icon is a "file folder" looking icon. Once its read/opened, it dissapears from the main message list on the BB. To see again, when in Messages, use Menu -> View Folder... then select the sub folder.

    If set to no, all messages will still show in the main message list, even if you did the above steps, and properly added the additional folders to the "reconcile" list.

    If you're moving from an Exchange Server folder to a PST, this can't be done wirelessly. But you can setup desktop manager and USB cable to work with this.
    Last edited by Mark_Venture; 12-17-08 at 09:01 AM.
    12-17-08 08:58 AM
  3. Rob1's Avatar
    Thanks Mark,

    I've done that and still my new messages appear in the main mail folder of the device....this is weird!

    If the new email was to be sent to a folder and I go to that folder on the device it's in the correct folder but there is no indicator of a message waiting there.

    Also, how do I accept new calender items? I don't see any options....

    Another thing, I replied to an email and it does not show in my Outlook sent items (laptop).

    Sorry for all the questions, I tried a Google search but have no luck.

    Cheers
    Rob.
    12-17-08 09:16 AM
  4. Mark_Venture's Avatar
    I've done that and still my new messages appear in the main mail folder of the device....this is weird!
    Even set up properly, they will show in the main messages list, until they have been opened.

    i.e. I have a BB1 folder, along with my inbox back in outlook.. I set both to recocile... and I have an outlook rule that move mail into that BB1 folder.

    On the hand held, it shows in the main message list with a file folder type icon next to it rather than an envelope. After I read it, it dissapears from the main message list.

    because wireless reconcile can take upwards of 20 or so minutes, if I READ the item in outlook, I'll have to wait for the unread mark to reconcile down to the bb before the message "hides" and doesn't show in the main message list.
    If the new email was to be sent to a folder and I go to that folder on the device it's in the correct folder but there is no indicator of a message waiting there.
    When I go Messages -> {menu} -> View Folder.. I don't see any indication that a particular folder has un-read messages.. I never have.

    maybe I'm not understanding what you mean?
    Also, how do I accept new calender items? I don't see any options....
    When you get a meeting invite, it shows up in the BB's messages. Open the invite. Menu button... there should be options to accept, decline, tentative... both with and without comments.

    The only time I've seen problems is if someone sends me an invite as a .ICS attachment. Then I can't accept from the hand held.

    One other thing to check.. Home Screen -> Calendar -> {menu b} -> Options... Select your calendar. Make sure Wireless Sync is set to YES or ON.
    Another thing, I replied to an email and it does not show in my Outlook sent items (laptop).
    make sure "save a copy in the sent folder" is selected, (Home -> Messages -> {menu b} -> Options -> Email settings.

    Also make sure folder redirection for SENT folder is on or "checked" (see earlier post)
    12-17-08 09:34 AM
  5. Rob1's Avatar
    Thanks for all your help!

    Slowing learning....

    Cheers
    12-17-08 10:26 AM
  6. BBman1911's Avatar
    Hey I ran in to ths same problem but found a fix for the issue. If you have a user who has setup many folders under the inbox of the Outlook client and has rules that send mail to the folders, you can simple solve your blackberry device issue by going in to your BES on your mail server. Once you are there, choose the server you have BB user added and right click on the user. Click on Choose folders for Redirection. Choose Redirect the following selected folders option. Go down the list and select all of the folders under the inbox that your user has setup. Ok the window and your problem is solved
    12-18-08 02:33 PM
  7. tealturboser's Avatar
    It is easy to tell if an email was redirected from a folder other than the inbox, as the normal mail icon will look like a folder now
    12-18-08 02:44 PM
  8. Mark_Venture's Avatar
    Hey I ran in to ths same problem but found a fix for the issue. If you have a user who has setup many folders under the inbox of the Outlook client and has rules that send mail to the folders, you can simple solve your blackberry device issue by going in to your BES on your mail server. Once you are there, choose the server you have BB user added and right click on the user. Click on Choose folders for Redirection. Choose Redirect the following selected folders option. Go down the list and select all of the folders under the inbox that your user has setup. Ok the window and your problem is solved
    Only the BES admin can go into the BES and do the steps you've outlined...

    The steps I put in Post # 2 of this thread are the same, but can be done by the End User right from the hand held.

    End user's can also do this if they have Blackberry Desktop Manager software on their PC and it links back to the BES... Under the Email Settings icon, advanced.. "select folders" button...
    12-18-08 02:45 PM
  9. wheeline's Avatar
    If you have created sub-folders in your exchange mailbox space, and want to see changes reflected on the BB after you move the emails in outlook..

    You need to turn on Folder Redirection for these additional folders... i.e. by default, only the Main Inbox and Sent items are wirelessly reconciled. If you make additional folders, you need to make the BES/BB aware, otherwise if you file a message (or move it from your inbox to a sub folder), the change wont be reflected on your hand held, instead, the message stays in your main message list on the hand held.

    Adjusting which folders are wirelessly reconciled can be done either from the hand held, or Desktop Manager on your computer (when connected to your company's network).

    To configure from the device this you do the following.. From the hand held... Home Screen -> Messages -> {menu button} -> Options -> Email Settings -> {menu button} -> Folder Redirection... You'll be presented with your folder list.. or a "+" next to... "Mailbox - Your name.." and you'll have to highlight -> {menu b} -> Expand to see them all...

    Go down the folder list, and select those folders you wish to reconcile with.

    Save that and exit. Give it a few minutes for the BES to become aware of the setting change.

    From that point on, when you file a message either from outlook or on the hand held to one of these folders, the changes will be reconciled (approximately every 20 or so minutes).

    One other thing... You might want to set "Hide Filed Messages" to YES. (its under Home Screen -> Messages -> {menu button} -> Options -> General options). When set this way, if you or Outlook/Exchange Rules move mail from the inbox to one of those sub folders on the exchange server, You'll see it on the BB in the message list while its Unread/unopened. The icon is a "file folder" looking icon. Once its read/opened, it dissapears from the main message list on the BB. To see again, when in Messages, use Menu -> View Folder... then select the sub folder.

    If set to no, all messages will still show in the main message list, even if you did the above steps, and properly added the additional folders to the "reconcile" list.

    If you're moving from an Exchange Server folder to a PST, this can't be done wirelessly. But you can setup desktop manager and USB cable to work with this.
    This is a great tip but i am unable to select the deleted items folder. It is greyed out. When I delete a message on my computer it stays in my phone new message list. Anyone know a fix for this?
    09-02-09 01:41 PM
  10. Mark_Venture's Avatar
    This is a great tip but i am unable to select the deleted items folder. It is greyed out. When I delete a message on my computer it stays in my phone new message list. Anyone know a fix for this?
    Are you emptying deleted items in outlook too soon? i.e. delete something in outlook, it gets moved to deleted items. Every 20 min or so (the BES replication cycle), the BES checks your Deleted items folder in your mailbox on the exchange server. If there is anything there, it removes it from the hand held. IF you've emptied deleted items, then nothing is there so the BES moves on to its next task, and the item on the hand held doesn't get touched.

    Are you doing a "hard delete" in outlook (hold the ctrl key while deleting an email)? When deleting this way, items just dissapear from outlook, do NOT go to the Exchange Deleted items folder. When the bes comes looking at Exchange's Deleted items, nothing is there, so the BES moves on to the next task and the item stays on the hand held
    09-02-09 01:58 PM
  11. wheeline's Avatar
    Are you emptying deleted items in outlook too soon? i.e. delete something in outlook, it gets moved to deleted items. Every 20 min or so (the BES replication cycle), the BES checks your Deleted items folder in your mailbox on the exchange server. If there is anything there, it removes it from the hand held. IF you've emptied deleted items, then nothing is there so the BES moves on to its next task, and the item on the hand held doesn't get touched.

    Are you doing a "hard delete" in outlook (hold the ctrl key while deleting an email)? When deleting this way, items just dissapear from outlook, do NOT go to the Exchange Deleted items folder. When the bes comes looking at Exchange's Deleted items, nothing is there, so the BES moves on to the next task and the item stays on the hand held
    I do a soft delete and only permanently clear items from the deleted items folder after they are 1 month old.
    09-07-09 02:21 PM
  12. dlazo80's Avatar
    how do you default a folder to view first when opening mailbox? when i click the messages button it always shows me my phone log or missed calls instead of my inbox?
    04-16-10 08:42 AM
LINK TO POST COPIED TO CLIPBOARD