1. elw7792's Avatar
    So I got my Storm at the beginning of January and it seemed to be working perfectly fine until about the last week and a half. The battery life is very weak and the phone will die after about nine hours from when it's fully charged. During this time I'm not doing anything that would cause it to deplete so quickly, only very few text messages. It also has been very slow and the "hour glass" came up frequently and simple tasks took a very long time. A few days ago I turned it off because it was stuck on a screen and I turned it back on and the battery life went back to normal and it stopped taking so long. But yesterday the battery life started to deplete quickly again. I don't believe that I'm doing anything that would make it run out of battery so fast, but has anyone had this problem or could offer any advice on how to fix it? I've turned it off and on mulitple times but it hasn't gone back to normal yet. Thanks and I hope that all of this is making sense.
    02-11-09 04:53 PM
  2. WJF84's Avatar
    Do you have any open bbm conversations? They stay open after a bat pull.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-11-09 05:02 PM
  3. mjesenovec's Avatar
    can you post a list of apps you have installed on your phone? I mean it's quite possible that your battery is prematurely wearing out, but with the storm, i think it's more likely that something is running constantly in the background and eating up battery. is the backlight on more than is should be? are you using apps that constantly use the internet, like slacker, messaging, etc? what OS are you on? might want to try reflashing.
    02-11-09 06:36 PM
  4. berkdog84's Avatar
    i just upgraded to .99 and have the battery issue now as well. happened when i upgraded to .85 as well initially. It then what back to normal after several days (on .85) I believe i posted up some about that back when it was happening.
    Now that I'm running .99 battery life is back to crap. full charge over night and in 5 hours of ONLY a few texts i have 2 bars left and draining fast. Something IS wrong but im jumping right to .103 now but im sure the issue will be there as well.
    02-11-09 08:25 PM
  5. jk5one3's Avatar
    i just upgraded to .99 and have the battery issue now as well. happened when i upgraded to .85 as well initially. It then what back to normal after several days (on .85) I believe i posted up some about that back when it was happening.
    Now that I'm running .99 battery life is back to crap. full charge over night and in 5 hours of ONLY a few texts i have 2 bars left and draining fast. Something IS wrong but im jumping right to .103 now but im sure the issue will be there as well.
    same crap happened to me. i switched back to .90 and battery life is back to normal. i couldnt deal with the poor battery life with .99. i think ill just stick with .90 until the official release comes out.
    02-11-09 08:29 PM
  6. jk5one3's Avatar
    oh yeah to the ts, what os do you have installed? everyone has different issues with different os's. whatever os you have on right now might be draining your battery and that might be the problem.
    02-11-09 08:31 PM
  7. elw7792's Avatar
    My applications are:

    Facebook
    Weatherbug
    AP Moblie News
    Storm Saber (which I will be deleting soon)
    Tiltris
    MiaPuzzle (deleting)

    My OS is 4.7.0.75

    The only thing I'm really doing on my phone is texting, and not even that much of it. I set my blacklight timer to ten seconds, but that hasn't made that much of a difference. The blacklight brightness is at 100 and it's set to automatically dim.

    One question that I have: when in an application do I need to go to menu > close to fully close it down and not waste battery or can I just simply press the END key?
    02-11-09 09:02 PM
  8. reactortrip's Avatar
    set weatherbug to update every 4 hours, turn off auto locate and gps find in weatherbug

    set backlight to 10 brightness


    that helped me a ton
    02-11-09 09:09 PM
LINK TO POST COPIED TO CLIPBOARD