1. Medic2010's Avatar
    Ok, I purchased a completely unlocked Storm 2 a couple of months ago. It has been working great with AT&T. No problems. AT&T set it up in the system without issue. I deployed and the phone worked without issue. UNTIL - last week. I took the battery out to update the phone and when I put the battery back in, it would not Register to the system. Several calls and run arounds with no help.
    Today I started back working on it and called AT&T again. The tech I talked to seemed alot more helpful and contacted RIM several times. She finally found a note somewhere she said, stating that AT&T will start blocking IMEI/PINs of "non-authorized" phones. She tried fooling the system by putting a Bold IMEI in without any luck.
    So right now I am sitting here with a lighted brick.

    Does ANYONE have even an idea where to start?

    Thanks!
    04-19-10 08:37 AM
  2. Blacklac's Avatar
    oh man, i hope they do not block 'non authorized" phones. I just got my Storm 2 last week.

    That doesn't make sense , business wise. How could anyone roam on their signal? So they are trying to say you can't use their service without having a phone they sell? That would pretty much screw travelers.

    Or is she trying to say AT&T is now blocking "blacklisted" phones?? Where did you buy it?
    04-19-10 08:50 AM
  3. Medic2010's Avatar
    I bought if from a source that does not sell blacklisted phones. She was saying it is just not authorized to be registered on their system. Even on the att.blackberry.com website, it says "this phone is not authorized"

    Anyone know a work around? Or recommendation?
    04-19-10 08:58 AM
  4. Medic2010's Avatar
    The dialog that pops up when I try to register it from the website is: "the information is not valid for this service provider"
    04-19-10 09:03 AM
  5. Blacklac's Avatar
    Hmm. I just have my PIN/IMEI with the device selected as a Bold on ATT's website. I guess I will cross my fingers. I hope someone can help you.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-19-10 10:35 AM
  6. Medic2010's Avatar
    Blacklac,
    Where do you select the device on the att.blackberry.com website? I only have the section for the PIN/IMEI.
    04-19-10 11:23 AM
  7. Res215dg's Avatar
    I dont see At&t blocking IMEI #s from unathorized phones...I think they would still rather have your service and money than care about the phone you use. I mean your are paying for a BlackBerry Data plan regardless so why should it matter?
    04-19-10 02:16 PM
  8. Res215dg's Avatar
    Hmm. I just have my PIN/IMEI with the device selected as a Bold on ATT's website.
    Same Here, I still have my original Bold listed as my primary phone on the At&t site- but I never chagned the PIN/IMEI through them from what i am aware of. All I know is that At&t believes I am still currently on the Bold. I purchased my Storm 2, swaped sim cards and havn't had a problem since....
    04-19-10 02:22 PM
  9. Medic2010's Avatar
    Ok-I had RIM and AT&T on the phone and it seems it is something with them "registering" it.
    They said "if you get the service books, it should connect, but we can not initiating helping push any type books to them or support."

    So where am I at starting from infancy on this. How do I wipe everything including the OS and starting completely over?
    04-19-10 02:25 PM
  10. Res215dg's Avatar
    Your best best would go up to the "Blackberry Help" tab under the "Blackberry 101 Lecture" series entries. You'll find all the topics on how to reload the operarting from scratch.
    04-19-10 02:31 PM
  11. Res215dg's Avatar
    Regarding what OS to use, I would just back to the main Storm 2 forum page, and on the sticky threads, you'll see one for official Storm 2 OS - download the latest one from there and you'll be on your way to reloading everything
    04-19-10 02:33 PM
LINK TO POST COPIED TO CLIPBOARD