1. yellar2000's Avatar
    I upgraded to a storm 2 this friday. I have been using my storm 1 for about 8 months and I grown to love it and thought the newer storm would be much better, but its not. First let me say the 9550 was pre-loaded with .607 OS and its making me hate this phone. I have the same problems as everyone else with freezing and having to do multiple battery pulls during the day. I have tried downgrading to .428 since a lot of people have said its great but have had no luck. I am thinking I am gonna take it back and wait to see if the new bold hits in the next week. All in all I love the storm 2 but the OS is making it a bad experience any advice?
    05-30-10 11:38 AM
  2. kolonji's Avatar
    Thats odd .. I too just switched to a 9550.. had to install .607 myself .. but I have no issues so far (except for bbm group kb issue, but I was used to that workaround from .591 on my s1). Other than that, I dont know why I didnt get an s2 sooner..

    Haven't rebooted since Thursday and its runnin like a champ.
    05-30-10 11:43 AM
  3. RicanMedic78's Avatar
    Only bad thing I've noticed so far on .607 is that the keyboard doesn't pop up for bbm groups and doesn't pop up for ims when you open them from the messages icon. I also notice that in some instances, the charger won't register a charge unless I do a battery pull. So far its usually just been with my car charger.

    Quite annoying and if you ask me! I don't experience the freezing however...

    Posted from my CrackBerry at wapforums.crackberry.com
    05-30-10 11:47 AM
  4. sting5566's Avatar
    I upgraded to a storm 2 this friday. I have been using my storm 1 for about 8 months and I grown to love it and thought the newer storm would be much better, but its not. First let me say the 9550 was pre-loaded with .607 OS and its making me hate this phone. I have the same problems as everyone else with freezing and having to do multiple battery pulls during the day. I have tried downgrading to .428 since a lot of people have said its great but have had no luck. I am thinking I am gonna take it back and wait to see if the new bold hits in the next week. All in all I love the storm 2 but the OS is making it a bad experience any advice?
    First thing I would do is try one of the many hybrids out there. I have had
    .607 since it was leaked, yes it's not great, but I only need to do battery pulls when install or delete something.
    05-30-10 11:47 AM
  5. howarmat's Avatar
    you shoud not be doing daily battery pulls on a storm 2, you have to be doing something wrong to make it freeze up that bad or your device is bad
    05-30-10 11:53 AM
  6. dukebluedevil's Avatar
    you shoud not be doing daily battery pulls on a storm 2, you have to be doing something wrong to make it freeze up that bad or your device is bad
    What he said!
    05-30-10 11:59 AM
  7. sparhawke2000's Avatar
    First thing I would do is try one of the many hybrids out there. I have had
    .607 since it was leaked, yes it's not great, but I only need to do battery pulls when install or delete something.
    I agree, there are a number of great Hybrid's available. Check out bbhybrids.net for a number of them. You've tried downgrading once, and if the problem persists after loading a hybrid, then it's more than likely a problem with your phone.

    I'm using 9550/9520 - .692 Hybrid (517/580-Based) by lyricidal, and it works very well for me. Here are the links.

    Hybrid OS: 9550/9520 - .692 Hybrid (517/580-Based) - Downloads - BBHybrids Forums

    OS: 5.0.0.517 (Official) - Downloads - BBHybrids Forums
    05-30-10 12:48 PM
  8. chuckh0308's Avatar
    I've only "had" to do a battery pull I think once in four months and that was in January. Any other resets were due to OS or application installs/updates. This thing easily goes weeks without resets and probably months if I didn't have any updates to do.


    Something is not right with your Storm.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-30-10 01:00 PM
  9. 1812dave's Avatar
    you shoud not be doing daily battery pulls on a storm 2, you have to be doing something wrong to make it freeze up that bad or your device is bad
    definitely a "+1"
    05-30-10 01:12 PM
  10. yellar2000's Avatar
    I was kinda thinking maybe I got a bad phone. I use it the same way I use my storm 1 with all the same apps and settings. I thought maybe it something was weird when it takes it over twice as long to boot, I figured it would be faster or at least the same. I guess maybe I should take it back to Verizon and get a different one.
    05-30-10 01:28 PM
  11. dmcman73's Avatar
    I was kinda thinking maybe I got a bad phone. I use it the same way I use my storm 1 with all the same apps and settings. I thought maybe it something was weird when it takes it over twice as long to boot, I figured it would be faster or at least the same. I guess maybe I should take it back to Verizon and get a different one.
    When you got your Storm 2, did you use the Blackberry transfer program in BB Desktop manager? It's the program to transfer all your stuff from one Blackberry to another.

    When I switched from Storm 1 to Storm 2 and used the transfer program, everything went screwy. I had lockups, unresponsiveness, had to do battery pulls, etc. After I did a full wipe of my Storm 2 and manually load everything, problems went away. I have a feeling that when it transferred my apps over from my S1 to S2 (which it did) and one of the apps was not compatible and that's what caused all my problems. Could also be caused by some corrupt data during the transfer process as well.

    I say try a device wipe and take it from there.
    05-30-10 06:29 PM
  12. SirGodLess's Avatar
    I have a storm 2 and nothing wrong with it, no freezes sometimes it lags a little when using the bb app store
    05-30-10 06:34 PM
  13. Thud Hardsmack's Avatar
    +1

    When I went from a 8130 to my S2 I did a device transfer and had a number of quirks. I wiped it and reinstalled the stock OS (.320 at the time) and did an advanced restore, where you can selectively restore components. I only put contacts, calendar, and email settings back on and set up the rest manually; haven't had any of the original problems return. You could go that route, and if even that fails take the device back and request a new one.

    When you got your Storm 2, did you use the Blackberry transfer program in BB Desktop manager? It's the program to transfer all your stuff from one Blackberry to another.

    When I switched from Storm 1 to Storm 2 and used the transfer program, everything went screwy. I had lockups, unresponsiveness, had to do battery pulls, etc. After I did a full wipe of my Storm 2 and manually load everything, problems went away. I have a feeling that when it transferred my apps over from my S1 to S2 (which it did) and one of the apps was not compatible and that's what caused all my problems. Could also be caused by some corrupt data during the transfer process as well.

    I say try a device wipe and take it from there.
    05-30-10 08:21 PM
  14. kolonji's Avatar
    I have a storm 2 and nothing wrong with it, no freezes sometimes it lags a little when using the bb app store
    Thats not your BB .. that BB crApStore..
    05-30-10 08:25 PM
  15. Thud Hardsmack's Avatar
    Thats not your BB .. that BB crApStore..
    I'll second that. >.<
    05-30-10 08:33 PM
  16. yellar2000's Avatar
    When you got your Storm 2, did you use the Blackberry transfer program in BB Desktop manager? It's the program to transfer all your stuff from one Blackberry to another.

    When I switched from Storm 1 to Storm 2 and used the transfer program, everything went screwy. I had lockups, unresponsiveness, had to do battery pulls, etc. After I did a full wipe of my Storm 2 and manually load everything, problems went away. I have a feeling that when it transferred my apps over from my S1 to S2 (which it did) and one of the apps was not compatible and that's what caused all my problems. Could also be caused by some corrupt data during the transfer process as well.

    I say try a device wipe and take it from there.
    Thats exactly what I did, I transfered all the settings and apps. I did a wipe and it worked fine then did the transfer again and it got all sluggish and jerky. So I wiped again and just transfered my basic stuff no apps and it seems to be running like a champ now! I had thought about that and sure enough I believe some of the apps were not clicking right and was causing problems. I have only had it running again for about 3 hours so time will tell I guess, but for now it sure seems to be working and I am really liking it.
    Last edited by yellar2000; 05-30-10 at 10:04 PM.
    05-30-10 10:00 PM
  17. jwebste9's Avatar
    I just recently switched from the tour over to the storm 2 new from verizon with .607 on it. I have been usign it heavily for about a week now and am yet to experience any problems. From what i have read it really does seem to be either you get a good device or crappy one. as much as a bad gamble that may be i am glad i took it and i love my storm 2.

    As for battery pulls, i have not had to do one due to the phone freezing ever. i do use the quick pull app once in a while. And as for battery draining problems i charged it full the day i got it and the next day it seem to drain rather quick. however after that i charged it and left it on the charger overnight even though it was full charged when i went to sleep, and i have not had a problem since, im able to go through the whole day while texting, emailing, and browsing alot and still have plenty of battery at night
    06-01-10 11:57 AM
LINK TO POST COPIED TO CLIPBOARD