1. TigerGlide's Avatar
    My screen backlight has dimmed and will not brighten.
    I've adjusted it in the Options menu and it has the same
    brightness if its set on 10 or 100. Has anyone else had
    this problem or does it sound like a hardware issue?

    I'm not familiar with how these things are made, but I
    suspect that there may be more than one light source
    behind the screen and one of mine may have blown.

    Thanks in advance for any help.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-17-10 02:48 PM
  2. bry360's Avatar
    My Storm does the same thing, and I could never figure out how to fix it. It is set to 100 on brightness and sometimes it will be lit at 100, but then it will dim and at random times it will brighten back up. Its very weird but I don't know why it does that. I would like a fix to this as well.
    04-17-10 07:32 PM
  3. k8108's Avatar
    What OS are you running? It might help to upgrade. It fixed my problem.
    04-17-10 08:44 PM
  4. djrdan6's Avatar
    Have you set it to automatically dim backlight? If you have, set the option to 'no'. Let me know if it works
    04-18-10 01:14 PM
  5. TigerGlide's Avatar
    I'm running 5.0.0.328. I'm pretty sure its the latest. I've had the automatic dim turned off for a while now. Thanks though.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-18-10 05:14 PM
  6. irishanimal917's Avatar
    When OS 5.0.0.328 came out, this was and still is still a big problem.
    There is no way to fix this that I am aware of after having researched every possible thread and haveing been led in every wrong direction. The only thing you can do to get it to light up is tilt the phone up and down a couple of times until it lights back up. Annoying as ****, hope the fix it with the next update.
    04-19-10 05:50 PM
  7. ajs602's Avatar
    Mine does the same thing. Always worked fine then one day the screen stayed dim. I haven't figured out how to fix it either.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-20-10 02:42 PM
  8. TigerGlide's Avatar
    Just an FYI. My Storm's screen became unresponsive. I had to exchange it. Thank goodness I had the foresight to create a backup file on my Desktop Manager. So, if your having similar issues its not good.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-25-10 09:05 PM
  9. grahamf's Avatar
    I know that on mine if I cover the top part near the speaker grille it will dim after a while, then brighten again when I uncover it. could there be something obstructing a sensor in there?
    04-25-10 09:49 PM
LINK TO POST COPIED TO CLIPBOARD