1. SeanGTS's Avatar
    Of people complaining they can't hear me! I've tried cupping my hand over the microphone, and fiddling with the background noise filters, all with no avail! I'm running .109 and I still seem to have problems!!

    Are these updates improving call clarity for anyone? I can always hear people just fine, they just cant hear me! I've listened to myself on another cell phone, it sounds like I'm under water!
    03-04-09 12:42 AM
  2. epicfailure's Avatar
    This! Does not increase! The chances of people! Knowing the! Answer?

    Posted from my CrackBerry at wapforums.crackberry.com
    03-04-09 12:47 AM
  3. digo909's Avatar
    maybe its a phone issue because i am also on .109 and don't seem to have any clarity problems
    03-04-09 01:07 AM
  4. seVer916's Avatar
    if diff OS's aren't fixing the issue, then one has to assume it's a hardware issue.
    03-04-09 01:46 AM
  5. Slojo's Avatar
    I had exactly the same problem on my last Storm. Finally took it back for replacement and the new phone is like night and day, works exactly as I would expect. I know from experience how frustrating this problem is. Having tried all the leaked updates I never found my problem to get any better (or worse).

    Take the thing back, insist on a replacement or, failing that a repair. I strongly believe that this is not an issue that will be fixed by firmware and although mine is a 9500, the problem definitely sounds like the same one.

    Hope this helps.

    Slojo.
    03-04-09 03:06 AM
  6. JKaytheISH's Avatar
    ^agreed
    i'd think it's a hardware issue
    03-04-09 03:12 AM
  7. parkster705's Avatar
    Do a search this every week someone makes a new thread about this same problem.
    03-04-09 07:05 AM
  8. Roadbiker's Avatar
    Of people complaining they can't hear me! I've tried cupping my hand over the microphone, and fiddling with the background noise filters, all with no avail! I'm running .109 and I still seem to have problems!!

    Are these updates improving call clarity for anyone? I can always hear people just fine, they just cant hear me! I've listened to myself on another cell phone, it sounds like I'm under water!
    I have read on other threads that people who have storm's made in mexico are having the problems you are describing. Units made in Canada seem to work better. I suggest that you call around and find a verizon store who has inventor of storms made in Canada and retrun yours. To determine where your unit was made, pull the battery and look at the label or look on the lable on the outside of the box.
    03-04-09 07:13 AM
  9. kigs's Avatar
    yea just go around opening up 10-20 boxes to find one
    03-04-09 08:08 AM
  10. bigman2's Avatar
    yea just go around opening up 10-20 boxes to find one
    Or look at the sticker on the side of the box. Though I imagine opening up a bunch of boxes is more fun.
    03-04-09 08:28 AM
  11. SeanGTS's Avatar
    Do a search this every week someone makes a new thread about this same problem.
    Thanks for the help, you've really solved my problem. I'm glald you took the time to write such an informative sentence.

    I'm already on my 4th blackberry storm, it was a HUGE ordeal with Verizon and I do not want to attempt round 5. They refused to continue my phone service until I paid the near 900 dollar bill. Horrible, horrible experience.


    Guess I'll just continue to be frusterated and deal with it.
    03-04-09 10:20 AM
  12. dd214's Avatar
    It sounds like you might want to downgrade to .75 and return your phone for a new one.

    Just a hint, if your "traveling" real soon they will give you a new one instead of making you wait 2 days for a refurbished one...
    03-04-09 10:37 AM
  13. parkster705's Avatar
    Thanks for the help, you've really solved my problem. I'm glald you took the time to write such an informative sentence.

    I'm already on my 4th blackberry storm, it was a HUGE ordeal with Verizon and I do not want to attempt round 5. They refused to continue my phone service until I paid the near 900 dollar bill. Horrible, horrible experience.


    Guess I'll just continue to be frusterated and deal with it.
    Ok buddy. You're not the only one who has this problem. I replied JUST YESTERDAY to a thread of the EXACT SAME ISSUE. If you dont want to search just click the little 2 at the bottom of this discussion forum, it'll bring you to page two which has the thread entitled, ".109 users, can people hear you okay on the other end?". Sound familiar? To save you some time I'll just be nice and tell you what I wrote.

    Phone, Options, General Options, Enhance Handset Call Audio, Boost Treble

    Completely eliminated the problem for me.
    Btw, this phone has been out for a while now. I guarantee if you have a problem someone else has it to and therefore searching saves not only you but all of us a lot of time.
    03-04-09 10:44 AM
  14. gawad619's Avatar
    Ok buddy. You're not the only one who has this problem. I replied JUST YESTERDAY to a thread of the EXACT SAME ISSUE. If you dont want to search just click the little 2 at the bottom of this discussion forum, it'll bring you to page two which has the thread entitled, ".109 users, can people hear you okay on the other end?". Sound familiar? To save you some time I'll just be nice and tell you what I wrote.



    Btw, this phone has been out for a while now. I guarantee if you have a problem someone else has it to and therefore searching saves not only you but all of us a lot of time.
    jus give it a rest G no1 is gonna listen.... that sounds really logical but in 5 mins were gonna have another 1 of these threads, or maybe even another "MMS issue" thread... even though its been fixed.... GETS KINDA ANNOYING!
    03-04-09 02:16 PM
  15. parkster705's Avatar
    jus give it a rest G no1 is gonna listen.... that sounds really logical but in 5 mins were gonna have another 1 of these threads, or maybe even another "MMS issue" thread... even though its been fixed.... GETS KINDA ANNOYING!
    LOL Agree 100%
    03-05-09 06:25 AM
  16. crwolf79's Avatar
    Hardware problem. I had exactly the same issue, as did another co-worker with a Storm. I too tried every leaked OS in hopes that it would fix the problem. It didn't.

    Both of us sent it back to Verizon, and the new one was night and day better. Insist that there is a problem, and get a replacement.
    03-05-09 07:25 AM
LINK TO POST COPIED TO CLIPBOARD