1. chadric_g's Avatar
    Alright so I have a dead Storm battery and I am away from my wall charger. I do have the usb cable with me but when I plug her up all I get is a solid red LED. Any suggestions? Preciate it in advance.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-30-09 01:29 AM
  2. Richard Munch's Avatar
    I believe the usb adapter does not charge the storm as fast as the the wall adapter so don't be too worried
    05-30-09 01:32 AM
  3. bedlam454's Avatar
    If it's completely depleted, it will take quite some time to recharge.
    I had a similar instance & my LED remained red for a long time- I did a physical battery pull & that took care of it.
    Might want to try that after charging it for a while...
    05-30-09 01:55 AM
  4. chadric_g's Avatar
    So after hours of charging and several pulls I still get nothing. But it should be fine when I can finally get it to the wall charger.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-30-09 09:10 AM
  5. bmtenney's Avatar
    Is your batter display showing the charging icon?
    05-30-09 09:58 AM
  6. adidas1124's Avatar
    In order to charge a BB via USB you have to have desktop manager installed and running on the computer you are using power from...

    Posted from my CrackBerry at wapforums.crackberry.com
    05-30-09 11:51 AM
  7. arcanexvi's Avatar
    In order to charge a BB via USB you have to have desktop manager installed and running on the computer you are using power from...

    Posted from my CrackBerry at wapforums.crackberry.com
    not true

    10char
    05-30-09 12:12 PM
  8. deadlikeoscar's Avatar
    yes, definitely not true because I run Linux and it still charges my BB.
    05-30-09 12:32 PM
  9. Thenollyon's Avatar
    I have seen this before and it is almost like the battery got so low, it would not accept USB charging. Using the wall charger did the trick.

    There may have been one time I got it working but plugging into the PC via USB without the battery and then installed the battery after the fact. It is frustrating when it happens for sure. I remember pressing all of the buttons on the device, holding buttons down, pressing the lock button, etc. and it eventually came up on USB.
    05-30-09 12:37 PM
  10. Itaku's Avatar
    From what i've tested, when you first put the battery back in from a pull and the solid red comes on, it means the motion sensor is calibrating. When I keep moving the phone when its solid red it doesn't go off and doesn't start up. And when I stop moving it, it goes off and turns on. So try stop moving the phone?
    05-30-09 12:53 PM
  11. paulwright1's Avatar
    and just so you know, if you are using a USB hub it most likely will not charge you phone. Either plug into the wall or directly to a usb port on your computer. And yes a completely depleted battery will need to be plugged into the wall to be charged up.
    05-30-09 01:27 PM
  12. blueskyjunkie's Avatar
    Mine did this a couple weeks ago after I tried to charge it using my Xbox. I remember a lot of people advised to just plug it into the wall for a while, but I lost the piece with the prongs. If I remember correctly, I plugged my phone into my desktop and let it sit for about ten minutes. After a while, a battery charging icon appeared in the middle of the screen. I then did a battery pull and let it charge some more and eventually I turned it back on.
    05-30-09 01:37 PM
  13. blueskyjunkie's Avatar
    and just so you know, if you are using a USB hub it most likely will not charge you phone. Either plug into the wall or directly to a usb port on your computer. And yes a completely depleted battery will need to be plugged into the wall to be charged up.
    Not true. I lost my pronged piece for the wall charger while I was at a skydiving boogie a couple hundred miles from my house. I tried to use my Xbox to charge my Storm and this is what happened. I tried charging it with a laptop, and that wouldn't work, but when I plugged it into my desktop it worked just fine.
    05-30-09 01:39 PM
  14. paulwright1's Avatar
    Not true. I lost my pronged piece for the wall charger while I was at a skydiving boogie a couple hundred miles from my house. I tried to use my Xbox to charge my Storm and this is what happened. I tried charging it with a laptop, and that wouldn't work, but when I plugged it into my desktop it worked just fine.
    When mine died from being plugged into a USB hub I plugged it into my laptop and left it there for over an hour and nothing happened. So I plugged it into the wall and it started charging. Not sure if this has happened to anyone else but it did for me.
    05-30-09 09:17 PM
  15. blueskyjunkie's Avatar
    When mine died from being plugged into a USB hub I plugged it into my laptop and left it there for over an hour and nothing happened. So I plugged it into the wall and it started charging. Not sure if this has happened to anyone else but it did for me.
    It didn't work on my laptop either but it did with my desktop.
    05-30-09 09:49 PM
  16. chadric_g's Avatar
    I have seen this before and it is almost like the battery got so low, it would not accept USB charging. Using the wall charger did the trick.
    Yeah that's exactly what happened. Soon as I got home to my wall charger everything was back in order.
    05-31-09 02:52 AM
  17. awarren001's Avatar
    This is how joe says to fix.
    1. Pull battery.
    2. Plug in usb cable.
    3. Put in battery.
    4. When red led comes on pull battery replace battery
    5. Problem solved.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-31-09 03:18 AM
LINK TO POST COPIED TO CLIPBOARD