1. Switcher's Avatar
    Yesterday at work I opened my locker to check my phone for new email.
    The screen was black... Okay, so I was thinking my battery was dead, I tried to bring it back to life once I was home from work.

    I plugged it in and all what I saw was the red light blinking a few seconds and then in the center of the screen I saw a charging battery icon.
    Left it plugged in a while, but that screen would not go away.
    Plugged into my Mac and the Mac Desktop Manager froze on it.

    So I went to my local BB dealer, the device was purchased on eBay Germany and the dude behind the desk said that the BlackBerry Belgium probably would not look at it and would not fix it because it was purchased in Germany...

    So here I am, waiting for my Storm 2 to get back, don't know if it would be fixed or not. Device is like 7 months old. Been happy with it so far. Hope I can stay a happy BB user. We'll see... Lucky to own an 8520, so I am not without a BB.
    06-17-10 12:45 PM
  2. corymcnutt's Avatar
    Bummer...hope it works out for you.; seven months is nothing! I had a 16 month old Pearl that did that and it was fried - I had to buy a new one. Bought my Storm2 10/28 and it has work fine ever since.
    06-17-10 01:27 PM
  3. Switcher's Avatar
    Bummer...hope it works out for you.; seven months is nothing! I had a 16 month old Pearl that did that and it was fried - I had to buy a new one. Bought my Storm2 10/28 and it has work fine ever since.
    Thanks. Worst casa scenario is that I would have to ship it to BB Germany to fix it...

    Posted from my CrackBerry at wapforums.crackberry.com
    06-17-10 01:32 PM
  4. 1magine's Avatar
    Nope - just overly dead battery. Did you try a fresh battery? Happens to me all the time. Device wont boot in that state until battery is at like 20%
    06-17-10 02:29 PM
  5. Switcher's Avatar
    Nope - just overly dead battery. Did you try a fresh battery? Happens to me all the time. Device wont boot in that state until battery is at like 20%
    Just wondering how that is possible since it was charged overnight?
    06-17-10 02:39 PM
  6. 1magine's Avatar
    It happens. Try either 1. A fresh battery or 2. a battery pull and load into safe mode or 3. a bat pull and connect to a PC (not Mac)
    06-17-10 02:45 PM
  7. jwebste9's Avatar
    Ya i guy i worked with had that happen. his storm 1 died on way to work, so he tried charging all day and nothing. so he put the battery in out of another guys storm and it booted right up
    06-17-10 02:48 PM
  8. Switcher's Avatar
    It happens. Try either 1. A fresh battery or 2. a battery pull and load into safe mode or 3. a bat pull and connect to a PC (not Mac)
    Okay, thanks a lot for the info, as soon as I get the phone back I will try it!
    06-17-10 02:48 PM
  9. tabocaw's Avatar
    Same thing happened to me. I put my spare battery in and it booted up fine. I left the dead battery on charge later that night and it booted up about 4 hours later. Even at that it was only at 30%. Haven't had that problem since. But I don't let it discharge all the way anymore.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-17-10 03:41 PM
  10. keseaquist's Avatar
    In general,if the battery gets too low you have to pull the battery and then charge it for at least 20 mins (I would do so from a wall outlet) before the phone will boot up.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-18-10 12:03 AM
  11. collin16's Avatar
    I have never heard of that before, but if you are getting your charging icon then it doesnt seem to be completely dead.

    If charging it doesn't work then check out this guide on reloading your nuked berry!

    http://crackberry.com/blackberry-101...ked-blackberry
    06-18-10 03:11 AM
LINK TO POST COPIED TO CLIPBOARD