1. SwsFoe's Avatar
    When I first got it and was playing with it it took barely any weight to press the screen. Then I restored all my data from my old phone and now it feels like I need to press harder to actually get the screen to click. Am I just getting used to the amount of pressure needed to click the screen or did my old settings change something?
    05-17-10 05:40 PM
  2. bad_boy321's Avatar
    Could be a little of both. Might even be the theme you're running causing an issue.
    05-17-10 05:46 PM
  3. Mr. Orange 645's Avatar
    Do a security wipe and see if it softens back up. If it does, then that's your answer.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-17-10 06:07 PM
  4. WhoolioPreludee's Avatar
    Loosen the screw without the sticker a bit. That helped mines...

    Posted from my CrackBerry at wapforums.crackberry.com
    05-17-10 06:13 PM
  5. SwsFoe's Avatar
    Do a security wipe and see if it softens back up. If it does, then that's your answer.

    Posted from my CrackBerry at wapforums.crackberry.com
    Okay so it says that if I do a security wipe I will not be able to send or receive e-mails on the device if I do so. Is this permanent or just until I reenter the passwords for them?
    05-17-10 06:27 PM
  6. SK1's Avatar
    Okay so it says that if I do a security wipe I will not be able to send or receive e-mails on the device if I do so. Is this permanent or just until I reenter the passwords for them?
    You will have to reenter your email information for it to work again on your device.
    05-17-10 06:35 PM
  7. Thud Hardsmack's Avatar
    When I first got it and was playing with it it took barely any weight to press the screen. Then I restored all my data from my old phone and now it feels like I need to press harder to actually get the screen to click. Am I just getting used to the amount of pressure needed to click the screen or did my old settings change something?
    Mine did exactly this, and still does it after resets whether it be from a physical battery pull or app-initiated. Goes away in minutes.
    If you're still inside the 10 days you get before being billed for it, try it for a week as is and see if it's something that will bother you as time goes on. In my case it doesn't and the updated screen is a thousand times better than the device I originally had.
    This device is a refurb btw; the one I returned was brand-new.
    05-17-10 06:43 PM
  8. SwsFoe's Avatar
    Well I went into the verizon store and they swapped it there at no charge because it was under warranty and the screen stopped clicking on the bottom right corner. I just did a security wipe and it didn't set back to the soft click it had a few hours ago. Oh well I guess it is still a better click than my old screen I guess. Would of been nice if it stayed soft like that.
    05-17-10 07:33 PM
  9. Mr. Orange 645's Avatar
    I have two other suggestions:

    1. Like WhoolioPrel...whatever said, try adjusting the exposed torx screw under the battery cover.

    2. You might also try downgrading to OS .517, which IMO had a better feeling screen click. Like butter.
    05-17-10 08:09 PM
  10. SwsFoe's Avatar
    I have two other suggestions:

    1. Like WhoolioPrel...whatever said, try adjusting the exposed torx screw under the battery cover.

    2. You might also try downgrading to OS .517, which IMO had a better feeling screen click. Like butter.
    Does adjusting the screw void my warranty at all?
    05-17-10 09:34 PM
  11. WhoolioPreludee's Avatar
    Well don't tell vzw first or all. Second only play with the screw without the sticker. Do not even try to remove the sticker it will crack.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-17-10 10:03 PM
LINK TO POST COPIED TO CLIPBOARD