1. mbt12's Avatar
    I have been very happy with my storm, even though I just realized it runs a little slower than my friends. My biggest problem is the time it takes to open up the sms messages from someone.

    All the texts I get are able to open up pretty much right away, and when I send them they go through right away. My big issue is the texts I send to my girlfriend (who I text the most) take a lot longer. It takes a while to open up and sending takes much longer. Does anyone know what could cause this and if there is any way to fix it?

    She has an iphone and I thought that may be the issue at first, but I have texted other people with the iphone and it is much faster. I would really appreciate it if someone could help
    01-18-09 11:13 PM
  2. howardb's Avatar
    Best bet is to do a full backup and then wipe handset and give things a test. Then start restoring things slowly like your SMSs first and see if it gets slower.
    01-18-09 11:19 PM
  3. mbt12's Avatar
    Has anyone else had this problem and were able to fix it?
    01-19-09 10:34 AM
  4. atang79's Avatar
    Your girlfriend has an iPhone so I assume she's on AT&T. There's the issue not the phone. Most of my friends use AT&T, and I have realized there is a lag between the time the SMS is sent before it is received. There's no fix. Verizon to Verizon is immediate.
    01-19-09 10:39 AM
  5. anon(96573)'s Avatar
    What OS are you running?
    01-19-09 10:40 AM
  6. mbt12's Avatar
    I am running the official .75. And I thought AT&T may be the problem but when sending to other people on there it works fine
    01-19-09 10:56 AM
  7. atang79's Avatar
    There's no formula that makes the SMS sent or received immediate. The lag is normally about a minute or two, but I remember over the summer, the delay was sometimes 10 minutes. There's no "fix" to this problem. Get your girlfriend on Verizon or switch to AT&T! LOL!
    01-19-09 10:59 AM
  8. jjd228's Avatar
    The OP's complaint was that it takes a long time to "open up" sms messages. What would that have to do with the carrier? If you have more texts saved on your phone from your girlfriend than from anyone else, this could be the problem. Try deleting older messages. But really, what are we talking about here? A second or 2? Does it take 30 seconds or more to open a message? THAT would be an issue. If it's just a second or 2, delete all your old messages and reboot.
    01-19-09 11:04 AM
  9. mbt12's Avatar
    It takes about 10-15 seconds to open up new ones and to send them, but only to her. Everyone else it opens and sends almost right away. I periodically delete all messages and it doesn't seem to help.
    Last edited by mbt12; 01-19-09 at 11:16 AM.
    01-19-09 11:10 AM
  10. jjd228's Avatar
    Makes no sense. Do a backup and then wipe and reinstall the OS. See if it still happens. If not, restore all your messages databases and see if it happens again.
    01-19-09 11:24 AM
  11. randumbthots's Avatar
    well i must say this must've been
    the reason why i got no replies to my threat
    with the same exact issue. i text my gf the most
    and it gives me the 15 second delay to open
    and send a text. i hate it, i always have to delete
    all her texts when they go above 50 or so. your not
    the only one, im installing OS.99 as we speak, hopefully
    this resolves the issue.
    02-03-09 02:44 AM
  12. xLife's Avatar
    The only time I ever get lag opening a message is when I have a lot that I havent deleted and when I do delete them it goes faster. There really shouldn't be a 15 second delay though, maybe you have too many things running. Like someone said just reboot and see if its faster. If not I would call some people.
    02-03-09 02:50 AM
  13. randumbthots's Avatar
    right.. thats the issue, i have alot from my griflriend, and there really is
    a 10-15 second lag with opening a new one and sending one. i just finished
    updating to .99 and my display doesnt seem as smooth as it was before.
    02-03-09 02:54 AM
  14. tarheeltri's Avatar
    I've had this same problem, and determined that its only slow when i text people that ive texted a whole lot. in the past, ive done a device reset, and that has worked. however, two days ago, i deleted all of my SMS's and it started working great again...try deleting all or some of the messages from your girlfriend (use search (4) then delete prior)
    03-14-09 07:16 PM
  15. sinfuldragon's Avatar
    if the only issue he sees is with his GF and not other AT&T users then why would everyone think that its his phone?

    Does she see an issue with all other people txting her? maybe its an issue with her line/phone/service/etc.
    03-14-09 07:32 PM
  16. kgle's Avatar
    Because he isn't talking about how long it takes her to receive a text or how long it takes him to receive one from her, but how long it actually takes the actual application to send it through from his phone before it bumps him back to the SMS log.
    03-24-09 01:03 AM
LINK TO POST COPIED TO CLIPBOARD