1. JsGrandma's Avatar
    My phone rings 2 times and then goes to "missed call" or "voice mail"......is there a way to set it to ring for say 4 times or more before hanging up? Lovin' my Storm otherwise!

    12-10-08 08:56 PM
  2. Terminatorbob's Avatar
    I would like to know as well. This is one of the few real issues I'm having.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-10-08 09:06 PM
  3. buckifvr's Avatar
    Ditto, I too would like a little more time to answer my phone.
    12-10-08 09:33 PM
  4. phillypharm's Avatar
    i don't think it's the problem of ringing longer, but something about the connection. i've called my storm from my house line. i can hear it ringing thru the earpiece, but there's quite a long delay b4 the phone rings (even a delay from when the vibe starts). if i called my voyager, it would go thru within 2 seconds, but with the storm, it takes a good 10 seconds or even 15 b/c the phone receives a call. by that time, either the caller hangs up after another 10 seconds or it goes to voicemail by 30 seconds of calling (only 15 seconds of teh phone ringing)
    12-10-08 09:37 PM
  5. hal1's Avatar

    Call Verizon, THEY can program your incoming calls to ring (what the caller hears) from 1 to 8 times, which equals 5 to 40 seconds, before going to voice mail.

    I'm pretty sure that THEY must set it up.
    12-10-08 09:56 PM
  6. blackwidowinsc's Avatar
    Your ring time shouldn't have changed because you traded out devices. Have you called your phone to hear how many times it rings before the call goes to vmail? The caller may hear it ring four or more times but your device may only ring twice based on the ringer you have. I would complete that test before calling to try to have the ring time extended.
    12-10-08 10:12 PM
  7. alabamr's Avatar
    The problem is there is a pause before it starts ringing where it would vibrate, then it rings, then pause where vibrate would be, etc. so it takes a long time. If you get a longer ringtone, it will play longer. Something like this, 30 seconds of ringing, before it would start over.

    There was a post here a few weeks ago about it, but I can't find it atm.
    12-10-08 10:16 PM
  8. WTVA's Avatar
    I too would like to be able to adjust this too. I know with my old WM device there was a way to go into a phone feature menu by doing a *number number thing and setting how often your phone polls the cell towers this does have a bad side of taken a slight battery hit to increase how fast the actual call comes through to your phone no matter what ringer you have set, I know on my WM device it used to ring like 2-3 times for the end user before going to VM or missed call on the phone. I just wish we knew how to get into this setting on the storm.
    12-10-08 10:28 PM
  9. uniqueinvestor's Avatar
    i had the same issue..

    So, I called Tmobile.. extended mine to 30 seconds,that was the longest they have, rep said they normally set them to 20 seconds.. gave me a code to type into the phone.. and BAM! 30 seconds..

    after 2 tests.. it rings about 32-33 seconds.. long enough now for me to answer
    12-10-08 11:28 PM
  10. kbluna's Avatar
    I have mine set to 1 min so that people aren't leaving me voice mails every ten seconds. You just have to call and request it.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-11-08 05:28 AM
  11. jonnybb1's Avatar
    Just an FYI, I've been fighting with Sprint about this very issue for the last 2 months. When you call my BB Curve8330 from a LL, it takes anywhere from 2-3 rings before my device wakes up and starts ringing.

    I am a service contractor and am all over SoCal so towers are not the issue.

    I have an understanding with Ethel Buckle and Scott at Sprint (in Customer Care and the Tech Support Dept) that if I'm not happy with either setting up ring-back caller tones, or if I'm happier with another carrier's BB service, I can cancel w/o an ETF. So I am truly going to see what happens.

    IMHO, I beleive these phones rely too much on pushing data and do not focus on the phone call quality. We are all acting like sheep when we allow these companies to go on this long with these types of problems with speaking out.

    There is nothing wrong with your phone people! There is a flaw in these networks that cause the devices to have a long ring delay!

    Wake up! Get mad and call your carrier today. I'll bet the president's BB doesn;t have a ring delay!
    01-20-09 05:51 PM
  12. jeepguy_1980's Avatar
    It's the phone, not the network. My phone vibrates, rings once, and then keeps vibrating. I need to figure out how to fix this.

    Edit: There may be a carrier option. But my phone knows a call is coming in for a much longer period of time than it actually rings.
    Last edited by jeepguy_1980; 01-20-09 at 08:03 PM.
    01-20-09 07:58 PM
  13. backsidetailslide's Avatar
    i would love to know this as well. although i always thought i was up to the carrier
    01-20-09 08:01 PM
  14. cfbrew2's Avatar
    I had that problem, my phone would not show an incoming call until the caller had heard 3 rings. I had Verizon update the system registry and it now shows a call on the first ring.
    02-10-09 01:31 PM
  15. t16tomcat's Avatar
    For vodaphone uk you enter in the dialing section on your phone the following code:
    *61*121*11*30# then push send. nothing much happens to acknowledge this but your ring lasts longer. The 30 is the period you want it to ring ie 30 seconds but this can be varied between 0 and 30 but no longer. not sure codes are the same for other providers, but 121 is the voice mail for vodaphone uk, so maybe you may need to enter your own voicemail number in this section on other providers?
    06-17-10 04:03 AM
  16. bigbadwulff's Avatar
    This was one reason I quit Verizon in the past. Because my phone would never ring but I'd have a message that i got a call. And now I find out THEY can change this after I pitched a fit to them to do something?

    06-17-10 11:34 AM