1. missyzane's Avatar
    I've had my storm 2 for about 2 months or less. Never removed the SD card. Yesterday a sd card error kept popping up and I don't remember exactly what it said. I thought it was something like my sd card has been removed.

    I took a few pics and they still went to my sd card, then suddenly they began going to device memory and now nothing from sd card shows up on my storm. I did numerous battery pulls, nothing. Removed and inserted sd card again, nothing. Repaired it on phone, nothing.

    However, everything from my sd card DOES show up on my PC.

    Help Any ideas?
    05-09-10 08:21 AM
  2. dkingsf's Avatar
    Suggest you copy everything from the SD card to your PC and the reformat the card. I believe that will fix it. Probably just a card error and reformatting it should fix it.
    05-09-10 08:42 AM
  3. kazmi's Avatar
    Things to check:

    • It shows up when you attach the BB to the PC and go through DM?
    • Have you checked to see if its properly placed in the storm?
    • Mass storage mode enabled?


    I think the safest thing to do would be to make a backup of the entire card on your PC, double check to ensure you copied all the contents, and then format the card while in the BB...you can do that through Options>Memory and then hit menu key> Format...once that is done, copy the contents back to the SD card....
    05-09-10 08:47 AM
  4. dkingsf's Avatar
    Thanks for the extra typing to say the exact same thing I said 5 minutes before. I'm sure she understands better now.
    05-09-10 09:01 AM
  5. kazmi's Avatar
    Thanks for the extra typing to say the exact same thing I said 5 minutes before. I'm sure she understands better now.
    easy there big fella - by the time I posted, I guess you already had...I'm glad you were able to help her.
    05-09-10 09:10 AM
  6. missyzane's Avatar
    Thanks everyone for your help. I'm going to try that later today and will let you know if it works...but first, have to celebrate mothers day.
    05-09-10 09:44 AM
  7. missyzane's Avatar
    Well I tried to format the sd card while in the blackberry. It only formats my device memory?? Everything is still on my card? I love my phone but I really hate when something goes wrong...I'm so lost as to how to fix these things.

    Any other ideas for me? Do I need a new phone?....lol that would be so much easier if Verizon will just give me one
    05-09-10 07:34 PM
  8. dkingsf's Avatar
    options-memory- select the media card (highlight it, where it shows the total memory), BB menu, format. If you got everything off the SD card, you can also format it with your PC, the BB then should configure it when you put it back in.
    Last edited by dkingsf; 05-09-10 at 07:46 PM.
    05-09-10 07:42 PM
  9. missyzane's Avatar
    UNBELIEVABLE!!

    I fixed it. As I said..when my bb stopped detecting my sd card...I had not removed it or even removed the back of my bb in over a week. I've NEVER taken the sd card out at all.

    Anyhow...I was at my wits end, had the options -memory screen on and at the bottom is said no sd card is in the device. So I just kept sliding sd card in and out a few times and suddenly....it says media card is inserted and there were all of my pics/ringtones etc..

    Just craziness

    Thanks to you both for trying to help me, leave it to me to have such a goofy problem.
    05-09-10 07:44 PM
  10. missyzane's Avatar
    options-memory- select the media card (highlight it), BB menu, format.
    Okay, I see. My phone wasn't detecting the card at all so that option wasn't there. I'm sure it's there now but I won't even look, with my luck i'd accidentally format it now that my problems resolved
    05-09-10 07:46 PM
LINK TO POST COPIED TO CLIPBOARD