1. mikevickers10's Avatar
    Last night, ive run into this problem. When i turn on my phone, the touch screen works perfect, then when i let it go into like sleep mode( screen turns off when not in use mode) it wont come back on with touch of the screen or ANY key.. Only way for me to use the screen again is if i do a battery pull and then the same thing happens.. Any ideas for me here? Ive already tried doing a restore from about a month ago.. no luck
    07-19-10 09:10 PM
  2. MRHommel's Avatar
    Mine just started doing the exact same thing today. It works for a little bit then goes crazy. Before the screen stops working theres static lines and stuff. Like its under super lag.
    07-19-10 10:19 PM
  3. mikevickers10's Avatar
    Id love help within the next 12 hours before i do buy a bran new one as its not under warranty anymore lol Thanks in advance!
    07-19-10 10:28 PM
  4. MRHommel's Avatar
    I read on another post that it was the humidity. I know it was really hot where I live and it was in my pocket while I was outside working. I'm home now in teh A/C so I will let you know how my phone has turned out. We you in a similar heat situation?
    07-19-10 10:59 PM
  5. MRHommel's Avatar
    Heres the link to where I read the humidity issue.

    http://forums.crackberry.com/f86/sto...onsive-497845/
    07-19-10 11:00 PM
  6. MRHommel's Avatar
    Well, its been in the A/C for over 2 hours now, and its still the same. IDK what is going on. But its annoying.
    07-19-10 11:50 PM
LINK TO POST COPIED TO CLIPBOARD