1. 1magine's Avatar
    Storm2 9550 has native hardware support for RTSP streaming 3GP (AAC) http://docs.blackberry.com/en/smartp...martphones.pdf and yet all sites I try with RTSP (3GP AAC) fail to play.

    Anyone using an S2 and able to stream 3GP AAC? If so what OS and browser configuration?

    Orb = fail.
    Cisco test = fail.

    Verizon has no answer - their S2 would not stream RTSP audio or video.
    RIM Level 1 has no answer - ditto. Waiting on RIM level 2. Seriously? How can a device and an OS be pushed out and fail to have stated functionality almost a year later?
    07-08-10 02:00 PM
  2. ratsttam's Avatar
    This might be a silly question, but are those AAC files DRM free? IE: will older files play, and suddenly newer ones (or from a different source) won't play?
    07-08-10 02:21 PM
  3. 1magine's Avatar
    Answer is.....

    Doesn't work. Despite RTSP 3GP being a supported format for multiple RIM devices, apparently something in the latest round of software for several devices breaks this. WOOPS. So sorry - did you want that to work?

    RIM reports that they are working on the issue but I was generally instructed not to hold my breath for a fix. Neither level 1 or 2 suppot was even aware of an RIM RTSP server for testing streaming media. Nice. Maybe its not something they even bother to test. Given how buggy the best of their software is, I wouldn't be surprised.
    07-08-10 03:34 PM
  4. Fnord's Avatar
    I have gotten clips to play off an RTSP server, but it seems to be hit or miss.

    I've had the exact same clip work at one time and fail another. Seems finicky at best.
    07-08-10 04:05 PM
  5. titusilvering's Avatar
    Can provide any link? I can help to test see if mine work or not.
    07-08-10 10:28 PM
  6. 1magine's Avatar
    test.orb.com
    07-09-10 10:34 AM
  7. Fnord's Avatar
    I've PM'd you guys with a direct RTSP link you can try.

    Let me know if it works??
    07-09-10 10:48 AM
  8. hydroz_23's Avatar
    Yes test.orb.com fails but orb does work. I use it to watch the tv tuner on my hp laptop but can also look at videos on my pc and look at any photos, music or docs. I can also view my webcam. This is what i do to make it work

    open bb browser

    go to Orb and login

    Click new speed test



    Click on settings>stream>3GP-AAC/RTSP format (.3GP)

    07-09-10 11:30 AM
  9. 1magine's Avatar
    IV been doing this. What are your browser settings? BES or BIS? I get photos and docs. Audio and video fail to play. What OS are you using?

    Posted from my CrackBerry at wapforums.crackberry.com
    07-09-10 11:37 AM
  10. hydroz_23's Avatar
    IV been doing this. What are your browser settings? BES or BIS? I get photos and docs. Audio and video fail to play. What OS are you using?

    Posted from my CrackBerry at wapforums.crackberry.com
    I am using BIS. 5.0.0.713 but have used it on other OS's too
    Windows 7 Ultimate X64
    Last edited by hydroz_23; 07-09-10 at 11:43 AM.
    07-09-10 11:40 AM
  11. hydroz_23's Avatar
    I just verified that it was just not only my tv tuner working. I have a video in my documents that i browsed to with the file browser and it opens and plays perfectly. I can also open a movie right from my dvd drive
    07-09-10 11:42 AM
  12. 1magine's Avatar
    So you are using iE browser. What do you identify as? BB iE or firefox. Javascript?
    07-09-10 11:44 AM
  13. hydroz_23's Avatar
    So you are using iE browser. What do you identify as? BB iE or firefox. Javascript?
    Same results with bb or firefox with default settings. Just tried both
    07-09-10 11:46 AM
  14. 1magine's Avatar
    Going to PM you momentarily with a temp login to my orb. If you steam ok then its either a corrupted Os or my device.
    07-09-10 11:47 AM
  15. hydroz_23's Avatar
    Going to PM you momentarily with a temp login to my orb. If you steam ok then its either a corrupted Os or my device.
    Cool. Have you updated orb recently? There are few updates recently
    07-09-10 11:48 AM
  16. 1magine's Avatar
    latest orb running PM sent.
    07-09-10 11:57 AM
  17. hydroz_23's Avatar
    latest orb running PM sent.
    Hmm weird. I can see the files but and they open but no sound. With the same settings as mine it does not work

    EDIT. Have you tried to login in mycast.orb on you pc and open a file that way to see if it works?
    Last edited by hydroz_23; 07-09-10 at 12:06 PM.
    07-09-10 12:03 PM
  18. 1magine's Avatar
    Weirder is - I get them to load but they never open! It will show whether audio or video the amount of time but they never play. So maybe its the PC? But truly odd thing is it works on other PCs and my son's Incredible.

    I've tried streaming from both an XP and a WIN7 64bit OS.

    And just to confirm, video and audio both played, but you could not hear the audio?
    07-09-10 12:08 PM
  19. hydroz_23's Avatar
    Weirder is - I get them to load but they never open! It will show whether audio or video the amount of time but they never play. So maybe its the PC? But truly odd thing is it works on other PCs and my son's Incredible.

    I've tried streaming from both an XP and a WIN7 64bit OS.

    And just to confirm, video and audio both played, but you could not hear the audio?
    Dont change your password yet

    EDit. Nevermind
    07-09-10 12:10 PM
  20. hydroz_23's Avatar
    Click on these links on your phone. The first one is a audio file from my pc and the second is a video

    http://mycast.orb.com/orb/data/2CFDB...mp3/stream.sdp

    http://mycast.orb.com/orb/data/2CFDB...VOB/stream.sdp
    07-09-10 12:18 PM
  21. 1magine's Avatar
    Audio and video play using an Incredible. Audio and video play using any PC. I get nothing using my BB. You also were unable to stream from my Orb PC to your BB? I would think that it was my Orb installation causing some kind of encoding error if it wasn't for the fact that I can not stream from either my home (Win7 64 Ult) or from my office (Win XP SP3). Very frustrating.
    07-09-10 12:19 PM
  22. hydroz_23's Avatar
    Audio and video play using an Incredible. Audio and video play using any PC. I get nothing using my BB. You also were unable to stream from my Orb PC to your BB? I would think that it was my Orb installation causing some kind of encoding error if it wasn't for the fact that I can not stream from either my home (Win7 64 Ult) or from my office (Win XP SP3). Very frustrating.
    Yes it did not work. Click on my links above and that will completely bypass your pc and see if that works
    07-09-10 12:20 PM
  23. 1magine's Avatar
    Audio works - good tune!

    Video - works - Super Bad - looks Super Good.
    07-09-10 12:33 PM
  24. 1magine's Avatar
    Must be an Orb setting on my PCs?
    07-09-10 12:34 PM
  25. hydroz_23's Avatar
    Must be an Orb setting on my PCs?
    Yeah i would start with that. Uninstall/Reinstall
    07-09-10 12:35 PM
LINK TO POST COPIED TO CLIPBOARD