1. itsallsubliminal's Avatar
    I love the bb browser, I prefer it hands down over opera mini and bolt, but sometimes it gets stuck on "Requesting..." far too long for a Rev A network. I eas a winmo user for 3 years and opera mobile stomped on all other browsers. I'm not a fan of opera mini cuz all it really does is generate a "picture" of the site for you, making many sites unusable, for example my colleges website and login just polls errors.

    Don't get me wrong, this is my first bb and I love the thing. There are lot of people here ranting about how unstable the storm is, obviously they have never own a windows mobile device and have hi expectations. The storm is a solid device.

    So anyways, is there anything I can do to not deal with "requesting" being such a lag? I'm using radio 132 on a 141/5.0 hybrid.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-17-09 02:17 PM
  2. h20work's Avatar
    Yep, try the link a 2nd time. Usually goes right through for me.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-17-09 04:23 PM
  3. itsallsubliminal's Avatar
    Yep, try the link a 2nd time. Usually goes right through for me.

    Posted from my CrackBerry at wapforums.crackberry.com
    Yeah I end up doin that but its still a tad inconvenient and sometimes still lags. I'm hoping they update the browser along with the rest of the os.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-17-09 04:36 PM
  4. jakeh0's Avatar
    happens to me a lot, will load like 21 out of 22 images and then hang there
    05-17-09 08:03 PM
  5. Duderotamy's Avatar
    I came to a Storm from a Motorola Q with WindowsMobile and Verizon. The browser on the Q was so much fast. I've always assumed it was because BB allows Java and scripts.
    05-17-09 09:54 PM
  6. itsallsubliminal's Avatar
    I just ran a speed test using the speed test app and i got 497kbps down. That is no where near Rev A speeds. On my sprint touch pro and diamond, i would run 1100-1200kbps easily. The Verizon and Sprint Rev A EVDO Network are basically identical.

    So its definitely a radio issue with the Storm.

    But, blackberry's have that beautiful thing about them which recieves emails the instant they enter your mail box, as apposed to windows mobile which has to check for new emails at user-specified intervals.

    Maybe that is the issue? The radio in blackberries are being utilized much more than other devices due to its "Elite" email capabilities?

    I dunno, just pouring out thoughts

    Just a question: Does every new OS have a new radio with it?
    05-18-09 11:16 AM
  7. izsharp's Avatar
    Yeah, I'm a fan of the built in browser too. When I'm having major speed problems, however, I toggle my wireless connection on/off and it seems to help. Kind of like an internet battery pull! Who knows if anything is actually happening...
    05-18-09 12:04 PM
  8. itsallsubliminal's Avatar
    Yeah, I'm a fan of the built in browser too. When I'm having major speed problems, however, I toggle my wireless connection on/off and it seems to help. Kind of like an internet battery pull! Who knows if anything is actually happening...
    probably gives it a little refresh. I'll give that a try and if i see it actually helpin out, it would be nice to set that to a convenience key/button, I use the browser A LOT.
    05-18-09 12:46 PM
LINK TO POST COPIED TO CLIPBOARD