1. JsWoRLd316's Avatar
    How you guys doing?

    Ok this is my situation. I have a blackberry curve from tmobile. My sister got a new phone so she gave me her blackberry storm 9350. I went to a cell phone shop around my area and they unlocked the storm so i can use it with my tmobile sim card. I put on the sim card and i thought everything was working perfect but then i found out that i have multiple problem.

    The good: I can make calls, i can use the internet.

    The bad: when i place a call my sister number appears in the other person phone (not my tmobile number), i cant call my voicemail, cant setup my email, cant receive calls and more problems i still havent discovered lol.

    Can you guys please help me out and advise me of what should i do. Thanks in advance.
    04-25-10 04:35 PM
  2. Laura Knotek's Avatar
    Your sister needs to contact Verizon to release the PIN.
    04-25-10 04:43 PM
  3. JsWoRLd316's Avatar
    thanks for the reply. I got the PIN, whats the next step.
    04-25-10 05:11 PM
  4. Laura Knotek's Avatar
    04-25-10 05:14 PM
  5. Roweazie's Avatar
    To change the "my number", dial ##000000 then select send.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-25-10 05:17 PM
  6. JsWoRLd316's Avatar
    Oh boy, the problems are now worst. I followed all the instruction posted here HowTo:Get All Features (Browser, MMS) Working on T-Mobile w/Unlocked Storm 95xx, and now i cant use the browser, before i did this i was able to do it. I need help guys i dont now what to do. I still cant receive calls but i can make calls (my number still does not come out). I also changed the number by dialing ##000000. What should i do guys?
    04-25-10 08:17 PM
  7. JsWoRLd316's Avatar
    Are there any futher steps/options I can do to resolve this problem? Thank you guys.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-26-10 03:54 PM
  8. k8108's Avatar
    #1 step - did you do a battery pull?

    Do you have your phone listed on my.t-mobile as a Curve 8900?

    Try resending the service books.

    Restart your computer and try the process with CrackUtil again.

    Worst case scenario, re-install/upgrade your operating systerm and do the CrackUtil process again.
    04-26-10 04:25 PM
  9. JsWoRLd316's Avatar
    Yes I still have my phone as a curve on the tmobile site, what should I change it to? I will re-do all the steps later on tonight. Hopefully it works out. Hopefully everything works out. Any other inputs? Thanks

    Posted from my CrackBerry at wapforums.crackberry.com
    04-26-10 04:49 PM
  10. k8108's Avatar
    Yes I still have my phone as a curve on the tmobile site, what should I change it to? I will re-do all the steps later on tonight. Hopefully it works out. Hopefully everything works out. Any other inputs? Thanks

    Posted from my CrackBerry at wapforums.crackberry.com
    Don't change your phone to anything else. Since the Storm isn't a Tmo phone, you need to have the Curve there so you can access the BIS section (to monitor emails, etc.)

    Good luck with it all.
    04-26-10 05:21 PM
  11. b4k3d's Avatar
    1- From your Phone dial ##000000 press send. In the menu, change the mobile directory # with your cell # and select save. The phone will reboot.

    2- Log on to your T-Mobile account and change your phone to a 9700

    3- While in your account go into set up your email. look to the left and select "Change device"

    4- Input your S2's pin and IMEI and save.

    5- From your phone go to Options> Advanced Options> TCP> Now Change your APN to WAP.Voicestream.com (leave the User name and Password empty)

    6- Reboot your device

    7- Resend your service books

    8- Reboot your device

    This should solve your issues : ) I have unlocked several S2's and have done this exact process without having to use Crackutil or manually input service books. Give it a shot and I hope this helps!
    Last edited by b4k3d; 04-26-10 at 06:24 PM. Reason: Spell check for the anal watchdogs...
    04-26-10 06:17 PM
  12. JsWoRLd316's Avatar
    thanks for the reply bro. But im having no luck with this setup, i thought it would be much easier. When i go to the tmobile site to setup my email, when i put the pin and imei of the storm it tells me the following: "The information provided is not valid for this service provider". Is there away i can start from zero and do this entire thing all over? I mean the only good thing is that i can make calls from my tmobile sim card but it makes no sense because my number does not come out. Also when i dial ##000000 the mobile directory # is my number but the line below "IMSI_S #: my sisters phone comes out. when i changed it to my number, i was unable to make calls, until i changed it to my sister number. This is so confusing ughhh!!!!!!!
    04-26-10 09:56 PM
  13. b4k3d's Avatar
    Were you able to get the pin released from Verizon?

    By the way there was one more step that I missed. Did you force the phone to work on 2G?

    Posted from my CrackBerry at wapforums.crackberry.com
    04-26-10 10:37 PM
  14. JsWoRLd316's Avatar
    I finally did it bro, i was screwing around with the setting and watched a video on youtube on how to setup an unlock blackberry. I went into option/advance/sim and then typed MEPD n then inactivated the sim, rebooted and bam!! lol. Thanks for your time man, appreciated.
    04-26-10 10:47 PM
  15. JsWoRLd316's Avatar
    oh yeah the only problem i have right now is the email, for some reason i cant change my device email on the tmobile site.
    04-26-10 10:48 PM
  16. b4k3d's Avatar
    Well I'm glad you got to fix it! Try logging out and back in from the site. Are you able to change the email from your bb?

    Posted from my CrackBerry at wapforums.crackberry.com
    04-26-10 11:16 PM
LINK TO POST COPIED TO CLIPBOARD