1. kkwatson's Avatar
    Anyone else having a problem with he otter box? every time I put my storm in the cast (even just the bottom part of the case) it becomes non responsive
    02-02-09 10:30 PM
  2. jamesandyori's Avatar
    Did you do a search first?

    I did: http://forums.crackberry.com/f86/otterbox-sale-147385/

    Check here for a install video and review, of a successful install on a Storm.
    02-02-09 10:42 PM
  3. kkwatson's Avatar
    No the title said otter box for sale. Can you help with this problem, contribute to a solution or are you just posting to tell me to do a search first.
    02-02-09 10:51 PM
  4. jamesandyori's Avatar
    Oh my gosh, read the dang thread! LOL

    Please tell me you just didn't read the title and come back to complain that I'm not helping ya.
    02-02-09 11:37 PM
  5. kkwatson's Avatar
    No, I was calling you an *** for even answering it with a do a serch comment. LOL
    02-03-09 12:33 AM
  6. Ultrafied's Avatar
    No, I was calling you an *** for even answering it with a do a serch comment. LOL
    Wheeewww ... makes ya wanna just jump right in and help with that attitude!!!
    02-03-09 01:04 AM
  7. icmedia's Avatar
    No, I was calling you an *** for even answering it with a do a serch comment. LOL

    What did you expect...someone to totally repost the install video? Lol... If you knew someone would chastise you for not doing your own research (and even admitting you chose not to read that thread), why get so offended.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-03-09 01:17 AM
  8. kkwatson's Avatar
    I know how to install it, There is a problem with the case. You guys must have loads of time on your hands. Trolling treads commenting on others posts but adding nothing about the topic. just commenting on the post itself. If you work for the site great if not (and this is with no attitude) get a life. Hey, On a up note. have a great day.
    02-03-09 06:26 AM
  9. moviemogul's Avatar
    Dude, you are the first person to have a problem with it. The case has been released for less than a week. One other person has received theirs. I don't receive mine until tomorrow.

    You could've made a post in the thread already made.

    Honestly, you would have better luck contacting otterbox themselves since we haven't really had time to check it out yet.

    At the moment, since according to the video, it's installed correctly, I would have to say you have done something incorrect.

    Do you have an invisible shield, or some sort of screen protector?

    When you say unresponsive, is it just the screen, or the hard buttons too?
    02-03-09 06:45 AM
  10. nshorvath's Avatar
    I know how to install it.
    Obviously not. You also don't know how to research, accept help, and not be an as s hat. You sir have failed.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-03-09 07:00 AM
  11. stoneynumbnuts's Avatar
    Anyone else having a problem with he otter box? every time I put my storm in the cast (even just the bottom part of the case) it becomes non responsive
    I have not had that problem. But the two problems I have is it is next to impossible to use the buttons on the edge of the screen due to the case. Overlapping the screen
    And being raised so that you can't touch edge buttons. Particularly tough to type a message in landscape mode. 2. The watermark on the screen. Tried the baby powder trick they say you can't see the powder but in the sun it is very visible. Looks like dirt on your screen. Hard to see in direct sun. The added protection is nice but overall not real happy with the ob. The typing problem is very annoying. Just my opinion

    Posted from my CrackBerry at wapforums.crackberry.com
    02-03-09 09:48 AM
  12. mattallsop's Avatar
    Is it possible too have an invisible shield on the storm and an otter box over it??

    Had an IS for months now and like what its doing, otter box would be great when needed.
    But wouldn't live on my berry 24/7. Did do a search but couldn't find any responses about the combo.

    Cheers

    Posted from my CrackBerry at wapforums.crackberry.com
    02-25-09 02:59 AM
  13. dkb2's Avatar
    I have the same problem with my Storm when placed in the OB. I sent an email to Otter box and they sent me a new one. Same problem, new case. My friends Storm works fine in the same case mine does not. I can only think that there are some production variations in the storm production.
    05-23-09 04:31 AM
  14. bearkat38's Avatar
    I have the same problem with my Storm when placed in the OB. I sent an email to Otter box and they sent me a new one. Same problem, new case. My friends Storm works fine in the same case mine does not. I can only think that there are some production variations in the storm production.
    No problems here. Mine works great!
    05-23-09 04:33 AM
LINK TO POST COPIED TO CLIPBOARD