1. farkas_levi's Avatar
    Hello,



    I had many problems with my 9500 firmware, so i tried to upgrade it. Unfortunately my device didn't want to be upgraded, so i decided to help it by "wipeing" the OS with JL_CMDER. I did that, everything looked ok untill i had to install the new firmware to the blank device. Here i am getting an error when pressing the last Next button in the upgrade procedure saying: Invalid Configuration! The application "Email Setup Application" cannot be loaded because some required files are not available. I tryed many(4) offical and unofficial releases of the firmware, but no luck.



    I checked in c:\program files\common files\research in motion\shared\loader files\%relese name%\ and all of the firmware versions that i tried had the required .alx files. I deleted BISthickClient.alx from the above mentioned folder, than it jumped to the next error stating the same message for the Core application components, these ones i needed for the install so there was no point in deleteing them.



    I am stuck at this step. Anybody could help me out? My device was one of the first released so it had firmware 4.7.0.45... so you can't blaim me for these desperate measures for upgrading...



    Thank you!
    02-05-09 12:08 PM
  2. superaj's Avatar
    02-05-09 12:10 PM
  3. farkas_levi's Avatar
    No luck.

    i tried the /nojvm thing, the battery pull thing... still no luck, now the device does not see the new firmware anymore, it says that there is no newer version.

    Any other ideas?
    02-05-09 01:57 PM
  4. farkas_levi's Avatar
    Hi,



    I don't think that the DM or loader or Windows is the issue here... Since everything works fine even from DM, not using loader.exe until I press next to deploy the OS on the device. That is when I get the error: Invalid Configuration! The application "Email Setup Application" cannot be loaded because some required files are not available.

    I think that the problem could be from the OS I try to deploy (not complete with all the files) or something with the device...

    I can't revert to any OLD OS and I can't upgrade either...



    Is there another way to copy the OS from a working device to the wiped one?
    02-06-09 05:28 AM
  5. TheMisses's Avatar
    Please, do exactly what I type, do not think that you can skip a step please... Yes some will be unnecessary but if you want it to work do it like this. If it then doesn't work, send it for repair:

    Remove ALL Storm related software from your system and REBOOT. Then reinstall from CD. DM 4.7 build 32 should be included with the Storm. If not, download the version from the RIM website. Then download the .100 OS from the .100 thread on this forum. Reboot your PC before installing the OS on your PC. After reboot make sure the DM is closed and install the OS on your PC. Remove the battery, start the DM, goto apploader and make sure the screen in which you normally select your pin and type in a password if necessary is standing by and connect your device to the pc with the cable. The light will turn red and you will be able to connect one way or another. Quickly select the OS to install and DO NOT GOTO THE OPTIONS SCREEN to select other things to install on your phone but QUICKLY and without hesitation or delay (important: mind over matter attitude :P ) click through so the first files are going to get loaded on it. BEFORE the bar turns blue for the first time (actually before the device gets the chance to reboot) make sure the battery is put back in again. Wait. Use your device

    Please do it like this. Not any other way and report back.
    02-06-09 01:13 PM
  6. farkas_levi's Avatar
    Hi,

    I followed the steps exactley as you wrote. The issue is that with .100 installed the DM says that i have no updates to install and the only option is to go back in the wizard.
    02-09-09 04:09 AM
  7. arifjk's Avatar
    Try all of those steps again, but when you connect your device to DM to install OS to your device, make sure you TURNED OFF the internet connection.

    let me know how it works.
    02-09-09 01:19 PM
  8. farkas_levi's Avatar
    I tried everything. No luck...

    I got anoyed and sent back the device to RIM. I am curios about their diagnostic...
    02-10-09 03:48 AM
LINK TO POST COPIED TO CLIPBOARD