1. glk#WN's Avatar
    My sent text messages are received, however, I am not receiving any incoming text messages. I spoke with Verizon and their solution is to send me a new Storm. That is all well and good but Im screwed until the phone arrives.
    I have done battery pulls but that has not corrected the problem.
    I am able to access the net, make phone calls, send/receive emails and use BB messenger.
    Any ideas?
    02-22-09 03:31 PM
  2. kokuryuha's Avatar
    Maybe try resending the service books? Email settings > bb menu > service books > resend service books.
    02-22-09 03:44 PM
  3. glk#WN's Avatar
    Thanks for the suggestion but I tried that as well and still no go.
    02-22-09 04:02 PM
  4. kokuryuha's Avatar
    Hmm oddity. Well, unless they messed up something on your account, it may be the phone. How long have you had your phone for? And did you notice anything around the time it started?
    02-22-09 04:10 PM
  5. kokuryuha's Avatar
    While I doubt you did anything to change this, and unless you're on BES probably nothing, but just check real fast. Options > security > Firewall . Is it disabled or set to block anything?
    02-22-09 04:11 PM
  6. glk#WN's Avatar
    I have had the phone since its release but I stopped using it about a month ago and started using a curve. I was growing a little sick of the curves screen so I decided to reactivate the storm today.
    I never had a problem with sending or receiving texts on this phone prior to going to the curve.
    The firewall is disabled and nothing is checked but good call.
    02-22-09 04:13 PM
  7. kokuryuha's Avatar
    Was the Curve powered off before you programmed the Storm? If not make sure it is and try another *22899 on it to reprogram. I've had very rare instances where leaving an old device on will interfere with activating a new one. Otherwise, I'd actually say it's a problem on the account level, not the phone. I've had cases where phone changes have led to issues where the account doesn't switch over quite right.
    02-22-09 04:18 PM
  8. AisforAustin's Avatar
    maybe no one is sending you messages. lol jk
    02-22-09 04:26 PM
  9. glk#WN's Avatar
    I believe I had the Curve powered off but I could be wrong.
    I just did a *22899 and it doesnt appear that anything has changed.
    One other thing, is there supposed to be a SMS shortcut on the phone?
    I only have a messages icon and an icon for each of my email accounts.
    When I am sending a text it is not leaving a copy of the sent text in the message box.
    BTW thanks for all of your suggestions kokuryuha.
    Your right Mac!! and thats why Im sending myself messages.
    But in all seriousness, I have had my gf text me and I dont receive it but she receives my text.
    02-22-09 04:27 PM
  10. kokuryuha's Avatar
    No problem. The SMS/MMS shortcut is theme controlled. Open up your Messages Folder, go to BB Menu > Options > General Options > Change SMS and Email Inboxes to Seperate if you want it to default to two different boxes all the time. Otherwise it's up to the theme programmer. If you have the default theme on and it set to Theme Controlled, it should appear. If it doesn't show up there may be an issue. If it does, what does it say? Just SMS or SMS and MMS?
    02-22-09 04:30 PM
  11. MPSmith1's Avatar
    One other thing, is there supposed to be a SMS shortcut on the phone?
    I only have a messages icon and an icon for each of my email accounts.
    I copied this from the Appleberry FAQ. I hope it helps...

    "I lost my SMS icon! This is a common "issue" whenever you install a new theme. On your Application Menu, click on "Messages" (or any email account), and press the BB hardware key. Select "Options", then "General Options". Under "SMS and Email Inboxes" select "Separate" from the drop down menu. Save your settings, and when you check your Application Screen you'll now have a separate SMS icon."

    Edit: oops... kokuryuha beat me to it...
    Last edited by MPSmith1; 02-22-09 at 04:35 PM. Reason: kokuryuha is faster than me...
    02-22-09 04:34 PM
  12. glk#WN's Avatar
    When I go to view folder, sms folder I am getting;
    Uncaught exception:
    java.lang.NULLPOINTERException
    02-22-09 04:38 PM
  13. kokuryuha's Avatar
    What 3rd party apps do you have installed? Also have you done a backup or a restore recently?
    02-22-09 04:42 PM
  14. glk#WN's Avatar
    I have Vy mail and talk lock installed.
    The last time I did a backup and restore was probably a month ago while I was still using the phone and was tinkering with some beta os before going back to the official Verizon os.
    I can view the sms outbox which shows copies of my delivered text messages but I get an error while trying to view the sms inbox.
    Last edited by glock115; 02-22-09 at 04:49 PM.
    02-22-09 04:47 PM
  15. kokuryuha's Avatar
    Alright, I'm going to guess that you MAY have a corrupted SMS box. Do you know how to do a selective restore? You could use an older backup (not the one from a month ago) to restore the SMS box. Or clear the SMS database from the DM. If you're not familiar with that I can try to remember how to do it. I'm not at a PC that has DM as I'm at work, but I could probably give you a general idea.
    02-22-09 04:54 PM
  16. glk#WN's Avatar
    I deleted desktop manager for the Storm when I got the curve and downloaded the software for the Curve, am I screwed?
    02-22-09 04:58 PM
  17. kokuryuha's Avatar
    No, fact you may be able to do it with the Curve one. Otherwise you could go to BlackBerry® Software Updates and click on the Desktop Software link. Should let you download 4.7 again.
    02-22-09 04:59 PM
  18. SFXBrandon's Avatar
    When I know that I am not receiving text messages, I just call *68 to initiate a connection.

    This forces the phone to receive my text messages. I don't know why I have to do this.

    Ive received messages that should have been received hours ago doing that. Anyone know why this is?
    02-22-09 05:01 PM
  19. glk#WN's Avatar
    By default where would my backups be saved?
    Disregard, I found it.
    02-22-09 05:08 PM
  20. glk#WN's Avatar
    I found the backups but have no clue how to do a selective restore.
    02-22-09 05:12 PM
  21. kokuryuha's Avatar
    Go to the backup/restore section of DM, on the right hand side there should be an advanced option. Not sure if it says backup/restore selective, but it's definitely on the far right.

    Click on that.

    You should end up with a screen that shows the Desktop databases on the left, and the phone databases on the right. now in the top left there's a drop down menu that should let you select a backup file. Pick one that's older than the last backup you did (before teh database got corrupted).

    You should now have a list of databases from the backup file on the left. Look for the SMS database (not sure if there is one, if there isn't you may have to just restore the messages database in general) it's been awhile since I've done it selectively. Click on that and near the bottom middle there should be arrows that let you move that over to the phone.

    edit: after the sms database is restored, check your phone to see if you have access to your received messages again. If not, try an older backup til you do. The other option you have is to just click on the phone's SMS database, and just delete it. You will lose all your texts on the phone though, just so you're aware. After you get to the point where you can access the database, try doing test text messages.
    Last edited by kokuryuha; 02-22-09 at 05:17 PM.
    02-22-09 05:15 PM
  22. glk#WN's Avatar
    Whichever mms options which I drag over from the backup to the device do not appear to transfer over. I get a message that data is being transferred over but once the storm refreshes it returns to the state it was before and doesnt appear to accept the backup data.
    SMS Messages is grey and Im unable to choose it to carry it over from the back up.
    I do not notice sms messages as an option on the device database
    Last edited by glock115; 02-22-09 at 05:38 PM.
    02-22-09 05:33 PM
  23. kokuryuha's Avatar
    Sounds like the sms database might be corrupt in that backup. Have you tried an older backup?
    02-22-09 06:10 PM
  24. glk#WN's Avatar
    I'm throwing in the towel and going back to my curve until my new storm arrives. Thanks again for all your help.
    02-22-09 07:03 PM
  25. kokuryuha's Avatar
    hmm well if you still want help i will be home in a few hours from work and i can give you a step by step.
    02-22-09 07:13 PM
LINK TO POST COPIED TO CLIPBOARD