1. 1up_on_you's Avatar
    i just upgraded to .113 a week ago and in the last couple days ive had this problem where my phone thinks i have the tty blackberry headphones plugged in and i cant hear anything through the speaker or the regular handset when i make a call unless i have headphones plugged in. i can activate the headset and speaker if i go to play some music and hit the bb button and select activate headset/speaker. any one have any ideas how to fix this? oh and yes i tried plugging in my headphones while on a call but all that does is put the phone on mute
    03-29-09 03:31 PM
  2. MrWashy's Avatar
    Two suggestions, both of which have worked for me:
    1. Plug in earphones, and play a song. Stop the playback, exit media player and remove earplugs.

    2. Plug in and remove the earphones several times.

    Either of those should get the sound back.
    03-29-09 04:14 PM
  3. jhodge31's Avatar
    I am also having this problem as 1up. I attempted both of MrWashy's suggestions and neither worked. I also reset (battery pulls) the phone several times and played around with as many options as I could find. I'm kind of at a loss. I feel like it might be a hardware problem at this point. I will upgrade the OS to see if that helps (I'm using .103) but I'd like to avoid that since I the phone is working perfect for me, it takes forever and might not ultimately solve my problem. Any other suggestions would be awesome. Thank you for your help.
    04-02-09 05:26 PM
  4. Valace2's Avatar
    I think that this may be a problem with .113 because I had it as well. There is a thread around somewhere that talks about it. I just pushed the end of a pen cap into the headphone jack. It was to wide for the hole but wonder of wonders it did the trick. Can't really explain why that happens though.
    04-02-09 06:16 PM
  5. spo's Avatar
    Had similar issue w/ my Curve 8900. Speaker was clicking on and off. Found this thread and tried it with success! Thanks!
    04-04-09 04:45 PM
  6. Sosai X's Avatar
    I had the same problem after upgrading to .113. Just plug your headphones into the jack and make a call - then unplug and plug back in repeatedly until you get it to "unstick" from headset mode.

    Trust me, it works.
    04-04-09 08:06 PM
  7. tghockey07's Avatar
    Its not just .113 it does it for me too in regular .114.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-04-09 11:49 PM
  8. Ontittech's Avatar
    I had the same issue in .114 as well. I resolved it by plugging the headphones in while playing music and then unplugged and it worked again.

    Unfortunately the Headphone settings override the bluetooth so even having a bluetooth headset active doesn't make a difference.

    I think it is something that was introduced in .113/.114 unless someone who is using .76 can confirm the same issue, then we can head in the direction of hardware issue with the headphone jacks.
    04-05-09 08:21 PM
  9. FDOxygen's Avatar
    Here's a simple trick to fix that issue...
    Call your voicemail and when the call is initiated plug in your headphone, then while the call is still open unplug your headphones this will revert your phone from headset to handset.
    05-30-09 07:25 PM
LINK TO POST COPIED TO CLIPBOARD